Loading ...
Sorry, an error occurred while loading the content.

Re: Rgrep not working on vim 64-bit, win7

Expand Messages
  • Yegappan Lakshmanan
    Hi, ... The approach that works and used by the taglist plugin is to write the command line into a temporary .cmd file and execute it. The grep plugin also
    Message 1 of 19 , Apr 23, 2013
    • 0 Attachment
      Hi,


      On Tue, Apr 23, 2013 at 6:58 AM, Dariusz Gadomski <dgadomski@...> wrote:
      >
      > Hi
      >
      > On Mon, Apr 15, 2013 at 6:07 PM, Yegappan Lakshmanan
      > <yegappanl@...> wrote:
      > >
      > >
      > > This problem is caused by the shell command line quote escape
      > > character in MS-Windows.
      > > I have a fix for this issue. I will update the grep plugin and release
      > > a new version.
      > >
      > > - Yegappan
      >
      > I was trying to analyze this problem further and what I found out that
      > actually vim calls something like this underneath:
      > cmd /c (C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN ) -prune
      > -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n -- TODO {} ;)
      >
      > When I tried to paste it directly to cmd.exe I got:
      > -prune was unexpected at this time.
      > So no std output was generated and the process terminated with an error
      > on stderr - hence no tmp file created.
      > I think those brackets around cmd /c call conflict with brackets that make
      > a part of find call itself. When I replace the outer brackets with quotation
      > marks:
      > cmd /c "C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN )
      > -prune -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n --
      > TODO {} ;"
      > I get no error and expected output is printed.
      >
      > So my guess is either:
      > - a different method is needed in the find call to group the conditions
      > (does find even allow a different way of grouping?) or
      > - inner brackets need somehow be escaped in the call or
      > - vim system() call needs to be fixed to handle brackets in the argument string.
      >
      > Maybe is there another way to fix it or at least provide a temporary
      > work-around?
      >
      > I would appreciate any hints that would enable me to use Rgrep until this
      > problem gets fixed.
      >

      The approach that works and used by the taglist plugin is to write the
      command line
      into a temporary .cmd file and execute it. The grep plugin also will use this
      approach.

      - Yegappan

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Yegappan Lakshmanan
      Hi, On Tue, Apr 23, 2013 at 6:00 PM, Yegappan Lakshmanan ... I have uploaded a new version of the grep plugin to the Vim online website. You can try using the
      Message 2 of 19 , Apr 23, 2013
      • 0 Attachment
        Hi,

        On Tue, Apr 23, 2013 at 6:00 PM, Yegappan Lakshmanan
        <yegappanl@...> wrote:
        >> >
        >> > This problem is caused by the shell command line quote escape
        >> > character in MS-Windows.
        >> > I have a fix for this issue. I will update the grep plugin and release
        >> > a new version.
        >> >
        >> > - Yegappan
        >>
        >> I was trying to analyze this problem further and what I found out that
        >> actually vim calls something like this underneath:
        >> cmd /c (C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN ) -prune
        >> -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n -- TODO {} ;)
        >>
        >> When I tried to paste it directly to cmd.exe I got:
        >> -prune was unexpected at this time.
        >> So no std output was generated and the process terminated with an error
        >> on stderr - hence no tmp file created.
        >> I think those brackets around cmd /c call conflict with brackets that make
        >> a part of find call itself. When I replace the outer brackets with quotation
        >> marks:
        >> cmd /c "C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN )
        >> -prune -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n --
        >> TODO {} ;"
        >> I get no error and expected output is printed.
        >>
        >> So my guess is either:
        >> - a different method is needed in the find call to group the conditions
        >> (does find even allow a different way of grouping?) or
        >> - inner brackets need somehow be escaped in the call or
        >> - vim system() call needs to be fixed to handle brackets in the argument string.
        >>
        >> Maybe is there another way to fix it or at least provide a temporary
        >> work-around?
        >>
        >> I would appreciate any hints that would enable me to use Rgrep until this
        >> problem gets fixed.
        >>
        >
        > The approach that works and used by the taglist plugin is to write the
        > command line
        > into a temporary .cmd file and execute it. The grep plugin also will use this
        > approach.
        >

        I have uploaded a new version of the grep plugin to the Vim online website.
        You can try using the new version and let me know if you see any issues.

        - Yegappan

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Dariusz Gadomski
        Hi On Wed, Apr 24, 2013 at 7:28 AM, Yegappan Lakshmanan ... Great, the new version returns no error. Thanks! However, the Quickfix list contains no filenames,
        Message 3 of 19 , Apr 23, 2013
        • 0 Attachment
          Hi

          On Wed, Apr 24, 2013 at 7:28 AM, Yegappan Lakshmanan
          <yegappanl@...> wrote:
          > Hi,
          >
          > On Tue, Apr 23, 2013 at 6:00 PM, Yegappan Lakshmanan
          > <yegappanl@...> wrote:
          >>> >
          >>> > This problem is caused by the shell command line quote escape
          >>> > character in MS-Windows.
          >>> > I have a fix for this issue. I will update the grep plugin and release
          >>> > a new version.
          >>> >
          >>> > - Yegappan
          >>>
          >>> I was trying to analyze this problem further and what I found out that
          >>> actually vim calls something like this underneath:
          >>> cmd /c (C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN ) -prune
          >>> -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n -- TODO {} ;)
          >>>
          >>> When I tried to paste it directly to cmd.exe I got:
          >>> -prune was unexpected at this time.
          >>> So no std output was generated and the process terminated with an error
          >>> on stderr - hence no tmp file created.
          >>> I think those brackets around cmd /c call conflict with brackets that make
          >>> a part of find call itself. When I replace the outer brackets with quotation
          >>> marks:
          >>> cmd /c "C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN )
          >>> -prune -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n --
          >>> TODO {} ;"
          >>> I get no error and expected output is printed.
          >>>
          >>> So my guess is either:
          >>> - a different method is needed in the find call to group the conditions
          >>> (does find even allow a different way of grouping?) or
          >>> - inner brackets need somehow be escaped in the call or
          >>> - vim system() call needs to be fixed to handle brackets in the argument string.
          >>>
          >>> Maybe is there another way to fix it or at least provide a temporary
          >>> work-around?
          >>>
          >>> I would appreciate any hints that would enable me to use Rgrep until this
          >>> problem gets fixed.
          >>>
          >>
          >> The approach that works and used by the taglist plugin is to write the
          >> command line
          >> into a temporary .cmd file and execute it. The grep plugin also will use this
          >> approach.
          >>
          >
          > I have uploaded a new version of the grep plugin to the Vim online website.
          > You can try using the new version and let me know if you see any issues.
          >

          Great, the new version returns no error. Thanks!

          However, the Quickfix list contains no filenames, only line numbers, so it's
          impossible to jump directly from the quicklist to the place that grep found.
          Is there a "-H" flag missing to grep or does the msys version of grep behave
          differently?

          I observe one more strange thing. If I run:
          :Rgrep TODO
          and give the directory to search and file extensions in subsequent prompts
          it all works flawlessly, but if I run:
          :Rgrep TODO *.cpp
          the find command is expanded to:
          (...) -type f ( -name -o -name *.cpp ) (...)
          and returns no results. Providing more than one extension:
          :Rgrep TODO *.cpp *.h
          results with expanding to:
          (...) -type f ( -name -o -name *.cpp -name *.h ) (...)
          which still provides no results.

          Is that behavior expected or is giving file extensions inline not supported?

          Thanks,
          Darek

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Dariusz Gadomski
          Hi ... I have tried .761 and the yesterdays version from hg (reported as .905). I guess the shellquote valeus are ok since the fix in new grep.vim does the
          Message 4 of 19 , Apr 23, 2013
          • 0 Attachment
            Hi

            On Tue, Apr 23, 2013 at 5:14 PM, Ben Fritz <fritzophrenic@...> wrote:
            > On Tuesday, April 23, 2013 8:58:20 AM UTC-5, Darek wrote:
            >> Hi
            >>
            >>
            >>
            >> On Mon, Apr 15, 2013 at 6:07 PM, Yegappan Lakshmanan
            >>
            >> <yegappanl@...> wrote:
            >>
            >> >
            >>
            >> >
            >>
            >> > This problem is caused by the shell command line quote escape
            >>
            >> > character in MS-Windows.
            >>
            >> > I have a fix for this issue. I will update the grep plugin and release
            >>
            >> > a new version.
            >>
            >> >
            >>
            >> > - Yegappan
            >>
            >>
            >>
            >> I was trying to analyze this problem further and what I found out that
            >>
            >> actually vim calls something like this underneath:
            >>
            >> cmd /c (C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN ) -prune
            >>
            >> -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n -- TODO {} ;)
            >>
            >>
            >>
            >> When I tried to paste it directly to cmd.exe I got:
            >>
            >> -prune was unexpected at this time.
            >>
            >> So no std output was generated and the process terminated with an error
            >>
            >> on stderr - hence no tmp file created.
            >>
            >> I think those brackets around cmd /c call conflict with brackets that make
            >>
            >> a part of find call itself. When I replace the outer brackets with quotation
            >>
            >> marks:
            >>
            >> cmd /c "C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN )
            >>
            >> -prune -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n --
            >>
            >> TODO {} ;"
            >>
            >> I get no error and expected output is printed.
            >>
            >>
            >>
            >> So my guess is either:
            >>
            >> - a different method is needed in the find call to group the conditions
            >>
            >> (does find even allow a different way of grouping?) or
            >>
            >> - inner brackets need somehow be escaped in the call or
            >>
            >> - vim system() call needs to be fixed to handle brackets in the argument string.
            >>
            >>
            >>
            >> Maybe is there another way to fix it or at least provide a temporary
            >>
            >> work-around?
            >>
            >>
            >>
            >> I would appreciate any hints that would enable me to use Rgrep until this
            >>
            >> problem gets fixed.
            >>
            >
            > There were several 7.3 patches in a row (I think in the 400s) handling default shell escaping in Windows. I don't see your Vim version in this thread, do you have those?
            >
            > If so, what values do you have for the following options?
            >
            > 'shellxquote' (should usually be ( or "()
            > 'shellquote' (should be empty)
            > 'shellslash' (causes problems with shellescape() function when set)
            > 'shellxescape' (should contain ( and ))
            > 'shell' (should be cmd.exe or full path to it)
            > 'shellcmdflag' (should be "/c" or "/c /s" or similar)
            >
            > I remember parentheses being problematic, but I thought that problem was solved.
            >
            > See http://vim.wikia.com/wiki/Execute_external_programs_asynchronously_under_Windows#Some_notes_on_cmd.exe_quoting which also has links to the vim_dev discussions on the patches.
            >
            > If all your options look to be in order, you might be able to manually escape the () characters with '^' but I didn't think you needed to. You might also try "( instead of just ( as a shellxquote value. If neither of those work you can try " but I *know* that has problems in some common situations, which is why ( and "( were introduced.
            >

            I have tried .761 and the yesterdays version from hg (reported as
            .905). I guess the shellquote valeus are ok since the fix in new
            grep.vim does the job.

            Thanks,
            Darek

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Ben Fritz
            ... It sounds like the issue is fixed for this plugin at least. But it sounded like Yegappan was going to bypass the shellquote settings entirely by writing to
            Message 5 of 19 , Apr 24, 2013
            • 0 Attachment
              On Wednesday, April 24, 2013 1:55:57 AM UTC-5, Darek wrote:
              > Hi
              >
              >
              >
              > On Tue, Apr 23, 2013 at 5:14 PM, Ben Fritz <fritzophrenic@...> wrote:
              >
              > > On Tuesday, April 23, 2013 8:58:20 AM UTC-5, Darek wrote:
              >
              > >> Hi
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> On Mon, Apr 15, 2013 at 6:07 PM, Yegappan Lakshmanan
              >
              > >>
              >
              > >> <yegappanl@...> wrote:
              >
              > >>
              >
              > >> >
              >
              > >>
              >
              > >> >
              >
              > >>
              >
              > >> > This problem is caused by the shell command line quote escape
              >
              > >>
              >
              > >> > character in MS-Windows.
              >
              > >>
              >
              > >> > I have a fix for this issue. I will update the grep plugin and release
              >
              > >>
              >
              > >> > a new version.
              >
              > >>
              >
              > >> >
              >
              > >>
              >
              > >> > - Yegappan
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> I was trying to analyze this problem further and what I found out that
              >
              > >>
              >
              > >> actually vim calls something like this underneath:
              >
              > >>
              >
              > >> cmd /c (C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN ) -prune
              >
              > >>
              >
              > >> -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n -- TODO {} ;)
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> When I tried to paste it directly to cmd.exe I got:
              >
              > >>
              >
              > >> -prune was unexpected at this time.
              >
              > >>
              >
              > >> So no std output was generated and the process terminated with an error
              >
              > >>
              >
              > >> on stderr - hence no tmp file created.
              >
              > >>
              >
              > >> I think those brackets around cmd /c call conflict with brackets that make
              >
              > >>
              >
              > >> a part of find call itself. When I replace the outer brackets with quotation
              >
              > >>
              >
              > >> marks:
              >
              > >>
              >
              > >> cmd /c "C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN )
              >
              > >>
              >
              > >> -prune -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n --
              >
              > >>
              >
              > >> TODO {} ;"
              >
              > >>
              >
              > >> I get no error and expected output is printed.
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> So my guess is either:
              >
              > >>
              >
              > >> - a different method is needed in the find call to group the conditions
              >
              > >>
              >
              > >> (does find even allow a different way of grouping?) or
              >
              > >>
              >
              > >> - inner brackets need somehow be escaped in the call or
              >
              > >>
              >
              > >> - vim system() call needs to be fixed to handle brackets in the argument string.
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> Maybe is there another way to fix it or at least provide a temporary
              >
              > >>
              >
              > >> work-around?
              >
              > >>
              >
              > >>
              >
              > >>
              >
              > >> I would appreciate any hints that would enable me to use Rgrep until this
              >
              > >>
              >
              > >> problem gets fixed.
              >
              > >>
              >
              > >
              >
              > > There were several 7.3 patches in a row (I think in the 400s) handling default shell escaping in Windows. I don't see your Vim version in this thread, do you have those?
              >
              > >
              >
              > > If so, what values do you have for the following options?
              >
              > >
              >
              > > 'shellxquote' (should usually be ( or "()
              >
              > > 'shellquote' (should be empty)
              >
              > > 'shellslash' (causes problems with shellescape() function when set)
              >
              > > 'shellxescape' (should contain ( and ))
              >
              > > 'shell' (should be cmd.exe or full path to it)
              >
              > > 'shellcmdflag' (should be "/c" or "/c /s" or similar)
              >
              > >
              >
              > > I remember parentheses being problematic, but I thought that problem was solved.
              >
              > >
              >
              > > See http://vim.wikia.com/wiki/Execute_external_programs_asynchronously_under_Windows#Some_notes_on_cmd.exe_quoting which also has links to the vim_dev discussions on the patches.
              >
              > >
              >
              > > If all your options look to be in order, you might be able to manually escape the () characters with '^' but I didn't think you needed to. You might also try "( instead of just ( as a shellxquote value. If neither of those work you can try " but I *know* that has problems in some common situations, which is why ( and "( were introduced.
              >
              > >
              >
              >
              >
              > I have tried .761 and the yesterdays version from hg (reported as
              >
              > .905). I guess the shellquote valeus are ok since the fix in new
              >
              > grep.vim does the job.
              >
              >

              It sounds like the issue is fixed for this plugin at least. But it sounded like Yegappan was going to bypass the shellquote settings entirely by writing to a script file and running it instead of running the command directly.

              If you don't have any further problems it's certainly not worth fighting with Windows cmd.exe.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Yegappan Lakshmanan
              Hi, ... The problem in using the :Rgrep is fixed with the latest version (1.11) of the Vim plugin. - Yegappan -- -- You received this
              Message 6 of 19 , Apr 28, 2013
              • 0 Attachment
                Hi,

                On Tue, Apr 23, 2013 at 11:52 PM, Dariusz Gadomski <dgadomski@...> wrote:
                >>>> >
                >>>> > This problem is caused by the shell command line quote escape
                >>>> > character in MS-Windows.
                >>>> > I have a fix for this issue. I will update the grep plugin and release
                >>>> > a new version.
                >>>> >
                >>>> > - Yegappan
                >>>>
                >>>> I was trying to analyze this problem further and what I found out that
                >>>> actually vim calls something like this underneath:
                >>>> cmd /c (C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN ) -prune
                >>>> -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n -- TODO {} ;)
                >>>>
                >>>> When I tried to paste it directly to cmd.exe I got:
                >>>> -prune was unexpected at this time.
                >>>> So no std output was generated and the process terminated with an error
                >>>> on stderr - hence no tmp file created.
                >>>> I think those brackets around cmd /c call conflict with brackets that make
                >>>> a part of find call itself. When I replace the outer brackets with quotation
                >>>> marks:
                >>>> cmd /c "C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN )
                >>>> -prune -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n --
                >>>> TODO {} ;"
                >>>> I get no error and expected output is printed.
                >>>>
                >>>> So my guess is either:
                >>>> - a different method is needed in the find call to group the conditions
                >>>> (does find even allow a different way of grouping?) or
                >>>> - inner brackets need somehow be escaped in the call or
                >>>> - vim system() call needs to be fixed to handle brackets in the argument string.
                >>>>
                >>>> Maybe is there another way to fix it or at least provide a temporary
                >>>> work-around?
                >>>>
                >>>> I would appreciate any hints that would enable me to use Rgrep until this
                >>>> problem gets fixed.
                >>>>
                >>>
                >>> The approach that works and used by the taglist plugin is to write the
                >>> command line
                >>> into a temporary .cmd file and execute it. The grep plugin also will use this
                >>> approach.
                >>>
                >>
                >> I have uploaded a new version of the grep plugin to the Vim online website.
                >> You can try using the new version and let me know if you see any issues.
                >>
                >
                > Great, the new version returns no error. Thanks!
                >
                > However, the Quickfix list contains no filenames, only line numbers, so it's
                > impossible to jump directly from the quicklist to the place that grep found.
                > Is there a "-H" flag missing to grep or does the msys version of grep behave
                > differently?
                >
                > I observe one more strange thing. If I run:
                > :Rgrep TODO
                > and give the directory to search and file extensions in subsequent prompts
                > it all works flawlessly, but if I run:
                > :Rgrep TODO *.cpp
                > the find command is expanded to:
                > (...) -type f ( -name -o -name *.cpp ) (...)
                > and returns no results. Providing more than one extension:
                > :Rgrep TODO *.cpp *.h
                > results with expanding to:
                > (...) -type f ( -name -o -name *.cpp -name *.h ) (...)
                > which still provides no results.
                >
                > Is that behavior expected or is giving file extensions inline not supported?
                >

                The problem in using the ":Rgrep <pattern> <filenames>" is fixed with the
                latest version (1.11) of the Vim plugin.

                - Yegappan

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • lazureus
                ... Hi, I m encountering some similar problems as Dariusz have seen however on the 64-bit Ubuntu. Trying to run :Rgrep from VIM I get following error message :
                Message 7 of 19 , Jan 13, 2014
                • 0 Attachment
                  W dniu niedziela, 28 kwietnia 2013 18:42:08 UTC+2 użytkownik yega...@... napisał:
                  > Hi,
                  >
                  >
                  >
                  > On Tue, Apr 23, 2013 at 11:52 PM, Dariusz Gadomski <dgadomski@...> wrote:
                  >
                  > >>>> >
                  >
                  > >>>> > This problem is caused by the shell command line quote escape
                  >
                  > >>>> > character in MS-Windows.
                  >
                  > >>>> > I have a fix for this issue. I will update the grep plugin and release
                  >
                  > >>>> > a new version.
                  >
                  > >>>> >
                  >
                  > >>>> > - Yegappan
                  >
                  > >>>>
                  >
                  > >>>> I was trying to analyze this problem further and what I found out that
                  >
                  > >>>> actually vim calls something like this underneath:
                  >
                  > >>>> cmd /c (C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN ) -prune
                  >
                  > >>>> -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n -- TODO {} ;)
                  >
                  > >>>>
                  >
                  > >>>> When I tried to paste it directly to cmd.exe I got:
                  >
                  > >>>> -prune was unexpected at this time.
                  >
                  > >>>> So no std output was generated and the process terminated with an error
                  >
                  > >>>> on stderr - hence no tmp file created.
                  >
                  > >>>> I think those brackets around cmd /c call conflict with brackets that make
                  >
                  > >>>> a part of find call itself. When I replace the outer brackets with quotation
                  >
                  > >>>> marks:
                  >
                  > >>>> cmd /c "C:\msys\bin\find.exe C:\dev\<my-project> -type d ( -name .SVN )
                  >
                  > >>>> -prune -o -type f ( -name *.cpp ) -exec c:\msys\bin\grep.exe -s -n --
                  >
                  > >>>> TODO {} ;"
                  >
                  > >>>> I get no error and expected output is printed.
                  >
                  > >>>>
                  >
                  > >>>> So my guess is either:
                  >
                  > >>>> - a different method is needed in the find call to group the conditions
                  >
                  > >>>> (does find even allow a different way of grouping?) or
                  >
                  > >>>> - inner brackets need somehow be escaped in the call or
                  >
                  > >>>> - vim system() call needs to be fixed to handle brackets in the argument string.
                  >
                  > >>>>
                  >
                  > >>>> Maybe is there another way to fix it or at least provide a temporary
                  >
                  > >>>> work-around?
                  >
                  > >>>>
                  >
                  > >>>> I would appreciate any hints that would enable me to use Rgrep until this
                  >
                  > >>>> problem gets fixed.
                  >
                  > >>>>
                  >
                  > >>>
                  >
                  > >>> The approach that works and used by the taglist plugin is to write the
                  >
                  > >>> command line
                  >
                  > >>> into a temporary .cmd file and execute it. The grep plugin also will use this
                  >
                  > >>> approach.
                  >
                  > >>>
                  >
                  > >>
                  >
                  > >> I have uploaded a new version of the grep plugin to the Vim online website.
                  >
                  > >> You can try using the new version and let me know if you see any issues.
                  >
                  > >>
                  >
                  > >
                  >
                  > > Great, the new version returns no error. Thanks!
                  >
                  > >
                  >
                  > > However, the Quickfix list contains no filenames, only line numbers, so it's
                  >
                  > > impossible to jump directly from the quicklist to the place that grep found.
                  >
                  > > Is there a "-H" flag missing to grep or does the msys version of grep behave
                  >
                  > > differently?
                  >
                  > >
                  >
                  > > I observe one more strange thing. If I run:
                  >
                  > > :Rgrep TODO
                  >
                  > > and give the directory to search and file extensions in subsequent prompts
                  >
                  > > it all works flawlessly, but if I run:
                  >
                  > > :Rgrep TODO *.cpp
                  >
                  > > the find command is expanded to:
                  >
                  > > (...) -type f ( -name -o -name *.cpp ) (...)
                  >
                  > > and returns no results. Providing more than one extension:
                  >
                  > > :Rgrep TODO *.cpp *.h
                  >
                  > > results with expanding to:
                  >
                  > > (...) -type f ( -name -o -name *.cpp -name *.h ) (...)
                  >
                  > > which still provides no results.
                  >
                  > >
                  >
                  > > Is that behavior expected or is giving file extensions inline not supported?
                  >
                  > >
                  >
                  >
                  >
                  > The problem in using the ":Rgrep <pattern> <filenames>" is fixed with the
                  >
                  > latest version (1.11) of the Vim plugin.
                  >
                  >
                  >
                  > - Yegappan

                  Hi,
                  I'm encountering some similar problems as Dariusz have seen however on the 64-bit Ubuntu. Trying to run :Rgrep from VIM I get following error message :

                  Error detected while processing function

                  <SNR>19_RunGrepRecursive..<SNR>19_RunGrepCmd:
                  line 20:
                  E484: Can't open file /tmp/vAgZSwX/0

                  As I said I use 64-bit 13.10 Ubuntu with freshly cloned grep plugin from the :

                  https://github.com/yegappan/grep

                  Plugin is cloned into the bundle directory because I use pathogen plugin. I was wonder maybe you could help me with my problem, I'd really appreciate your help.

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • John Beckett
                  ... You said it s a new version, but check the comments at the top of the .vim file. Does it say 1.11 as per Yegappan s advice? The above error can happen when
                  Message 8 of 19 , Jan 13, 2014
                  • 0 Attachment
                    lazureus wrote:
                    > I'm encountering some similar problems as Dariusz have seen
                    > however on the 64-bit Ubuntu. Trying to run :Rgrep from VIM
                    > I get following error message :
                    >
                    > Error detected while processing function
                    >
                    > <SNR>19_RunGrepRecursive..<SNR>19_RunGrepCmd:
                    > line 20:
                    > E484: Can't open file /tmp/vAgZSwX/0

                    You said it's a new version, but check the comments at the top
                    of the .vim file. Does it say 1.11 as per Yegappan's advice?

                    The above error can happen when a file name is not properly
                    escaped.

                    John


                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • lazureus
                    ... Yes I got the newest version 1.11. I ve cloned this from the GitHub and I think that this mirror is simultaneously updated with sources from the vim.org
                    Message 9 of 19 , Jan 14, 2014
                    • 0 Attachment
                      W dniu wtorek, 14 stycznia 2014 07:27:03 UTC+1 użytkownik JohnBeckett napisał:
                      > lazureus wrote:
                      >
                      > > I'm encountering some similar problems as Dariusz have seen
                      >
                      > > however on the 64-bit Ubuntu. Trying to run :Rgrep from VIM
                      >
                      > > I get following error message :
                      >
                      > >
                      >
                      > > Error detected while processing function
                      >
                      > >
                      >
                      > > <SNR>19_RunGrepRecursive..<SNR>19_RunGrepCmd:
                      >
                      > > line 20:
                      >
                      > > E484: Can't open file /tmp/vAgZSwX/0
                      >
                      >
                      >
                      > You said it's a new version, but check the comments at the top
                      >
                      > of the .vim file. Does it say 1.11 as per Yegappan's advice?
                      >
                      >
                      >
                      > The above error can happen when a file name is not properly
                      >
                      > escaped.
                      >
                      >
                      >
                      > John

                      Yes I got the newest version 1.11. I've cloned this from the GitHub and I think that this mirror is simultaneously updated with sources from the vim.org web page. To be sure I've updated all submodules in my .vim directory.

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • John Beckett
                      It looks like the wiki has had the answer since March 2013: http://vim.wikia.com/wiki/Script:311 That is linked in the top line at:
                      Message 10 of 19 , Jan 14, 2014
                      • 0 Attachment
                        It looks like the wiki has had the answer since March 2013:
                        http://vim.wikia.com/wiki/Script:311

                        That is linked in the top line at:
                        http://www.vim.org/scripts/script.php?script_id=311

                        I have not used the plugin, but what is written at the above
                        looks exactly what is needed to fix the error quoted earlier.

                        John


                        --
                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • lazureus
                        ... I found the reason of the problems, the problem was that in my .vimrc I added settings as follows: let Grep_Shell_Quoute_Char = let
                        Message 11 of 19 , Jan 14, 2014
                        • 0 Attachment
                          W dniu wtorek, 14 stycznia 2014 11:03:04 UTC+1 użytkownik JohnBeckett napisał:
                          > It looks like the wiki has had the answer since March 2013:
                          >
                          > http://vim.wikia.com/wiki/Script:311
                          >
                          >
                          >
                          > That is linked in the top line at:
                          >
                          > http://www.vim.org/scripts/script.php?script_id=311
                          >
                          >
                          >
                          > I have not used the plugin, but what is written at the above
                          >
                          > looks exactly what is needed to fix the error quoted earlier.
                          >
                          >
                          >
                          > John

                          I found the reason of the problems, the problem was that in my .vimrc I added settings as follows:

                          let Grep_Shell_Quoute_Char = "'"
                          let Grep_Shell_Escape_Char = "'"

                          This was causing that :Rgrep, right now everything is just fine. However I don't understand why it causes problems, maybe you can explain me this?

                          --
                          --
                          You received this message from the "vim_dev" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_dev" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        • Yegappan Lakshmanan
                          Hi, ... You have set both the quote and escape characters to single quote ( ). For Unix, the shell escape character should be set to backslash. The plugin sets
                          Message 12 of 19 , Jan 14, 2014
                          • 0 Attachment
                            Hi,

                            On Tue, Jan 14, 2014 at 5:17 AM, lazureus <lazureus86@...> wrote:
                            > W dniu wtorek, 14 stycznia 2014 11:03:04 UTC+1 użytkownik JohnBeckett napisał:
                            >> It looks like the wiki has had the answer since March 2013:
                            >>
                            >> http://vim.wikia.com/wiki/Script:311
                            >>
                            >> That is linked in the top line at:
                            >>
                            >> http://www.vim.org/scripts/script.php?script_id=311
                            >>
                            >> I have not used the plugin, but what is written at the above
                            >>
                            >> looks exactly what is needed to fix the error quoted earlier.
                            >>
                            >> John
                            >
                            > I found the reason of the problems, the problem was that in my .vimrc I added settings as follows:
                            >
                            > let Grep_Shell_Quoute_Char = "'"
                            > let Grep_Shell_Escape_Char = "'"
                            >
                            > This was causing that :Rgrep, right now everything is just fine. However I don't
                            > understand why it causes problems, maybe you can explain me this?
                            >

                            You have set both the quote and escape characters to single quote (').
                            For Unix, the shell escape character should be set to backslash. The plugin
                            sets these variables by default to the correct values. You don't need to change
                            this in your .vimrc file.

                            - Yegappan

                            --
                            --
                            You received this message from the "vim_dev" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_dev" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          • lazureus
                            ... I see, thanks a lot for your help, I really appreciate it. -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply
                            Message 13 of 19 , Jan 14, 2014
                            • 0 Attachment
                              W dniu wtorek, 14 stycznia 2014 17:17:57 UTC+1 użytkownik yega...@... napisał:
                              > Hi,
                              >
                              >
                              >
                              > On Tue, Jan 14, 2014 at 5:17 AM, lazureus <lazureus86@...> wrote:
                              >
                              > > W dniu wtorek, 14 stycznia 2014 11:03:04 UTC+1 użytkownik JohnBeckett napisał:
                              >
                              > >> It looks like the wiki has had the answer since March 2013:
                              >
                              > >>
                              >
                              > >> http://vim.wikia.com/wiki/Script:311
                              >
                              > >>
                              >
                              > >> That is linked in the top line at:
                              >
                              > >>
                              >
                              > >> http://www.vim.org/scripts/script.php?script_id=311
                              >
                              > >>
                              >
                              > >> I have not used the plugin, but what is written at the above
                              >
                              > >>
                              >
                              > >> looks exactly what is needed to fix the error quoted earlier.
                              >
                              > >>
                              >
                              > >> John
                              >
                              > >
                              >
                              > > I found the reason of the problems, the problem was that in my .vimrc I added settings as follows:
                              >
                              > >
                              >
                              > > let Grep_Shell_Quoute_Char = "'"
                              >
                              > > let Grep_Shell_Escape_Char = "'"
                              >
                              > >
                              >
                              > > This was causing that :Rgrep, right now everything is just fine. However I don't
                              >
                              > > understand why it causes problems, maybe you can explain me this?
                              >
                              > >
                              >
                              >
                              >
                              > You have set both the quote and escape characters to single quote (').
                              >
                              > For Unix, the shell escape character should be set to backslash. The plugin
                              >
                              > sets these variables by default to the correct values. You don't need to change
                              >
                              > this in your .vimrc file.
                              >
                              >
                              >
                              > - Yegappan

                              I see, thanks a lot for your help, I really appreciate it.

                              --
                              --
                              You received this message from the "vim_dev" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_dev" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                              For more options, visit https://groups.google.com/groups/opt_out.
                            Your message has been successfully submitted and would be delivered to recipients shortly.