Loading ...
Sorry, an error occurred while loading the content.
 

modeless-selection distorts all characters in gVim

Expand Messages
  • Dimitar DIMITROV
    Hi, Anyone knows why in gVim modeless-selection distorts all characters which makes the selection quite unreadable?   Dimitar ... GPG Key: 2048R/160C6FA8
    Message 1 of 19 , Apr 17, 2013
      Hi,

      Anyone knows why in gVim modeless-selection distorts all characters which makes the selection quite unreadable?
       
      Dimitar

      ---
      GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Ben Fritz
      ... Works fine for me on gvim 7.3.822 in Windows 7 64-bit. When I am in normal mode, and use the mouse to select some text in my buffer, the text looks
      Message 2 of 19 , Apr 17, 2013
        On Wednesday, April 17, 2013 9:23:58 AM UTC-5, Dimitar DIMITROV wrote:
        > Hi,
        >
        >
        > Anyone knows why in gVim modeless-selection distorts all characters which makes the selection quite unreadable?
        >  

        Works fine for me on gvim 7.3.822 in Windows 7 64-bit.

        When I am in normal mode, and use the mouse to select some text in my buffer, the text looks unchanged to me (aside from being highlighted).

        :set mouse? selectmode?
        mouse=a
        selectmode=mouse,key

        Can you provide more detail as to your system, configuration, and steps taken to see the problem? And maybe a screenshot too?

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Dimitar DIMITROV
        Hi Ben, what I meant is modeless selection (:h modeless) so try to select the text after using :e for instance (and before hitting or ^c of course)
        Message 3 of 19 , Apr 17, 2013
          Hi Ben,

          what I meant is modeless selection (:h modeless) so try to select the text after using :e for instance (and before hitting <esc> or ^c of course)

          Cheers

          Note: my gVim version is: 7.3.409

          Dimitar

          ---
          GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

          De : Ben Fritz <fritzophrenic@...>
          À : vim_dev@...
          Cc : Dimitar DIMITROV <mitkofr@...>
          Envoyé le : Mercredi 17 avril 2013 16h17
          Objet : Re: modeless-selection distorts all characters in gVim

          On Wednesday, April 17, 2013 9:23:58 AM UTC-5, Dimitar DIMITROV wrote:
          > Hi,
          >
          >
          > Anyone knows why in gVim modeless-selection distorts all characters which makes the selection quite unreadable?
          >  

          Works fine for me on gvim 7.3.822 in Windows 7 64-bit.

          When I am in normal mode, and use the mouse to select some text in my buffer, the text looks unchanged to me (aside from being highlighted).

          :set mouse? selectmode?
            mouse=a
            selectmode=mouse,key

          Can you provide more detail as to your system, configuration, and steps taken to see the problem? And maybe a screenshot too?

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.




          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • Ben Fritz
          ... Thanks for the clarification. I tried selecting text with the mouse after typing :e abcäáô.txt but before pressing . I still see nothing wrong in
          Message 4 of 19 , Apr 17, 2013
            > On Wednesday, April 17, 2013 10:47:00 AM UTC-5, Dimitar DIMITROV wrote:
            > I wrote:
            > > On Wednesday, April 17, 2013 9:23:58 AM UTC-5, Dimitar DIMITROV wrote:
            > > > Hi,
            > > >
            > > >
            > > > Anyone knows why in gVim modeless-selection distorts all characters
            > > > which makes the selection quite unreadable?
            > > >  
            > >
            > > Works fine for me on gvim 7.3.822 in Windows 7 64-bit.
            > >
            > > When I am in normal mode, and use the mouse to select some text in my
            > > buffer, the text looks unchanged to me (aside from being highlighted).
            > >
            > > :set mouse? selectmode?
            > >   mouse=a
            > >   selectmode=mouse,key
            > >
            > > Can you provide more detail as to your system, configuration, and steps
            > > taken to see the problem? And maybe a screenshot too?
            >
            > Hi Ben,
            >
            > what I meant is modeless selection (:h modeless) so try to select the text
            > after using :e for instance (and before hitting <esc> or ^c of course)
            >
            > Cheers
            >
            > Note: my gVim version is: 7.3.409
            >

            Thanks for the clarification.

            I tried selecting text with the mouse after typing :e abcäáô.txt but before
            pressing <Enter>.

            I still see nothing wrong in gvim 7.3.822 in Windows 7 64-bit.

            What OS are you running on? In what way (exactly) do you select the text?
            Using the mouse? Can you provide a screenshot?

            See image attached to my next message for what I see.

            And please bottom-post.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Benjamin Fritz
            ... Image attached. -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are replying to. For more
            Message 5 of 19 , Apr 17, 2013
              On Wed, Apr 17, 2013 at 11:06 AM, Ben Fritz <fritzophrenic@...> wrote:
              >
              > See image attached to my next message for what I see.
              >
              > And please bottom-post.
              >

              Image attached.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Dimitar DIMITROV
              ... -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are replying to. For more information,
              Message 6 of 19 , Apr 17, 2013

                Dimitar wrote:
                >
                > On Wed, Apr 17, 2013 at 11:06 AM, Ben Fritz <fritzophrenic@...> wrote:
                > >
                > > See image attached to my next message for what I see.
                > >
                > > And please bottom-post.
                > >
                > Thanks Ben, can't see clearly your image but maybe indeed the bug was fixed in your version. Here is what I see (attached image)

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
                 
                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
                 
                 
              • Benjamin Fritz
                ... Thanks for sending the screenshot. I don t see character distortion, so I assume you re talking about the partial white background on some of the letters.
                Message 7 of 19 , Apr 18, 2013
                  On Wed, Apr 17, 2013 at 4:20 PM, Dimitar DIMITROV <mitkofr@...> wrote:
                  >
                  > Dimitar wrote:
                  >>
                  >> On Wed, Apr 17, 2013 at 11:06 AM, Ben Fritz <fritzophrenic@...>
                  >> wrote:
                  >> >
                  >> > See image attached to my next message for what I see.
                  >> >
                  >> > And please bottom-post.
                  >> >
                  >> Thanks Ben, can't see clearly your image but maybe indeed the bug was
                  >> fixed in your version. Here is what I see (attached image)
                  >

                  Thanks for sending the screenshot. I don't see character distortion,
                  so I assume you're talking about the partial white background on some
                  of the letters.

                  So, it looks to me like the following is a description of your problem:

                  1. You launched gvim 7.3.409 on ???????? operating system.
                  2. You entered :e and then stayed in command-line mode
                  3. You selected some text *in the buffer* with the mouse
                  4. You see white backgrounds under some of your black letters within
                  the selection

                  Is this a correct problem description? If so, WHAT OPERATING SYSTEM
                  ARE YOU USING? I don't see your issue still in Windows 7.

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Dimitar DIMITROV
                  ... Hi Ben, Sorry for not mentioning this. These are my OS details:          Distribution: Gentoo Base System release 2.1 Machine hardware name: x86_64
                  Message 8 of 19 , Apr 18, 2013
                    >>
                    >>>
                    >>> On Wed, Apr 17, 2013 at 11:06 AM, Ben Fritz <fritzophrenic@...>
                    >>> wrote:
                    >>> >
                    >>> > See image attached to my next message for what I see.
                    >>> >
                    >>> > And please bottom-post.
                    >>> >
                    >>> Thanks Ben, can't see clearly your image but maybe indeed the bug was
                    >>> fixed in your version. Here is what I see (attached image)
                    >>
                    >
                    >Thanks for sending the screenshot. I don't see character distortion,
                    >so I assume you're talking about the partial white background on some
                    >of the letters.
                    >
                    >So, it looks to me like the following is a description of your problem:
                    >
                    >1. You launched gvim 7.3.409 on ???????? operating
                    system.
                    >2. You entered :e and then stayed in command-line mode
                    >3. You selected some text *in the buffer* with the mouse
                    >4. You see white backgrounds under some of your black letters within
                    >the selection
                    >
                    >Is this a correct problem description? If so, WHAT OPERATING SYSTEM
                    >ARE YOU USING? I don't see your issue still in Windows 7.

                    Hi Ben,

                    Sorry for not mentioning this. These are my OS details:

                             Distribution: Gentoo Base System release 2.1
                    Machine hardware name: x86_64
                        Hardware platform: GenuineIntel
                           Processor type: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
                              Kernel name: Linux
                           Kernel release: 3.7.10-gentoo
                              Compiled on: #1 SMP Tue Apr 2 13:12:22 BST 2013
                         Operating system: GNU/Linux

                    You are also correct that this is not distortion but background coloring issues.
                    The background color was white in my screenshot but can be of any color in a
                    syntax highlighted code file. Turns out I used :e but this simply happens in
                    modeless selection and not only *in the buffer* but anywhere, command line
                    included.

                    Regards

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                     
                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                     
                     
                  • Ben Fritz
                    ... I ve now reproduced the problem in gvim 7.3.600 on Kubuntu Precise. It seems Windows is unaffected. I have no idea what might cause this however. Attached
                    Message 9 of 19 , Apr 20, 2013
                      > >Thanks for sending the screenshot. I don't see character distortion,
                      > >so I assume you're talking about the partial white background on some
                      > >of the letters.
                      > >
                      > >So, it looks to me like the following is a description of your problem:
                      > >
                      > >1. You launched gvim 7.3.409 on ???????? operating
                      > system.
                      > >2. You entered :e and then stayed in command-line mode
                      > >3. You selected some text *in the buffer* with the mouse
                      > >4. You see white backgrounds under some of your black letters within
                      > >the selection
                      > >
                      > >Is this a correct problem description? If so, WHAT OPERATING SYSTEM
                      > >ARE YOU USING? I don't see your issue still in Windows 7.
                      >
                      > Hi Ben,
                      >
                      > Sorry for not mentioning this. These are my OS details:
                      >
                      >          Distribution: Gentoo Base System release 2.1
                      > Machine hardware name: x86_64
                      >     Hardware platform: GenuineIntel
                      >        Processor type: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
                      >           Kernel name: Linux
                      >        Kernel release: 3.7.10-gentoo
                      >           Compiled on: #1 SMP
                      > Tue Apr 2 13:12:22 BST 2013
                      >      Operating system: GNU/Linux
                      >
                      > You are also correct that this is not distortion but background coloring issues.
                      > The background color was white in my screenshot but can be of any color in a
                      > syntax highlighted code file. Turns out I used :e but this simply happens in
                      > modeless selection and not only *in the buffer* but anywhere, command line
                      > included.
                      >

                      I've now reproduced the problem in gvim 7.3.600 on Kubuntu Precise. It seems Windows is unaffected. I have no idea what might cause this however.

                      Attached before/after screenshots. My colorscheme is a bit more colorful, I can now see why you said "distorted" originally.

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Ben Fritz
                      ... I should probably include this, since it seems to be a GUI font rendering issue: VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Jul 13 2012 00:11:38)
                      Message 10 of 19 , Apr 20, 2013
                        On Saturday, April 20, 2013 11:53:58 AM UTC-5, Ben Fritz wrote:
                        >
                        > I've now reproduced the problem in gvim 7.3.600 on Kubuntu Precise. It seems Windows is unaffected. I have no idea what might cause this however.
                        >
                        >
                        >
                        > Attached before/after screenshots. My colorscheme is a bit more colorful, I can now see why you said "distorted" originally.

                        I should probably include this, since it seems to be a GUI font rendering issue:




                        VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Jul 13 2012 00:11:38)
                        Included patches: 1-600
                        Compiled by ben
                        Huge version with GTK2 GUI. Features included (+) or not (-):
                        +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl
                        +cmdline_hist +cmdline_info +comments +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff +digraphs
                        +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path +float +folding -footer +fork()
                        +gettext -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap
                        -lua +menu +mksession +modify_fname +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm -mouse_sysmouse
                        +mouse_xterm +mouse_urxvt +multi_byte +multi_lang -mzscheme +netbeans_intg +path_extra +perl/dyn +persistent_undo
                        +postscript +printer +profile +python/dyn -python3 +quickfix +reltime +rightleft -ruby +scrollbind +signs +smartindent
                        -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white -tcl +terminfo
                        +termresponse +textobjects +title +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo +vreplace
                        +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
                        system vimrc file: "$VIM/vimrc"
                        user vimrc file: "$HOME/.vimrc"
                        user exrc file: "$HOME/.exrc"
                        system gvimrc file: "$VIM/gvimrc"
                        user gvimrc file: "$HOME/.gvimrc"
                        system menu file: "$VIMRUNTIME/menu.vim"
                        fall-back for $VIM: "/usr/local/share/vim"
                        Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread -I/usr/include/gtk-2.0 -I/usr/lib/i386-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/local/include -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
                        Linking: gcc -Wl,-E -L/usr/local/lib -Wl,--as-needed -o vim -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm -ltinfo -lnsl -lselinux -lacl -lattr -lgpm -ldl -Wl,-E -fstack-protector -L/usr/local/lib -L/usr/lib/perl/5.14/CORE -lperl -ldl -lm -lpthread -lcrypt

                        --
                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Dimitar DIMITROV
                        And here is my version of gVim ... VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Nov 13 2012 20:47:10) Included patches: 1-409 Modified by Gentoo-7.3.409
                        Message 11 of 19 , Apr 20, 2013
                          And here is my version of gVim

                          :ve
                          VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Nov 13 2012 20:47:10)
                          Included patches: 1-409
                          Modified by Gentoo-7.3.409
                          Compiled by root@winterfell
                          Huge version with GTK2-GNOME GUI.  Features included (+) or not (-):
                          +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl +cmdline_hist
                          +cmdline_info +comments +conceal +cryptv -cscope +cursorbind +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags
                          +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path +float +folding -footer +fork() +gettext -hangul_input +iconv
                          +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap -lua +menu +mksession +modify_fname
                          +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm -mouse_sysmouse +mouse_xterm +mouse_urxvt +multi_byte
                          +multi_lang -mzscheme -netbeans_intg +path_extra -perl +persistent_undo +postscript +printer +profile +python -python3 +quickfix
                          +reltime +rightleft -ruby +scrollbind +signs +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary
                          +tag_old_static -tag_any_white -tcl +terminfo +termresponse +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
                          +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim +xsmp_interact
                          +xterm_clipboard -xterm_save
                             system vimrc file: "/etc/vim/vimrc"
                               user vimrc file: "$HOME/.vimrc"
                                user exrc file: "$HOME/.exrc"
                            system gvimrc file: "/etc/vim/gvimrc"
                              user gvimrc file: "$HOME/.gvimrc"
                              system menu file: "$VIMRUNTIME/menu.vim"
                            fall-back for $VIM: "/usr/share/vim"
                          Compilation: x86_64-pc-linux-gnu-gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2
                          .0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
                          -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15 -I/usr/include/libdrm   -DORBIT
                          2=1 -pthread -D_REENTRANT -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-
                          1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/g
                          dk-pixbuf-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0 -I/usr/
                          lib64/glib-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1
                          .0 -I/usr/include/gail-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/in
                          clude/pixman-1 -I/usr/include/libpng15 -I/usr/include/libdrm     -O2 -pipe -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
                          Linking: x86_64-pc-linux-gnu-gcc   -Wl,-O1 -Wl,--as-needed -L/usr/local/lib -Wl,--as-needed -o gvim   -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0
                              -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_l
                          gpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype
                          -lfontconfig -lgconf-2 -lgthread-2.0 -lgmodule-2.0 -lrt -lgobject-2.0 -lglib-2.0   -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm
                          -lelf   -lcurses -lacl -lattr -lgpm -ldl     -L/usr/lib/python2.7/config -lpython2.7 -lpthread -ldl -lutil -lm -Xlinker -export-dynami
                          c
                           
                          Dimitar

                          ---
                          GPG Key: 2048R/160C6FA8 2012-10-11 Dimitar Dimitrov (kurkale6ka) <mitkofr@...>

                          --
                          --
                          You received this message from the "vim_dev" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                           
                          ---
                          You received this message because you are subscribed to the Google Groups "vim_dev" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                           
                           
                        • Tony Mechelynck
                          ... I can reproduce the problem (see attached screenshot) in the latest gvim on openSUSE 12.1, but not with my almost-defaut colorscheme (very similar to the
                          Message 12 of 19 , Apr 20, 2013
                            On 20/04/13 20:32, Ben Fritz wrote:
                            > On Saturday, April 20, 2013 11:53:58 AM UTC-5, Ben Fritz wrote:
                            >>
                            >> I've now reproduced the problem in gvim 7.3.600 on Kubuntu Precise. It seems Windows is unaffected. I have no idea what might cause this however.
                            >>
                            >>
                            >>
                            >> Attached before/after screenshots. My colorscheme is a bit more colorful, I can now see why you said "distorted" originally.
                            >
                            > I should probably include this, since it seems to be a GUI font rendering issue:
                            >
                            >
                            >
                            >
                            > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Jul 13 2012 00:11:38)
                            > Included patches: 1-600
                            > Compiled by ben
                            > Huge version with GTK2 GUI. Features included (+) or not (-):
                            > +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl
                            > +cmdline_hist +cmdline_info +comments +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff +digraphs
                            > +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path +float +folding -footer +fork()
                            > +gettext -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap
                            > -lua +menu +mksession +modify_fname +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm -mouse_sysmouse
                            > +mouse_xterm +mouse_urxvt +multi_byte +multi_lang -mzscheme +netbeans_intg +path_extra +perl/dyn +persistent_undo
                            > +postscript +printer +profile +python/dyn -python3 +quickfix +reltime +rightleft -ruby +scrollbind +signs +smartindent
                            > -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white -tcl +terminfo
                            > +termresponse +textobjects +title +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo +vreplace
                            > +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
                            > system vimrc file: "$VIM/vimrc"
                            > user vimrc file: "$HOME/.vimrc"
                            > user exrc file: "$HOME/.exrc"
                            > system gvimrc file: "$VIM/gvimrc"
                            > user gvimrc file: "$HOME/.gvimrc"
                            > system menu file: "$VIMRUNTIME/menu.vim"
                            > fall-back for $VIM: "/usr/local/share/vim"
                            > Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread -I/usr/include/gtk-2.0 -I/usr/lib/i386-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/local/include -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
                            > Linking: gcc -Wl,-E -L/usr/local/lib -Wl,--as-needed -o vim -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm -ltinfo -lnsl -lselinux -lacl -lattr -lgpm -ldl -Wl,-E -fstack-protector -L/usr/local/lib -L/usr/lib/perl/5.14/CORE -lperl -ldl -lm -lpthread -lcrypt
                            >
                            I can reproduce the problem (see attached screenshot) in the latest gvim
                            on openSUSE 12.1, but not with my "almost-defaut" colorscheme (very
                            similar to the default) but with the "darkblue" colorscheme.

                            Here is the output of :version:

                            VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Apr 16 2013 00:22:40)
                            Included patches: 1-905
                            Compiled by antoine.mechelynck@...
                            Huge version with GTK2-GNOME GUI. Features included (+) or not (-):
                            +arabic +cryptv +file_in_path +linebreak
                            +mouse_sgr +python +tag_binary +viminfo
                            +autocmd +cscope +find_in_path +lispindent
                            -mouse_sysmouse -python3 -tag_old_static +vreplace
                            +balloon_eval +cursorbind +float +listcmds
                            +mouse_urxvt +quickfix -tag_any_white +wildignore
                            +browse +cursorshape +folding +localmap
                            +mouse_xterm +reltime +tcl +wildmenu
                            ++builtin_terms +dialog_con_gui -footer +lua
                            +multi_byte +rightleft +terminfo +windows
                            +byte_offset +diff +fork() +menu
                            +multi_lang +ruby +termresponse +writebackup
                            +cindent +digraphs +gettext +mksession
                            -mzscheme +scrollbind +textobjects +X11
                            +clientserver +dnd -hangul_input +modify_fname
                            +netbeans_intg +signs +title -xfontset
                            +clipboard -ebcdic +iconv +mouse
                            +path_extra +smartindent +toolbar +xim
                            +cmdline_compl +emacs_tags +insert_expand +mouseshape
                            +perl -sniff +user_commands +xsmp_interact
                            +cmdline_hist +eval +jumplist +mouse_dec
                            +persistent_undo +startuptime +vertsplit +xterm_clipboard
                            +cmdline_info +ex_extra +keymap +mouse_gpm
                            +postscript +statusline +virtualedit +xterm_save
                            +comments +extra_search +langmap -mouse_jsbterm
                            +printer -sun_workshop +visual
                            +conceal +farsi +libcall +mouse_netterm
                            +profile +syntax +visualextra
                            system vimrc file: "$VIM/vimrc"
                            user vimrc file: "$HOME/.vimrc"
                            user exrc file: "$HOME/.exrc"
                            system gvimrc file: "$VIM/gvimrc"
                            user gvimrc file: "$HOME/.gvimrc"
                            system menu file: "$VIMRUNTIME/menu.vim"
                            fall-back for $VIM: "/usr/local/share/vim"
                            Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread
                            -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include
                            -I/usr/include/atk-1.0 -I/usr/include/cairo
                            -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0
                            -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include
                            -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12
                            -I/usr/include/libpng14 -pthread -DORBIT2=1 -D_REENTRANT
                            -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0
                            -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1
                            -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0
                            -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0
                            -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/gnome-vfs-2.0
                            -I/usr/lib64/gnome-vfs-2.0/include -I/usr/include/dbus-1.0
                            -I/usr/lib64/dbus-1.0/include -I/usr/include/glib-2.0
                            -I/usr/lib64/glib-2.0/include -I/usr/include/orbit-2.0
                            -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0
                            -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0
                            -I/usr/include/freetype2 -I/usr/include/atk-1.0
                            -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo
                            -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/libpng14
                            -I/usr/local/include -O2 -fno-strength-reduce -Wall
                            -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -I/usr/include
                            -D_LARGEFILE64_SOURCE=1
                            Linking: gcc -L. -rdynamic -Wl,-export-dynamic -Wl,-E
                            -Wl,-rpath,/usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE
                            -L/usr/local/lib -Wl,--as-needed -o vim -pthread -lgtk-x11-2.0
                            -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0
                            -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig
                            -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0
                            -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2
                            -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2
                            -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0
                            -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype
                            -lfontconfig -lgconf-2 -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lrt
                            -lglib-2.0 -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm
                            -lncurses -lnsl -lacl -lattr -lgpm -ldl -L/usr/lib -llua -Wl,-E
                            -Wl,-rpath,/usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE
                            -L/usr/local/lib64 -fstack-protector
                            -L/usr/lib/perl5/5.14.2/x86_64-linux-thread-multi/CORE -lperl -lm -ldl
                            -lcrypt -lpthread -L/usr/lib64/python2.7/config -lpython2.7 -lpthread
                            -ldl -lutil -lm -Xlinker -export-dynamic -L/usr/lib64 -ltcl8.5 -ldl
                            -lieee -lm -Wl,-R -Wl,/usr/lib64 -L/usr/lib64 -lruby -lrt -ldl -lcrypt
                            -lm -L/usr/lib64


                            Best regards,
                            Tony.
                            --
                            A remarkable race are the Persians;
                            They have such peculiar diversions.
                            They make love the whole day
                            In the usual way
                            And save up the nights for perversions.

                            --
                            --
                            You received this message from the "vim_dev" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_dev" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          • Tony Mechelynck
                            ... [...] It seems that the bug can only appear in colorful places where both the foreground and the background are other than black or white (or maybe even
                            Message 13 of 19 , Apr 20, 2013
                              On 21/04/13 03:11, Tony Mechelynck wrote:
                              > On 20/04/13 20:32, Ben Fritz wrote:
                              >> On Saturday, April 20, 2013 11:53:58 AM UTC-5, Ben Fritz wrote:
                              [...]

                              It seems that the bug can only appear in "colorful" places where both
                              the foreground and the background are other than black or white (or
                              maybe even grey).


                              Best regards,
                              Tony.
                              --
                              Wi n0t trei a h0liday in Sweden thi yer?
                              "Monty Python and the Holy Grail" PYTHON (MONTY)
                              PICTURES LTD

                              --
                              --
                              You received this message from the "vim_dev" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_dev" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                              For more options, visit https://groups.google.com/groups/opt_out.
                            • Tony Mechelynck
                              ... No, I was wrong. The only colour where I absolutely can t see it is on a white background (which becomes black in the modeless selection). But colorful
                              Message 14 of 19 , Apr 20, 2013
                                On 21/04/13 03:44, Tony Mechelynck wrote:
                                > On 21/04/13 03:11, Tony Mechelynck wrote:
                                >> On 20/04/13 20:32, Ben Fritz wrote:
                                >>> On Saturday, April 20, 2013 11:53:58 AM UTC-5, Ben Fritz wrote:
                                > [...]
                                >
                                > It seems that the bug can only appear in "colorful" places where both
                                > the foreground and the background are other than black or white (or
                                > maybe even grey).
                                >
                                >
                                > Best regards,
                                > Tony.

                                No, I was wrong. The only colour where I absolutely can't see it is on a
                                white background (which becomes black in the modeless selection).

                                But colorful colorschemes makes the bug easier to see.

                                Best regards,
                                Tony.
                                --
                                Passionate hatred can give meaning and purpose to an empty life.
                                -- Eric Hoffer

                                --
                                --
                                You received this message from the "vim_dev" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php

                                ---
                                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                For more options, visit https://groups.google.com/groups/opt_out.
                              • Tony Mechelynck
                                P.S. For some reason I can t produce a modeless selection at all in the Linux console (i.e. Ctrl-Alt-F3) with gpm mouse. Best regards, Tony. -- Enzymes are
                                Message 15 of 19 , Apr 20, 2013
                                  P.S. For some reason I can't produce a modeless selection at all in the
                                  Linux console (i.e. Ctrl-Alt-F3) with gpm mouse.

                                  Best regards,
                                  Tony.
                                  --
                                  Enzymes are things invented by biologists that explain things which
                                  otherwise require harder thinking.
                                  -- Jerome Lettvin

                                  --
                                  --
                                  You received this message from the "vim_dev" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php

                                  ---
                                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                  For more options, visit https://groups.google.com/groups/opt_out.
                                • Tony Mechelynck
                                  ... Hm, maybe because there is no clipboard there. Best regards, Tony. -- Blore s Razor: Given a choice between two theories, take the one which is funnier. --
                                  Message 16 of 19 , Apr 20, 2013
                                    On 21/04/13 04:00, Tony Mechelynck wrote:
                                    > P.S. For some reason I can't produce a modeless selection at all in the
                                    > Linux console (i.e. Ctrl-Alt-F3) with gpm mouse.
                                    >
                                    > Best regards,
                                    > Tony.

                                    Hm, maybe because there is no clipboard there.

                                    Best regards,
                                    Tony.
                                    --
                                    Blore's Razor:
                                    Given a choice between two theories, take the one which is
                                    funnier.

                                    --
                                    --
                                    You received this message from the "vim_dev" maillist.
                                    Do not top-post! Type your reply below the text you are replying to.
                                    For more information, visit http://www.vim.org/maillist.php

                                    ---
                                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                    For more options, visit https://groups.google.com/groups/opt_out.
                                  • Yukihiro Nakadaira
                                    It seems that the current invert drawing method (dst = fg XOR bg XOR dst) is not good for anti-aliased font. I think that using GDK_INVERT is good for it.
                                    Message 17 of 19 , May 5, 2013
                                      It seems that the current invert drawing method (dst = fg XOR bg XOR dst)
                                      is not good for anti-aliased font.  I think that using GDK_INVERT is
                                      good for it.

                                      diff -r 9e3cdd762964 src/gui_gtk_x11.c
                                      --- a/src/gui_gtk_x11.c    Sat May 04 04:40:15 2013 +0200
                                      +++ b/src/gui_gtk_x11.c    Sun May 05 16:23:33 2013 +0900
                                      @@ -5271,13 +5271,9 @@
                                           if (gui.drawarea->window == NULL)
                                           return;
                                       
                                      -    values.foreground.pixel = gui.norm_pixel ^ gui.back_pixel;
                                      -    values.background.pixel = gui.norm_pixel ^ gui.back_pixel;
                                      -    values.function = GDK_XOR;
                                      +    values.function = GDK_INVERT;
                                           invert_gc = gdk_gc_new_with_values(gui.drawarea->window,
                                                              &values,
                                      -                       GDK_GC_FOREGROUND |
                                      -                       GDK_GC_BACKGROUND |
                                                              GDK_GC_FUNCTION);
                                           gdk_gc_set_exposures(invert_gc, gui.visibility !=
                                                                  GDK_VISIBILITY_UNOBSCURED);



                                      --
                                      Yukihiro Nakadaira - yukihiro.nakadaira@...

                                      --
                                      --
                                      You received this message from the "vim_dev" maillist.
                                      Do not top-post! Type your reply below the text you are replying to.
                                      For more information, visit http://www.vim.org/maillist.php
                                       
                                      ---
                                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                      For more options, visit https://groups.google.com/groups/opt_out.
                                       
                                       
                                    • Bram Moolenaar
                                      ... Thanks for making a patch. Can some users try this out and give feedback? -- A cow comes flying over the battlements, lowing aggressively. The cow lands
                                      Message 18 of 19 , May 5, 2013
                                        Yukihiro Nakadaira wrote:

                                        > It seems that the current invert drawing method (dst = fg XOR bg XOR dst)
                                        > is not good for anti-aliased font. I think that using GDK_INVERT is
                                        > good for it.
                                        >
                                        > diff -r 9e3cdd762964 src/gui_gtk_x11.c
                                        > --- a/src/gui_gtk_x11.c Sat May 04 04:40:15 2013 +0200
                                        > +++ b/src/gui_gtk_x11.c Sun May 05 16:23:33 2013 +0900
                                        > @@ -5271,13 +5271,9 @@
                                        > if (gui.drawarea->window == NULL)
                                        > return;
                                        >
                                        > - values.foreground.pixel = gui.norm_pixel ^ gui.back_pixel;
                                        > - values.background.pixel = gui.norm_pixel ^ gui.back_pixel;
                                        > - values.function = GDK_XOR;
                                        > + values.function = GDK_INVERT;
                                        > invert_gc = gdk_gc_new_with_values(gui.drawarea->window,
                                        > &values,
                                        > - GDK_GC_FOREGROUND |
                                        > - GDK_GC_BACKGROUND |
                                        > GDK_GC_FUNCTION);
                                        > gdk_gc_set_exposures(invert_gc, gui.visibility !=
                                        > GDK_VISIBILITY_UNOBSCURED);
                                        >

                                        Thanks for making a patch.

                                        Can some users try this out and give feedback?

                                        --
                                        A cow comes flying over the battlements, lowing aggressively. The cow
                                        lands on GALAHAD'S PAGE, squashing him completely.
                                        "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

                                        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                                        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                                        \\\ an exciting new programming language -- http://www.Zimbu.org ///
                                        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                                        --
                                        --
                                        You received this message from the "vim_dev" maillist.
                                        Do not top-post! Type your reply below the text you are replying to.
                                        For more information, visit http://www.vim.org/maillist.php

                                        ---
                                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                        For more options, visit https://groups.google.com/groups/opt_out.
                                      • Ben Fritz
                                        ... I finally got a chance to try applying the patch and it seems to work as advertised. I have no idea whether it has unintended side effects. I ll run with
                                        Message 19 of 19 , May 19, 2013
                                          On Sunday, May 5, 2013 4:31:03 PM UTC-5, Bram Moolenaar wrote:
                                          > Yukihiro Nakadaira wrote:
                                          >
                                          > > It seems that the current invert drawing method (dst = fg XOR bg XOR dst)
                                          > > is not good for anti-aliased font. I think that using GDK_INVERT is
                                          > > good for it.
                                          > >
                                          > > diff -r 9e3cdd762964 src/gui_gtk_x11.c
                                          > > --- a/src/gui_gtk_x11.c Sat May 04 04:40:15 2013 +0200
                                          > > +++ b/src/gui_gtk_x11.c Sun May 05 16:23:33 2013 +0900
                                          > > @@ -5271,13 +5271,9 @@
                                          > > if (gui.drawarea->window == NULL)
                                          > > return;
                                          > >
                                          > > - values.foreground.pixel = gui.norm_pixel ^ gui.back_pixel;
                                          > > - values.background.pixel = gui.norm_pixel ^ gui.back_pixel;
                                          > > - values.function = GDK_XOR;
                                          > > + values.function = GDK_INVERT;
                                          > > invert_gc = gdk_gc_new_with_values(gui.drawarea->window,
                                          > > &values,
                                          > > - GDK_GC_FOREGROUND |
                                          > > - GDK_GC_BACKGROUND |
                                          > > GDK_GC_FUNCTION);
                                          > > gdk_gc_set_exposures(invert_gc, gui.visibility !=
                                          > > GDK_VISIBILITY_UNOBSCURED);
                                          > >
                                          >
                                          > Thanks for making a patch.
                                          >
                                          > Can some users try this out and give feedback?
                                          >

                                          I finally got a chance to try applying the patch and it seems to work as advertised. I have no idea whether it has unintended side effects. I'll run with it for a while to see if I notice any. But I don't usually use modeless selection for anything so I doubt I'd see anything in my normal use.

                                          --
                                          --
                                          You received this message from the "vim_dev" maillist.
                                          Do not top-post! Type your reply below the text you are replying to.
                                          For more information, visit http://www.vim.org/maillist.php

                                          ---
                                          You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                          For more options, visit https://groups.google.com/groups/opt_out.
                                        Your message has been successfully submitted and would be delivered to recipients shortly.