Loading ...
Sorry, an error occurred while loading the content.
 

Re: Patch 7.3.872

Expand Messages
  • Ingo Karkat
    ... Typo: In the help, the abbrevation wic is mistakenly (re-)used instead of fic : diff -r c2bf5b221b1d runtime/doc/options.txt ... +++
    Message 1 of 7 , Mar 19, 2013
      On 19-Mar-13 16:49:37 +0100, Bram Moolenaar wrote:

      > Patch 7.3.872
      > Problem: On some systems case of file names is always ignored, on others
      > never.
      > Solution: Add the 'fileignorecase' option to control this at runtime.
      > Implies 'wildignorecase'.
      > Files: src/buffer.c, src/edit.c, src/ex_cmds2.c, src/ex_getln.c,
      > src/fileio.c, src/misc1.c, src/misc2.c, src/option.c,
      > src/option.h, src/vim.h, runtime/doc/options.txt

      Typo: In the help, the abbrevation 'wic' is mistakenly (re-)used instead of 'fic':

      diff -r c2bf5b221b1d runtime/doc/options.txt
      --- a/runtime/doc/options.txt Tue Mar 19 16:49:16 2013 +0100
      +++ b/runtime/doc/options.txt Tue Mar 19 17:20:49 2013 +0100
      @@ -2941,8 +2941,8 @@
      NOTE: This option is set to the Vi default value when 'compatible' is
      set and to the Vim default value when 'compatible' is reset.

      - *'fileignorecase'* *'wic'* *'nofileignorecase'* *'nowic'*
      -'fileignorecase' 'wic' boolean (default on for systems where case in file
      + *'fileignorecase'* *'fic'* *'nofileignorecase'* *'nofic'*
      +'fileignorecase' 'fic' boolean (default on for systems where case in file
      names is normally ignored.
      global
      {not in Vi}

      -- regards, ingo

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... Thanks for noticing that mistake. -- hundred-and-one symptoms of being an internet addict: 79. All of your most erotic dreams have a scrollbar at the right
      Message 2 of 7 , Mar 19, 2013
        Ingo Karkat wrote:

        > On 19-Mar-13 16:49:37 +0100, Bram Moolenaar wrote:
        >
        > > Patch 7.3.872
        > > Problem: On some systems case of file names is always ignored, on others
        > > never.
        > > Solution: Add the 'fileignorecase' option to control this at runtime.
        > > Implies 'wildignorecase'.
        > > Files: src/buffer.c, src/edit.c, src/ex_cmds2.c, src/ex_getln.c,
        > > src/fileio.c, src/misc1.c, src/misc2.c, src/option.c,
        > > src/option.h, src/vim.h, runtime/doc/options.txt
        >
        > Typo: In the help, the abbrevation 'wic' is mistakenly (re-)used
        > instead of 'fic':

        Thanks for noticing that mistake.

        --
        hundred-and-one symptoms of being an internet addict:
        79. All of your most erotic dreams have a scrollbar at the right side.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Ben Fritz
        ... Another typo: no closing parenthesis for description of default value. -- -- You received this message from the vim_dev maillist. Do not top-post! Type
        Message 3 of 7 , Mar 19, 2013
          On Tuesday, March 19, 2013 10:49:37 AM UTC-5, Bram Moolenaar wrote:
          > + *'fileignorecase'* *'wic'* *'nofileignorecase'* *'nowic'*
          > + 'fileignorecase' 'wic' boolean (default on for systems where case in file
          > + names is normally ignored.
          > + global
          > + {not in Vi}
          > + When set case is ignored when using file names and directories.
          > + See 'wildignorecase' for only ignoring case when doing completion.
          > +

          Another typo: no closing parenthesis for description of default value.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • h_east
          Hi Bram, ... When set fic on linux, file name completion order is strange. It s different for both case-sensitive and case-insensitive. How to reproduce (on
          Message 4 of 7 , Mar 20, 2013
            Hi Bram,

            2013/3/20(Wed) 0:49:37 UTC+9 Bram Moolenaar:
            > Patch 7.3.872
            >
            > Problem: On some systems case of file names is always ignored, on others
            >
            > never.
            >
            > Solution: Add the 'fileignorecase' option to control this at runtime.
            >
            > Implies 'wildignorecase'.
            >
            > Files: src/buffer.c, src/edit.c, src/ex_cmds2.c, src/ex_getln.c,
            >
            > src/fileio.c, src/misc1.c, src/misc2.c, src/option.c,
            >
            > src/option.h, src/vim.h, runtime/doc/options.txt

            When 'set fic' on linux, file name completion order is strange.
            It's different for both case-sensitive and case-insensitive.

            How to reproduce (on fedora17)
            $ mkdir test_fic
            $ cd !$
            $ touch I1.txt I2.txt J3.txt J4.txt i1.txt j3.txt
            (Necessary: same file name (without case-sensitive) exist.)
            $ vim -N -u NONE -i NONE --noplugin -c "set fic"
            input i<C-X><C-F>

            Actual result
            (popup menu list items)
            I1.txt
            I2.txt
            j3.txt
            J3.txt
            J4.txt
            i1.txt

            Expect result (like this)
            I1.txt
            i1.txt
            I2.txt
            j3.txt
            J3.txt
            J4.txt

            Patch attached. (Thanks for advice from Yukihiro Nakadaira)
            Please check.

            Best Regards,
            Hirohito Higashi

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Bram Moolenaar
            ... Thanks, I ll look into it later. -- From know your smileys : y:-) Bad toupee /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net
            Message 5 of 7 , Mar 20, 2013
              h_east wrote:

              > 2013/3/20(Wed) 0:49:37 UTC+9 Bram Moolenaar:
              > > Patch 7.3.872
              > >
              > > Problem: On some systems case of file names is always ignored, on others
              > >
              > > never.
              > >
              > > Solution: Add the 'fileignorecase' option to control this at runtime.
              > >
              > > Implies 'wildignorecase'.
              > >
              > > Files: src/buffer.c, src/edit.c, src/ex_cmds2.c, src/ex_getln.c,
              > >
              > > src/fileio.c, src/misc1.c, src/misc2.c, src/option.c,
              > >
              > > src/option.h, src/vim.h, runtime/doc/options.txt
              >
              > When 'set fic' on linux, file name completion order is strange.
              > It's different for both case-sensitive and case-insensitive.
              >
              > How to reproduce (on fedora17)
              > $ mkdir test_fic
              > $ cd !$
              > $ touch I1.txt I2.txt J3.txt J4.txt i1.txt j3.txt
              > (Necessary: same file name (without case-sensitive) exist.)
              > $ vim -N -u NONE -i NONE --noplugin -c "set fic"
              > input i<C-X><C-F>
              >
              > Actual result
              > (popup menu list items)
              > I1.txt
              > I2.txt
              > j3.txt
              > J3.txt
              > J4.txt
              > i1.txt
              >
              > Expect result (like this)
              > I1.txt
              > i1.txt
              > I2.txt
              > j3.txt
              > J3.txt
              > J4.txt
              >
              > Patch attached. (Thanks for advice from Yukihiro Nakadaira)
              > Please check.

              Thanks, I'll look into it later.


              --
              From "know your smileys":
              y:-) Bad toupee

              /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
              /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
              \\\ an exciting new programming language -- http://www.Zimbu.org ///
              \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • h_east
              Hi Bram, ... Sorry, It s doubt. This condition was not necessary. I report again below. How to reproduce (on linux) $ mkdir test_fic $ cd !$ $ touch i1.txt
              Message 6 of 7 , Mar 24, 2013
                Hi Bram,

                2013/3/21(Thu) 5:24:00 UTC+9 Bram Moolenaar:
                > h_east wrote:
                > > 2013/3/20(Wed) 0:49:37 UTC+9 Bram Moolenaar:
                > > > Patch 7.3.872
                > > >
                > > > Problem: On some systems case of file names is always ignored, on others
                > > >
                > > > never.
                > > >
                > > > Solution: Add the 'fileignorecase' option to control this at runtime.
                > > >
                > > > Implies 'wildignorecase'.
                > > >
                > > > Files: src/buffer.c, src/edit.c, src/ex_cmds2.c, src/ex_getln.c,
                > > >
                > > > src/fileio.c, src/misc1.c, src/misc2.c, src/option.c,
                > > >
                > > > src/option.h, src/vim.h, runtime/doc/options.txt
                > >
                > > When 'set fic' on linux, file name completion order is strange.
                > > It's different for both case-sensitive and case-insensitive.
                > >
                > > How to reproduce (on fedora17)
                > > $ mkdir test_fic
                > > $ cd !$
                > > $ touch I1.txt I2.txt J3.txt J4.txt i1.txt j3.txt
                > > (Necessary: same file name (without case-sensitive) exist.)
                Sorry, It's doubt.
                This condition was not necessary.

                I report again below.

                How to reproduce (on linux)
                $ mkdir test_fic
                $ cd !$
                $ touch i1.txt I2.txt J3.txt j4.txt

                $ vim -N -u NONE -i NONE --noplugin -c "set fic"
                input i<C-X><C-F>

                Actual result
                (popup menu list items)
                I2.txt
                J3.txt
                i1.txt
                j4.txt

                Expect result
                i1.txt
                I2.txt
                J3.txt
                j4.txt

                I update a patch. (against multi-byte).
                Please check.

                Best Regards,
                Hirohito Higashi

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.