Loading ...
Sorry, an error occurred while loading the content.

Issue 122 in vim: echo options when changing them

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 122 by j...@bendyworks.com: echo options when changing them
    Message 1 of 3 , Mar 12, 2013
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 122 by j...@...: echo options when changing them
      http://code.google.com/p/vim/issues/detail?id=122

      What steps will reproduce the problem?
      1. run `:set showcmd!`
      2. forget what was actually set (possibly after using `@:` a few times)
      3. run `:set showcmd?` to see what's set

      What is the expected output? What do you see instead?
      It'd be cool to have options get echoed out (as if you'd typed `:set
      showcmd!<cr>:set showcmd?<cr>`) once you change them to make it more
      obvious as to what's set after your change. This could happen even without
      using the bang to toggle the option, but I think it would be most useful in
      that case.

      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • vim@...
      Comment #1 on issue 122 by chrisbr...@googlemail.com: echo options when changing them https://code.google.com/p/vim/issues/detail?id=122 While not builtin, you
      Message 2 of 3 , Oct 11, 2014
      • 0 Attachment
        Comment #1 on issue 122 by chrisbr...@...: echo options when
        changing them
        https://code.google.com/p/vim/issues/detail?id=122

        While not builtin, you can easily define a command that does this:
        Take this example:

        :com! -complete=option -nargs=1 Toggle :set <args>!|set <args>?

        Then you can do :Toggle nu
        and Vim will turn on numbering and show the actual value of the number
        option.

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • vim@...
        Updates: Status: WontFix Comment #2 on issue 122 by chrisbr...@googlemail.com: echo options when changing them
        Message 3 of 3 , Oct 21, 2014
        • 0 Attachment
          Updates:
          Status: WontFix

          Comment #2 on issue 122 by chrisbr...@...: echo options when
          changing them
          https://code.google.com/p/vim/issues/detail?id=122

          Closing this for now. Use the provided command to achieve what you want.

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        Your message has been successfully submitted and would be delivered to recipients shortly.