Loading ...
Sorry, an error occurred while loading the content.

Re: runtime/doc/tags not ignored

Expand Messages
  • Tony Mechelynck
    ... I also use fetch --switch-parent but I have a local unnamed (topological) branch (inside the default -named- branch) which is merged at each fetch. It
    Message 1 of 8 , Mar 10, 2013
    • 0 Attachment
      On 08/03/13 02:38, John Little wrote:
      > I have runtime/doc/tags in my .hgignore file, but most times I update with
      >
      > hg fetch --switch-parent
      >
      > I'm told
      >
      > abort: outstanding uncommitted changes
      >
      > so I run hg commit, and the changed comment says
      >
      > HG: changed runtime/doc/tags
      >
      > Why isn't this ignored?
      >
      > Regards, John Little
      >
      I also use fetch --switch-parent but I have a local unnamed
      (topological) branch (inside the default -named- branch) which is merged
      at each fetch. It contains a few small changes to .hgignore and
      src/feature.h; it also has runtime/doc/tags "deleted" (see hg help
      remove). Whenever there is a change to runtime/doc/tags on Bram's repo,
      the fetch asks me if I want to import or delete the file (Hint: if you
      are logging Mercurial output by |tee logfilename, then in order to see
      the prompt you need PYTHONUNBUFFERED set to some nonempty string in the
      environment: I use PYTHONUNBUFFERED=unbuffered) so I hit d<Enter> and
      everything goes well.

      Best regards,
      Tony.
      --
      Another bucket of what can only be described as human ordure hits
      ARTHUR.
      ARTHUR: ... Right! (to the KNIGHTS) That settles it!
      "Monty Python and the Holy Grail" PYTHON (MONTY)
      PICTURES LTD

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.