Loading ...
Sorry, an error occurred while loading the content.

Issue 119 in vim: Euro sign on win32

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 119 by Go.Zu...@gmail.com: Euro sign on win32
    Message 1 of 9 , Mar 8, 2013
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 119 by Go.Zu...@...: Euro sign on win32
      http://code.google.com/p/vim/issues/detail?id=119

      What steps will reproduce the problem?
      To insert a € sign in "Insert Mode", i use
      3 keypress sequence :
      1 <C-k> >>> Ctrl-K key combination
      2 = >>> = key
      3 e >>> e key

      What is the expected output?

      What do you see instead?
      The cursor go to the beginning of the line, when setting encoding=utf-8,
      and none char to output. By default, the encoding is encoding=latin1, when
      input the 3 keys: <C-k>=e sequence, I see the e character on the display.
      But on Linux system this work well.

      What version of the product are you using? On what operating system?
      :ver
      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 8 2013 20:05:11)
      MS-Windows 32-bit console version
      Included patches: 1-854

      Please provide any additional information below.
      One char is the expected to output, the euro sign €.
      My options are:
      --- Options ---
      autoindent hlsearch modified
      scroll=19 showmatch t_vb=
      encoding=utf-8 ignorecase number
      scrolloff=3 smartcase
      helplang=fr incsearch ruler
      shiftwidth=3 ttyfast
      backspace=indent,eol,start
      fileencodings=ucs-bom,utf-8,default,latin1


      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Zulox4
      Hello, Also, I have some problem with console win32 Vim 7.3.861 version, for digraph GREEK CAPITAL LETTER PI - Ð char, the P* sequence display the *
      Message 2 of 9 , Mar 24, 2013
      • 0 Attachment
        Hello,

        Also, I have some problem with console win32 Vim 7.3.861 version, for digraph GREEK CAPITAL LETTER PI -> Π char, the <C-k>P* sequence display the * char.
        Thanks for investigations !
        Best regards !

        On Friday, March 8, 2013 8:59:17 PM UTC+1, v...@... wrote:
        > Status: New
        >
        > Owner: ----
        >
        > Labels: Type-Defect Priority-Medium
        >
        >
        >
        > New issue 119 by Go.Zu...@...: Euro sign on win32
        >
        > http://code.google.com/p/vim/issues/detail?id=119
        >
        >
        >
        > What steps will reproduce the problem?
        >
        > To insert a € sign in "Insert Mode", i use
        >
        > 3 keypress sequence :
        >
        > 1 <C-k> >>> Ctrl-K key combination
        >
        > 2 = >>> = key
        >
        > 3 e >>> e key
        >
        >
        >
        > What is the expected output?
        >
        > €
        >
        > What do you see instead?
        >
        > The cursor go to the beginning of the line, when setting encoding=utf-8,
        >
        > and none char to output. By default, the encoding is encoding=latin1, when
        >
        > input the 3 keys: <C-k>=e sequence, I see the e character on the display.
        >
        > But on Linux system this work well.
        >
        >
        >
        > What version of the product are you using? On what operating system?
        >
        > :ver
        >
        > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 8 2013 20:05:11)
        >
        > MS-Windows 32-bit console version
        >
        > Included patches: 1-854
        >
        >
        >
        > Please provide any additional information below.
        >
        > One char is the expected to output, the euro sign €.
        >
        > My options are:
        >
        > --- Options ---
        >
        > autoindent hlsearch modified
        >
        > scroll=19 showmatch t_vb=
        >
        > encoding=utf-8 ignorecase number
        >
        > scrolloff=3 smartcase
        >
        > helplang=fr incsearch ruler
        >
        > shiftwidth=3 ttyfast
        >
        > backspace=indent,eol,start
        >
        > fileencodings=ucs-bom,utf-8,default,latin1
        >
        >
        >
        >
        >
        > --
        >
        > You received this message because this project is configured to send all
        >
        > issue notifications to this address.
        >
        > You may adjust your notification preferences at:
        >
        > https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • vim@...
        Comment #1 on issue 119 by fritzoph...@gmail.com: Euro sign on win32 http://code.google.com/p/vim/issues/detail?id=119 I cannot reproduce. I get a Euro symbol
        Message 3 of 9 , Mar 24, 2013
        • 0 Attachment
          Comment #1 on issue 119 by fritzoph...@...: Euro sign on win32
          http://code.google.com/p/vim/issues/detail?id=119

          I cannot reproduce. I get a Euro symbol in 7.3.646 on Windows Vista when
          encoding is set to UTF-8. When encoding is Latin1, I just get an 'e'
          character.

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Zulox4
          Hello, I compiled on win7-64, the win32 console vim 7.3.646, and I now it display ? char. With ga keystrokes and cursor on ? char, vim return: 8364, Hex
          Message 4 of 9 , Mar 25, 2013
          • 0 Attachment
            Hello,
            I compiled on win7-64, the win32 console vim 7.3.646, and I now it display ? char. With ga keystrokes and cursor on ? char, vim return:

            <?> 8364, Hex 20ac, Octal 20254

            that I think is good, the hex codes is like in digraph.txt doc file :

            € Eu 20AC 8364 EURO SIGN

            Best regards !


            On Monday, March 25, 2013 12:01:41 AM UTC+1, v...@... wrote:
            > Comment #1 on issue 119 by fritzoph...@...: Euro sign on win32
            >
            > http://code.google.com/p/vim/issues/detail?id=119
            >
            >
            >
            > I cannot reproduce. I get a Euro symbol in 7.3.646 on Windows Vista when
            >
            > encoding is set to UTF-8. When encoding is Latin1, I just get an 'e'
            >
            > character.
            >
            >
            >
            > --
            >
            > You received this message because this project is configured to send all
            >
            > issue notifications to this address.
            >
            > You may adjust your notification preferences at:
            >
            > https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • vim@...
            Comment #2 on issue 119 by fritzoph...@gmail.com: Euro sign on win32 http://code.google.com/p/vim/issues/detail?id=119 I also could not reproduce in gvim
            Message 5 of 9 , Mar 25, 2013
            • 0 Attachment
              Comment #2 on issue 119 by fritzoph...@...: Euro sign on win32
              http://code.google.com/p/vim/issues/detail?id=119

              I also could not reproduce in gvim 7.3.822 on Windows 7, I get '€' or 'e'
              depending on my encoding as before. I can try again later with the latest
              Vim. Possibly it was introduced somewhere between 822 and 854 but as far as
              I can tell it hasn't yet been reproduced.

              --
              You received this message because this project is configured to send all
              issue notifications to this address.
              You may adjust your notification preferences at:
              https://code.google.com/hosting/settings

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Stephen Lee
              1 Ctrl-K key combination 2 = = key 3 e e key I got a chinese character and not ¤ GREEK CAPITAL LETTER PI - Ð char, the
              Message 6 of 9 , Mar 25, 2013
              • 0 Attachment
                "1 <C-k> >>> Ctrl-K key combination
                2 = >>> = key
                3 e >>> e key"

                I got a chinese character and not €

                "GREEK CAPITAL LETTER PI -> Π char, the <C-k>P*"

                I got GREEK CAPITAL LETTER PI -> Π char

                I use vim 7.3.796 on windows xp simplified chinese (codepage 936)

                I got both correct using gVim 7.3.796 on the same system.

                I would consider these the limitation of console. Under all MS Windows versions, console forces input to be some kind of encodings except utf-8, and if without parameter, output would be same as input, or unicode if having a parameter /U.

                So it would be better to use gVim instead to avoid the problem of console.

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Zulox4
                ... Hello, I tested on Vim 7.3.861, it s ok, and I found a way to display € char in windows console vim version: 1. Need to change console font to Lucida
                Message 7 of 9 , Mar 25, 2013
                • 0 Attachment
                  On Monday, March 25, 2013 4:19:17 PM UTC+1, v...@... wrote:
                  > Comment #2 on issue 119 by fritzoph...@...: Euro sign on win32
                  >
                  > http://code.google.com/p/vim/issues/detail?id=119
                  >
                  >
                  >
                  > I also could not reproduce in gvim 7.3.822 on Windows 7, I get '€' or 'e'
                  >
                  > depending on my encoding as before. I can try again later with the latest
                  >
                  > Vim. Possibly it was introduced somewhere between 822 and 854 but as far as
                  >
                  > I can tell it hasn't yet been reproduced.
                  >
                  >
                  >
                  > --
                  >
                  > You received this message because this project is configured to send all
                  >
                  > issue notifications to this address.
                  >
                  > You may adjust your notification preferences at:
                  >
                  > https://code.google.com/hosting/settings

                  Hello,

                  I tested on Vim 7.3.861, it's ok, and I found a way to display € char in windows console vim version:
                  1. Need to change console font to Lucida console in "Command shell" properties.
                  2. Before starting console Vim Change Active code page to 1253 with the command:
                  c:\>chcp 1253
                  3. Start Vim, and set with the Ex command encoding to utf8:
                  :set encoding=utf8

                  Now I have these options:
                  --- Options ---
                  autoindent hlsearch modified scroll=34 showmatch t_vb=
                  encoding=utf-8 ignorecase number scrolloff=3 smartcase
                  helplang=fr incsearch ruler shiftwidth=3 ttyfast
                  backspace=indent,eol,start
                  fileencodings=ucs-bom,utf-8,default,latin1

                  Thanks a lot !
                  Best regards !

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • vim@...
                  Comment #3 on issue 119 by Go.Zu...@gmail.com: Euro sign on win32 http://code.google.com/p/vim/issues/detail?id=119 Vim 7.3.861 - win32 console version - works
                  Message 8 of 9 , Mar 26, 2013
                  • 0 Attachment
                    Comment #3 on issue 119 by Go.Zu...@...: Euro sign on win32
                    http://code.google.com/p/vim/issues/detail?id=119

                    Vim 7.3.861 - win32 console version - works in windows 7 64bits.
                    Thanks a lot.

                    --
                    You received this message because this project is configured to send all
                    issue notifications to this address.
                    You may adjust your notification preferences at:
                    https://code.google.com/hosting/settings

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • vim@...
                    Updates: Status: WontFix Comment #4 on issue 119 by lech.lor...@gmail.com: Euro sign on win32 http://code.google.com/p/vim/issues/detail?id=119 (No comment was
                    Message 9 of 9 , Mar 27, 2013
                    • 0 Attachment
                      Updates:
                      Status: WontFix

                      Comment #4 on issue 119 by lech.lor...@...: Euro sign on win32
                      http://code.google.com/p/vim/issues/detail?id=119

                      (No comment was entered for this change.)

                      --
                      You received this message because this project is configured to send all
                      issue notifications to this address.
                      You may adjust your notification preferences at:
                      https://code.google.com/hosting/settings

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    Your message has been successfully submitted and would be delivered to recipients shortly.