Loading ...
Sorry, an error occurred while loading the content.

Patch 7.3.854

Expand Messages
  • Bram Moolenaar
    Patch 7.3.854 Problem: After using backspace in insert mode completion, CTRL-N and CTRL-P do not highlight the right entry. (Olivier Teuliere) Solution:
    Message 1 of 1 , Mar 7, 2013
    • 0 Attachment
      Patch 7.3.854
      Problem: After using backspace in insert mode completion, CTRL-N and CTRL-P
      do not highlight the right entry. (Olivier Teuliere)
      Solution: Set the current item to the shown item after using backspace.
      Files: src/edit.c


      *** ../vim-7.3.853/src/edit.c 2013-02-26 13:30:28.000000000 +0100
      --- src/edit.c 2013-03-07 19:31:46.000000000 +0100
      ***************
      *** 3380,3385 ****
      --- 3380,3388 ----
      if (compl_leader != NULL)
      {
      ins_compl_new_leader();
      + if (compl_shown_match != NULL)
      + /* Make sure current match is not a hidden item. */
      + compl_curr_match = compl_shown_match;
      return NUL;
      }
      return K_BS;
      *** ../vim-7.3.853/src/version.c 2013-03-07 18:50:52.000000000 +0100
      --- src/version.c 2013-03-07 19:34:32.000000000 +0100
      ***************
      *** 730,731 ****
      --- 730,733 ----
      { /* Add new patch number below this line */
      + /**/
      + 854,
      /**/

      --
      If you put 7 of the most talented OSS developers in a room for a week
      and asked them to fix a bug in a spreadsheet program, in 1 week
      you'd have 2 new mail readers and a text-based web browser.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.