Loading ...
Sorry, an error occurred while loading the content.

[patch] test55 may fail if lang isn't C

Expand Messages
  • Ken Takata
    Hi, The test55 may fail if lang isn t C, because the E737 message is translated. Here is an example. (Vim 7.3.843 with old runtime files of 7.3.000) $
    Message 1 of 3 , Mar 6, 2013
    • 0 Attachment
      Hi,

      The test55 may fail if lang isn't C, because the E737 message is translated.
      Here is an example.
      (Vim 7.3.843 with old runtime files of 7.3.000)

      $ LANG=ja_JP.UTF-8 make test55.out
      rm -rf test55.failed test.ok test.out X* viminfo
      cp test55.ok test.ok
      # Sleep a moment to avoid that the xterm title is messed up
      ../vim -u unix.vim -U NONE --noplugin -s dotest.in test55.in
      # For flaky tests retry one time.
      # Check if the test.out file matches test.ok.
      18c18
      < Vim(call):E737: ? <- A broken char is shown.
      ---
      > Vim(call):E737: 3
      116c116
      < Vim(call):E737: ? <- A broken char is shown.
      ---
      > Vim(call):E737: a
      rm -rf X* test.ok viminfo


      Attached patch fixes this problem.

      Regards,
      Ken Takata

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... Thanks. Somehow I didn t manage to reproduce the problem, looks like my locale setup isn t right... -- I m not familiar with this proof, but I m aware of
      Message 2 of 3 , Mar 7, 2013
      • 0 Attachment
        Ken Takata wrote:

        > The test55 may fail if lang isn't C, because the E737 message is translated.
        > Here is an example.
        > (Vim 7.3.843 with old runtime files of 7.3.000)
        >
        > $ LANG=ja_JP.UTF-8 make test55.out
        > rm -rf test55.failed test.ok test.out X* viminfo
        > cp test55.ok test.ok
        > # Sleep a moment to avoid that the xterm title is messed up
        > ../vim -u unix.vim -U NONE --noplugin -s dotest.in test55.in
        > # For flaky tests retry one time.
        > # Check if the test.out file matches test.ok.
        > 18c18
        > < Vim(call):E737: ? <- A broken char is shown.
        > ---
        > > Vim(call):E737: 3
        > 116c116
        > < Vim(call):E737: ? <- A broken char is shown.
        > ---
        > > Vim(call):E737: a
        > rm -rf X* test.ok viminfo
        >
        >
        > Attached patch fixes this problem.

        Thanks. Somehow I didn't manage to reproduce the problem, looks like my
        locale setup isn't right...


        --
        I'm not familiar with this proof, but I'm aware of a significant
        following of toddlers who believe that peanut butter is the solution
        to all of life's problems... -- Tim Hammerquist

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Yukihiro Nakadaira
        ... This problem is happend with old japanese .po file. en: E737: Key already exists: %s ja: E737: %s というキーは既に存在します %s is not
        Message 3 of 3 , Mar 7, 2013
        • 0 Attachment
          On Thu, Mar 7, 2013 at 10:51 PM, Bram Moolenaar <Bram@...> wrote:

          Ken Takata wrote:

          > The test55 may fail if lang isn't C, because the E737 message is translated.
          > Here is an example.
          > (Vim 7.3.843 with old runtime files of 7.3.000)
          >
          > $ LANG=ja_JP.UTF-8 make test55.out
          > rm -rf test55.failed test.ok test.out X* viminfo
          > cp test55.ok test.ok
          > # Sleep a moment to avoid that the xterm title is messed up
          > ../vim -u unix.vim -U NONE --noplugin -s dotest.in test55.in
          > # For flaky tests retry one time.
          > # Check if the test.out file matches test.ok.
          > 18c18
          > < Vim(call):E737: ?          <- A broken char is shown.
          > ---
          > > Vim(call):E737: 3
          > 116c116
          > < Vim(call):E737: ?          <- A broken char is shown.
          > ---
          > > Vim(call):E737: a
          > rm -rf X* test.ok viminfo
          >
          >
          > Attached patch fixes this problem.

          Thanks.  Somehow I didn't manage to reproduce the problem, looks like my
          locale setup isn't right...

          This problem is happend with old japanese .po file.

          en: "E737: Key already exists: %s"
          ja: "E737: %s というキーは既に存在します"

          "%s" is not placed at end in Japanese text.
          So in test55, the following expression returns wrong text.

          :$put =v:exception[:15] . v:exception[-1:-1]

          --
          Yukihiro Nakadaira - yukihiro.nakadaira@...

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        Your message has been successfully submitted and would be delivered to recipients shortly.