Loading ...
Sorry, an error occurred while loading the content.

Re: Can't compile Vim with python3 and perl support with MinGW for Windows XP

Expand Messages
  • rail shafigulin
    ... Well I found a solution to the python issue. Here it is http://markmail.org/thread/5lqelk2pfjobfwom But I still need a way to statically link those two
    Message 1 of 4 , Mar 1, 2013
    • 0 Attachment
      On Friday, March 1, 2013 3:12:23 PM UTC-5, rail shafigulin wrote:
      > On Friday, March 1, 2013 12:17:17 PM UTC-5, rail shafigulin wrote:
      > > I tried to compile Vim several times with perl and python3 support and the perl portion works but python3 crashes.
      > >
      > > I tried to compile it DYNAMIC_PYTHON3=yes and with DYNAMIC_PYTHON3=no.
      > >
      > > Problem 1.
      > > When I run gVim, In both cases (dynamic or non-dynamic python) it tells me that libstdc++-6.dll and libgcc_s_dw2-1.dll are missing. After I copy those libraries into my Vim directory, I finally can run Vim. If I compile it with DYNAMIC_PYTHON3=no, why do I need to copy those files into the Vim directory, shouldn't they be already linked to the executable?
      > >
      > > Problem 2.
      > > Now that I have both of the libraries in the Vim directory, whenever I try to execute :python3 print('Hello World'), gVim/Vim crashes with a Microsoft Visual C++ Runtime Library error. There is a difference between how they gVim and Vim crash. Unlike gVim, Vim has a fatal error in its command line before it crashes. Here is what it says: Fatal Python error: take_gil: NULL tstate.
      > >
      > > There is obviously something is mission in my compilation, but I can't figure out what. Does anybody know what have I done wrong?
      > >
      > > All the images with errors are attached to this post. Any help is appreciated.
      > >
      > >
      > > Windows XP Pro Version 2002 SP 3
      > > MinGW 4.6.2
      > > vim73_46.zip (that's the one I found on www.vim.org, if there is a later one, I will gladly take it)
      >
      > I forgot to mention that I'm trying to compile with OLE support. Here is what I have in my bat file
      >
      > @echo off
      > REM this file must be run in Vim source directory (e.g., C:\devel\vim73\src)
      > REM these folders and files can be deleted after compilation: /gobj/, /obj/, pathdef.c
      >
      > REM add "bin" directory of MinGW installation to system PATH
      > PATH = C:\MinGW\bin;%PATH%;
      >
      > REM build GUI version (gvim.exe)
      > mingw32-make.exe -f Make_ming.mak PYTHON3="C:/Python32" PYTHON3_VER=32 DYNAMIC_PYTHON3=yes PERL=C:/Perl PERL_VER=512 DYNAMIC_PERL=yes NETBEANS=no FEATURES=BIG OLE=yes GUI=yes gvim.exe > build_vim_log.txt 2>&1
      >
      > REM build console version (vim.exe)
      > mingw32-make.exe -f Make_ming.mak PYTHON3="C:/Python32" PYTHON3_VER=32 DYNAMIC_PYTHON3=yes PERL=C:/Perl PERL_VER=512 DYNAMIC_PERL=yes NETBEANS=no FEATURES=BIG OLE=yes GUI=no vim.exe >> build_vim_log.txt 2>&1
      >
      > pause
      >
      > I got these instructions from http://vim.wikia.com/wiki/Build_Python-enabled_Vim_on_Windows_with_MinGW and adapted them to what I need.

      Well I found a solution to the python issue. Here it is
      http://markmail.org/thread/5lqelk2pfjobfwom

      But I still need a way to statically link those two libraries. Any help is appreciated.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Please try building from the latest Vim source. You said you used the zip file of 7.3.46 from a few years ago. The latest code from the Mercurial
      Message 2 of 4 , Mar 1, 2013
      • 0 Attachment
        On Friday, March 1, 2013 3:01:39 PM UTC-6, cyboman wrote:
        > On Friday, March 1, 2013 3:12:23 PM UTC-5, rail shafigulin wrote:
        > > On Friday, March 1, 2013 12:17:17 PM UTC-5, rail shafigulin wrote:
        > > > I tried to compile Vim several times with perl and python3 support and the perl portion works but python3 crashes.
        > > >
        > > > I tried to compile it DYNAMIC_PYTHON3=yes and with DYNAMIC_PYTHON3=no.
        > > >
        > > > Problem 1.
        > > > When I run gVim, In both cases (dynamic or non-dynamic python) it tells me that libstdc++-6.dll and libgcc_s_dw2-1.dll are missing. After I copy those libraries into my Vim directory, I finally can run Vim. If I compile it with DYNAMIC_PYTHON3=no, why do I need to copy those files into the Vim directory, shouldn't they be already linked to the executable?
        > > >
        > > > Problem 2.
        > > > Now that I have both of the libraries in the Vim directory, whenever I try to execute :python3 print('Hello World'), gVim/Vim crashes with a Microsoft Visual C++ Runtime Library error. There is a difference between how they gVim and Vim crash. Unlike gVim, Vim has a fatal error in its command line before it crashes. Here is what it says: Fatal Python error: take_gil: NULL tstate.
        > > >
        > > > There is obviously something is mission in my compilation, but I can't figure out what. Does anybody know what have I done wrong?
        > > >
        > > > All the images with errors are attached to this post. Any help is appreciated.
        > > >
        > > >
        > > > Windows XP Pro Version 2002 SP 3
        > > > MinGW 4.6.2
        > > > vim73_46.zip (that's the one I found on www.vim.org, if there is a later one, I will gladly take it)
        > >
        > > I forgot to mention that I'm trying to compile with OLE support. Here is what I have in my bat file
        > >
        > > @echo off
        > > REM this file must be run in Vim source directory (e.g., C:\devel\vim73\src)
        > > REM these folders and files can be deleted after compilation: /gobj/, /obj/, pathdef.c
        > >
        > > REM add "bin" directory of MinGW installation to system PATH
        > > PATH = C:\MinGW\bin;%PATH%;
        > >
        > > REM build GUI version (gvim.exe)
        > > mingw32-make.exe -f Make_ming.mak PYTHON3="C:/Python32" PYTHON3_VER=32 DYNAMIC_PYTHON3=yes PERL=C:/Perl PERL_VER=512 DYNAMIC_PERL=yes NETBEANS=no FEATURES=BIG OLE=yes GUI=yes gvim.exe > build_vim_log.txt 2>&1
        > >
        > > REM build console version (vim.exe)
        > > mingw32-make.exe -f Make_ming.mak PYTHON3="C:/Python32" PYTHON3_VER=32 DYNAMIC_PYTHON3=yes PERL=C:/Perl PERL_VER=512 DYNAMIC_PERL=yes NETBEANS=no FEATURES=BIG OLE=yes GUI=no vim.exe >> build_vim_log.txt 2>&1
        > >
        > > pause
        > >
        > > I got these instructions from http://vim.wikia.com/wiki/Build_Python-enabled_Vim_on_Windows_with_MinGW and adapted them to what I need.
        >
        > Well I found a solution to the python issue. Here it is
        > http://markmail.org/thread/5lqelk2pfjobfwom
        >
        > But I still need a way to statically link those two libraries. Any help is appreciated.

        Please try building from the latest Vim source. You said you used the zip file of 7.3.46 from a few years ago. The latest code from the Mercurial repository is at version 7.3.843.

        As for the runtime errors, I wonder whether you simply need to update your system path to include the python install location?

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.