Loading ...
Sorry, an error occurred while loading the content.

Sometimes there is no popup when balloonexpr uses synID and synIDattr

Expand Messages
  • Ben Fritz
    I m sorry I don t have a better subject line; I can t get too much more specific. I created the following test .vimrc, and saved it to %TEMP% test.vim on
    Message 1 of 4 , Feb 27, 2013
    • 0 Attachment
      I'm sorry I don't have a better subject line; I can't get too much more specific.

      I created the following test .vimrc, and saved it to %TEMP%\test.vim on Windows 7:

      set nocompatible
      set nowrap
      filetype on
      syntax on
      let &balloonexpr="'synname: '.synIDattr(synID(v:beval_lnum, v:beval_col, 0), 'name')"
      set ballooneval

      I launched Vim with:

      gvim -N -u %TEMP%\test.vim --noplugin -i NONE %TEMP%\test.vim

      When the gvim window pops up, sometimes when I hover over syntax highlighted text, the tooltip balloon comes up with the name of the syntax group. After viewing a few balloon tooltips, inevitably the tooltip stops appearing no matter how long I hover over a highlighted word.

      Sometimes, the tooltip doesn't come up at all even right after launching Vim.

      The only way I've found to recover is close the file, and open it in a brand new Vim.

      I'm using 7.3.822 from the "Vim without Cream" install. As I mentioned, I reproduced with the simple .vimrc above on Windows 7. With actual tooltip I found this in to begin with, I saw the issue on Windows XP 64-bit as well. I just haven't gotten around to reducing it to a smaller case until now.

      I can't think of anything I might be doing wrong with so simple a test case, but please point it out if you see it. Otherwise, I think this is a bug.

      :set balloondelay? ballooneval? balloonexpr? shows the expected values of balloonexpr and ballooneval, and balloondelay of 600.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • John Little
      FWIW, gvim 7.3.843, Kubuntu, Huge version with GTK2-GNOME GUI, I’ve seen maybe 80 tooltips, and still going. I count 20 different tips moving the mouse
      Message 2 of 4 , Feb 27, 2013
      • 0 Attachment
        FWIW, gvim 7.3.843, Kubuntu, Huge version with GTK2-GNOME GUI, I’ve seen maybe 80 tooltips, and still going. I count 20 different tips moving the mouse pointer through the file.

        Regards, John Little

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Ben Fritz
        ... Ugh, I can t reproduce it at home with the example config on Windows Vista. There has to be something else interfering. I hope it s not some video card
        Message 3 of 4 , Feb 27, 2013
        • 0 Attachment
          On Wednesday, February 27, 2013 7:42:14 PM UTC-6, John Little wrote:
          > FWIW, gvim 7.3.843, Kubuntu, Huge version with GTK2-GNOME GUI, I’ve seen maybe 80 tooltips, and still going. I count 20 different tips moving the mouse pointer through the file.
          >
          >
          >
          > Regards, John Little

          Ugh, I can't reproduce it at home with the example config on Windows Vista.

          There has to be something else interfering. I hope it's not some video card thing or something. I'll try it on a few more computers at work I suppose.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Lech Lorens
          ... Confirmed on Windows 7 64 bit. For me the tooltips did not show at all after hovering over a piece of text until I moved the mouse pointer by a pixel or
          Message 4 of 4 , Feb 28, 2013
          • 0 Attachment
            On 28 February 2013 06:19, Ben Fritz <fritzophrenic@...> wrote:
            > Ugh, I can't reproduce it at home with the example config on Windows Vista.
            >
            > There has to be something else interfering. I hope it's not some video card thing or something. I'll try it on a few more computers at work I suppose.

            Confirmed on Windows 7 64 bit.
            For me the tooltips did not show at all after hovering over a piece of
            text until I moved the mouse pointer by a pixel or two.

            --
            Cheers,
            Lech

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.