Loading ...
Sorry, an error occurred while loading the content.

Re: Wrong completion entry selection after backspace

Expand Messages
  • Christian Brabandt
    Hi Olivier! ... Yes. n needs to be initialized to -1. It fixes the problem you described in your first message for me. regards, Christian -- -- You received
    Message 1 of 8 , Feb 26, 2013
    • 0 Attachment
      Hi Olivier!

      On Di, 26 Feb 2013, Olivier Teuliere wrote:

      > Hi Christian,
      >
      > Sorry, but there doesn't seem to be any difference.
      > And there is a compilation warning:
      > edit.c: In function ‘ins_complete’:
      > edit.c:5377:16: warning: ‘n’ may be used uninitialized in this
      > function [-Wmaybe-uninitialized]
      > edit.c:4944:9: note: ‘n’ was declared here

      Yes. n needs to be initialized to -1. It fixes the problem you described
      in your first message for me.

      regards,
      Christian

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Olivier Teuliere
      Hi Christian, ... Initializing n doesn t fix the initial problem either. I don t know if I was supposed to revert your first patch before applying the second
      Message 2 of 8 , Feb 26, 2013
      • 0 Attachment
        Hi Christian,

        On Tue, Feb 26, 2013 at 11:56 PM, Christian Brabandt <cblists@...> wrote:
        > Yes. n needs to be initialized to -1. It fixes the problem you described
        > in your first message for me.

        Initializing n doesn't fix the initial problem either.
        I don't know if I was supposed to revert your first patch before
        applying the second one, but neither way works for me:
        - if I apply only the second one, the behaviour described in my first
        email is still there
        - if I apply both, it's the same as when applying only the first one:
        the selection is lost after typing the 'f'

        Did you use the latest sources from hg for your tests?

        Best regards,
        --
        Olivier

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        ... Hi Olivier, I used something like 7.3.840 patch yesterday night to test it and as I said, it works for me, but let me look into it again later today.
        Message 3 of 8 , Feb 27, 2013
        • 0 Attachment
          On Wed, February 27, 2013 08:35, Olivier Teuliere wrote:
          > Hi Christian,
          >
          > On Tue, Feb 26, 2013 at 11:56 PM, Christian Brabandt <cblists@...>
          > wrote:
          >> Yes. n needs to be initialized to -1. It fixes the problem you described
          >> in your first message for me.
          >
          > Initializing n doesn't fix the initial problem either.
          > I don't know if I was supposed to revert your first patch before
          > applying the second one, but neither way works for me:
          > - if I apply only the second one, the behaviour described in my first
          > email is still there
          > - if I apply both, it's the same as when applying only the first one:
          > the selection is lost after typing the 'f'
          >
          > Did you use the latest sources from hg for your tests?

          Hi Olivier,
          I used something like 7.3.840 patch yesterday night to test it and as
          I said, it works for me, but let me look into it again later today.

          regards,
          Christian

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.