Loading ...
Sorry, an error occurred while loading the content.

Re: Issue 116 in vim: xxd -i output syntactically incorrect for empty files.

Expand Messages
  • Bram Moolenaar
    ... Thanks. I ll do it slightly differently: leave the code before the loop as it is and omitting the n below it when the file is empty. Looks like that
    Message 1 of 4 , Feb 26, 2013
    • 0 Attachment
      Lawrence Woodman wrote:

      > Comment #1 on issue 116 by lorrywoo...@...: xxd -i output
      > syntactically incorrect for empty files.
      > http://code.google.com/p/vim/issues/detail?id=116
      >
      > I have fixed this with the following commit:
      > http://code.google.com/r/lorrywoodman-fix-xxd-zero-byte-input-bug/source/detail?r=687a7d45da13e62bad6f801fd0873f0d86c2c8a3

      Thanks. I'll do it slightly differently: leave the code before the loop
      as it is and omitting the "\n" below it when the file is empty. Looks
      like that was the original intention of the code.

      --
      Every engineer dreams about saving the universe and having sex with aliens.
      This is much more glamorous than the real life of an engineer, which consists
      of hiding from the universe and having sex without the participation of other
      life forms. (Scott Adams - The Dilbert principle)

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • vim@...
      Updates: Status: Fixed Comment #2 on issue 116 by chrisbr...@googlemail.com: xxd -i output syntactically incorrect for empty files.
      Message 2 of 4 , Sep 30, 2014
      • 0 Attachment
        Updates:
        Status: Fixed

        Comment #2 on issue 116 by chrisbr...@...: xxd -i output
        syntactically incorrect for empty files.
        https://code.google.com/p/vim/issues/detail?id=116

        Should be fixed by Vim 7.3.835

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      Your message has been successfully submitted and would be delivered to recipients shortly.