Loading ...
Sorry, an error occurred while loading the content.

Bug win32 gui: window position is changed when invoking :vert under certain conditions

Expand Messages
  • lith
    Hi! I sometimes use gvim 7.3 @ win7 (64 bit). When I move the gvim window by means of the key combination to the left or right half
    Message 1 of 3 , Feb 23, 2013
    • 0 Attachment
      Hi!

      I sometimes use gvim 7.3 @ win7 (64 bit). When I move the gvim window by means of the <windows-key + left/right> key combination to the left or right half of the screen, it seems gvim doesn't properly notice this change. When I invoke any command with :vert prepended (e.g. :vert split), gvim moves the gvim window back to the previous position on the screen.

      Steps:
      1. Open gvim -> gvim window opens at position #1
      2. Press <windows-left> -> gvim window is moved to the left (position #2)
      3. Type :vert split

      Result: The gvim window is back at position #1.

      This problem seems to affect only the win gui. At least with gnome/gtk everything seems ok.

      Regards,
      Tom

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Reproduced with 7.3.762 on 64-bit Windows 7. gvim -N -u NONE -i NONE gvim window pops up near middle of screen with 256x80 lines/columns
      Message 2 of 3 , Feb 24, 2013
      • 0 Attachment
        On Saturday, February 23, 2013 2:23:07 AM UTC-6, lith wrote:
        > Hi!
        >
        > I sometimes use gvim 7.3 @ win7 (64 bit). When I move the gvim window by means of the <windows-key + left/right> key combination to the left or right half of the screen, it seems gvim doesn't properly notice this change. When I invoke any command with :vert prepended (e.g. :vert split), gvim moves the gvim window back to the previous position on the screen.
        >
        > Steps:
        > 1. Open gvim -> gvim window opens at position #1
        > 2. Press <windows-left> -> gvim window is moved to the left (position #2)
        > 3. Type :vert split
        >
        > Result: The gvim window is back at position #1.
        >
        > This problem seems to affect only the win gui. At least with gnome/gtk everything seems ok.
        >
        > Regards,
        > Tom

        Reproduced with 7.3.762 on 64-bit Windows 7.

        gvim -N -u NONE -i NONE
        gvim window pops up near middle of screen with 256x80 lines/columns
        <Windows key>+<Left>
        gvim moves to left side of screen, 48x95 lines/columns
        :vert split
        gvim window unnecessarily moves by itself to be somewhat off-screen, still at 48x95

        This also happens with the :vnew command.

        This looks like a bug. Opening a split window should not move the application window.

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • lith
        ... In case somebody cares about this problem, it seemingly also affects tab-related commands like :tabnew. Regards, Tom -- -- You received this message from
        Message 3 of 3 , Mar 5, 2013
        • 0 Attachment
          > > I sometimes use gvim 7.3 @ win7 (64 bit). When I move the gvim window by means of the <windows-key + left/right> key combination to the left or right half of the screen, it seems gvim doesn't properly notice this change. When I invoke any command with :vert prepended (e.g. :vert split), gvim moves the gvim window back to the previous position on the screen.
          >
          > This also happens with the :vnew command.
          >
          > This looks like a bug. Opening a split window should not move the application window.

          In case somebody cares about this problem, it seemingly also affects tab-related commands like :tabnew.

          Regards,
          Tom

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.