Loading ...
Sorry, an error occurred while loading the content.

Re: Build problem with Make_cyg.mak [Was: Re: Can't build with Perl using Make_ming.mak any more]

Expand Messages
  • Ken Takata
    Hi Christian, ... I couldn t compile with this command. Versions of interpreters should be specified like the following: $ make -f Make_cyg.mak -j2
    Message 1 of 7 , Feb 22, 2013
    View Source
    • 0 Attachment
      Hi Christian,

      2013/02/22 Fri 6:21:09 UTC+9 Heptite wrote:

      > make -f Make_cyg.mak -j2 PERL=/cygdrive/c/strawberry/perl \
      > RUBY=/cygdrive/c/Ruby193 RUBY_PLATFORM=i386-mingw32 POSTSCRIPT=yes \
      > DYNAMIC_PERL=yes PYTHON=/cygdrive/c/Python27 OLE=yes XPM=xpm \
      > FEATURES=BIG

      I couldn't compile with this command.
      Versions of interpreters should be specified like the following:

      $ make -f Make_cyg.mak -j2 PERL=/cygdrive/c/strawberry/perl \
      RUBY=/cygdrive/c/Ruby193 POSTSCRIPT=yes DYNAMIC_PERL=yes \
      PYTHON=/cygdrive/c/Python27 OLE=yes XPM=xpm FEATURES=BIG \
      RUBY_VER=19 RUBY_VER_LONG=1.9.1 PYTHON_VER=27 PERL_VER=516

      But I still got the following error:

      /usr/lib/gcc/i686-pc-mingw32/4.5.2/../../../../i686-pc-mingw32/bin/ld: cannot find -lXpm
      collect2: ld returned 1 exit status
      Make_cyg.mak:575: recipe for target `gvim.exe' failed
      make: *** [gvim.exe] Error 1

      After I removed 'XPM=xpm' from the command line, I could build gvim.exe.
      (I didn't notice that Make_cyg.mak could not build with the bundled XPM library.)


      > gobj/eval.o:eval.c:(.text+0x38d4): undefined reference to `_pow'

      Oh, this error comes again!?
      I have no idea with this error.

      Regards,
      Ken Takata

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.