Loading ...
Sorry, an error occurred while loading the content.

Re: vim compilation

Expand Messages
  • W. David Jarvis
    ... James - Forgive the daft response here, but I m having the same problem and don t understand why my ./configure script is forcing me to build the python3
    Message 1 of 4 , Feb 21, 2013
    • 0 Attachment
      On Thursday, December 20, 2012 4:47:11 PM UTC-8, James McCoy wrote:
      > On Thu, Dec 20, 2012 at 03:02:59PM -0500, joe M wrote:
      >
      > > On Thu, Dec 20, 2012 at 1:49 PM, joe M <joe9mail@...> wrote:
      >
      > > > Hello,
      >
      > > >
      >
      > > > The latest mercurial version of vim fails with the below error. python
      >
      > > > --version == 2.7.3
      >
      > > >
      >
      > > > gcc -c -I. -Iproto -DHAVE_CONFIG_H -O2 -pipe -ftracer
      >
      > > > -fgcse-after-reload -march=corei7-avx -mcx16 -msahf -mno-movbe
      >
      > > > -mno-aes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4
      >
      > > > -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -msse4.2
      >
      > > > -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param
      >
      > > > l1-cache-size=32 --param l1-cache-line-size=64 --param
      >
      > > > l2-cache-size=3072 -mtune=corei7-avx -U_FORTIFY_SOURCE
      >
      > > > -D_FORTIFY_SOURCE=1 -I/usr/include -D_LARGEFILE64_SOURCE=1 -o
      >
      > > > objects/if_tcl.o if_tcl.c
      >
      > > > if_python3.c:84:0: warning: "PyString_Check" redefined [enabled by default]
      >
      > > > In file included from /usr/include/python2.7/Python.h:94:0,
      >
      > > > from if_python3.c:59:
      >
      > > > /usr/include/python2.7/stringobject.h:58:0: note: this is the location
      >
      > > > of the previous definition
      >
      > >
      >
      > > As an fyi, The above error is happening when I have the compilation
      >
      > > option "--enable-python3interp=dynamic "
      >
      >
      >
      > Why are you trying to build the Python3 bindings using Python2?
      >
      >
      >
      > Cheers,
      >
      > --
      >
      > James
      >
      > GPG Key: 4096R/331BA3DB 2011-12-05 James McCoy <jamessan@...>

      James -

      Forgive the daft response here, but I'm having the same problem and don't understand why my ./configure script is forcing me to build the python3 bindings using python2. I've tried to configure explicitly with:

      ./configure --enable-python3interp=yes vi_cv_path_python3=/usr/local/bin/python3 --with-python3-config-dir=/usr/local/Cellar/python3/3.2.3/lib/python3.2/config-3.2m

      But this gets me the same problem, e.g.:

      gcc -c -I. -Iproto -DHAVE_CONFIG_H -DMACOS_X_UNIX -no-cpp-precomp -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -I/Users/jarvis/.virtualenvs/ak-sci-env/include/python2.7 -DPYTHON3_HOME=L\"/Users/jarvis/.virtualenvs/ak-sci-env\" -o objects/if_python3.o if_python3.c
      if_python3.c:84:1: warning: "PyString_Check" redefined
      In file included from /Users/jarvis/.virtualenvs/ak-sci-env/include/python2.7/Python.h:94,
      from if_python3.c:59:
      /Users/jarvis/.virtualenvs/ak-sci-env/include/python2.7/stringobject.h:58:1: warning: this is the location of the previous definition
      if_python3.c:91:1: warning: "PyInt_Check" redefined
      In file included from /Users/jarvis/.virtualenvs/ak-sci-env/include/python2.7/Python.h:86,
      from if_python3.c:59:
      /Users/jarvis/.virtualenvs/ak-sci-env/include/python2.7/intobject.h:30:1: warning: this is the location of the previous definition
      if_python3.c: In function ‘Python3_Init’:
      ...

      I had an initial suspicion that my virtualenv might have been the source of the problem, but even deactivating and trying to install just to the system bindings doesn't work for me. Any thoughts on what my root cause is here?

      Thanks!

      - WDJ

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.