Loading ...
Sorry, an error occurred while loading the content.

Issue 114 in vim: vim breaks statically-linked ruby by stripping symbols

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 114 by mistyde...@gmail.com: vim breaks statically-linked ruby by stripping symbols
    Message 1 of 2 , Feb 21, 2013
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 114 by mistyde...@...: vim breaks statically-linked ruby by
      stripping symbols
      http://code.google.com/p/vim/issues/detail?id=114

      When vim statically links against ruby, for instance if the selected ruby
      interpreter doesn't provide shared libraries, stripping symbols during
      `make install` will result in the vim binary segfault when calling any
      ruby functions.

      What steps will reproduce the problem?
      1. Configure vim with --enable-rubyinterp
      2. make
      3. make install
      4. In vim, enter: :ruby p RUBY_VERSION

      What is the expected output? What do you see instead?

      vim will instantly segfault. gdb reveals that vim is unable to find
      the '_rb_encdb_declare' symbol.

      What version of the product are you using? On what operating system?

      vim 7.3.831 using Mac OS X 10.6.8.

      Please provide any additional information below.

      If `make install` is run with stripping disabled, the resulting binary will
      work as expected.

      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • vim@...
      Comment #1 on issue 114 by chrisbr...@googlemail.com: vim breaks statically-linked ruby by stripping symbols https://code.google.com/p/vim/issues/detail?id=114
      Message 2 of 2 , Oct 9, 2014
      • 0 Attachment
        Comment #1 on issue 114 by chrisbr...@...: vim breaks
        statically-linked ruby by stripping symbols
        https://code.google.com/p/vim/issues/detail?id=114

        Does this still happen? What ruby version are you using?

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      Your message has been successfully submitted and would be delivered to recipients shortly.