Loading ...
Sorry, an error occurred while loading the content.

Re: Patch 7.3.821

Expand Messages
  • Steve Hall
    ... Works for me. Just curious why this wouldn t be the default instead of the option? (Having to specify STATIC_STDCPLUS=yes at the build line is always
    Message 1 of 8 , Feb 18, 2013
    • 0 Attachment
      On 02/16/2013 06:16 PM, Bram Moolenaar wrote:
      >
      > Patch 7.3.821
      > Problem: Build with OLE and Cygwin is broken. (Steve Hall)
      > Solution: Select static or shared stdc library. (Ken Takta)
      > Files: src/Make_cyg.mak

      Works for me.

      Just curious why this wouldn't be the default instead of the option?
      (Having to specify STATIC_STDCPLUS=yes at the build line is always
      required.)


      --
      Steve Hall [ digitect dancingpaper com ]

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ken Takata
      Hi Steve, ... I don t know why. I just copied it from Make_ming.mak. ... Actually It is not required, if you use stdc++ DLLs. You may find the required DLLs in
      Message 2 of 8 , Feb 18, 2013
      • 0 Attachment
        Hi Steve,

        2013/02/18 Mon 22:41:13 UTC+9 Steve Hall wrote:

        > Just curious why this wouldn't be the default instead of the option?

        I don't know why. I just copied it from Make_ming.mak.


        > (Having to specify STATIC_STDCPLUS=yes at the build line is always
        > required.)

        Actually It is not required, if you use stdc++ DLLs.
        You may find the required DLLs in the following directory:
        C:\cygwin\usr\i686-pc-mingw32\sys-root\mingw\bin .

        Regards,
        Ken Takata

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Steve Hall
        Hi Ken, ... Just tested this, and reporting for the record. It appears the var is required to build binaries/installers that would be installed without Cygwin
        Message 3 of 8 , Feb 20, 2013
        • 0 Attachment
          Hi Ken,

          On Mon, Feb 18, 2013 at 9:24 AM, Ken Takata <kentkt@...> wrote:
          > 2013/02/18 Mon 22:41:13 UTC+9 Steve Hall wrote:
          > >
          > > (Having to specify STATIC_STDCPLUS=yes at the build line is always
          > > required.)
          > Actually It is not required, if you use stdc++ DLLs.
          > You may find the required DLLs in the following directory:
          > C:\cygwin\usr\i686-pc-mingw32\sys-root\mingw\bin .

          Just tested this, and reporting for the record. It appears the var is
          required to build binaries/installers that would be installed without
          Cygwin on path.


          -- 
          Steve Hall  [ digitect dancingpaper com ]

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        Your message has been successfully submitted and would be delivered to recipients shortly.