Loading ...
Sorry, an error occurred while loading the content.

BUG: Cursor disappears when I split the window in GVIM.

Expand Messages
  • mind entropy
    Hi, When I split the window my cursor disappears. The cursor is still functional but has just disappeared. This is tested because when I scroll I can see the
    Message 1 of 5 , Feb 16, 2013
    • 0 Attachment
      Hi,

        When I split the window my cursor disappears. The cursor is still functional but has just disappeared. This is tested because when I scroll I can see the brace match happening. This is usually triggered when I get NerdTree window and after I close it the cursor disappears. The only way to fix this now is just minimize and maximize the window and the cursor reappears. I am using it in fluxbox under ubuntu 12.10. My VIM version is 7.3.547

      Thanks,
      Gautam.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Tony Mechelynck
      ... Do you mean the text cursor (at the intersection of cursorline and cursorcolumn if you use them) or the mouse pointer? It is a known feature that gvim
      Message 2 of 5 , Feb 17, 2013
      • 0 Attachment
        On 17/02/13 08:54, mind entropy wrote:
        > Hi,
        >
        > When I split the window my cursor disappears. The cursor is still
        > functional but has just disappeared. This is tested because when I
        > scroll I can see the brace match happening. This is usually triggered
        > when I get NerdTree window and after I close it the cursor disappears.
        > The only way to fix this now is just minimize and maximize the window
        > and the cursor reappears. I am using it in fluxbox under ubuntu 12.10.
        > My VIM version is 7.3.547
        >
        > Thanks,
        > Gautam.

        Do you mean the text cursor (at the intersection of 'cursorline' and
        'cursorcolumn' if you use them) or the mouse pointer? It is a known
        feature that gvim hides the mouse pointer whenever you haven't used the
        mouse for a certain time.

        If the former, ":set cuc cul" (without the quotes) might help by giving
        you "crosshairs" on the cursor location. If the latter, just move the
        mouse and its pointer will reappear.


        Best regards,
        Tony.
        --
        Beer & pretzels can't be served at the same time in any bar or restaurant.
        [real standing law in North Dakota, United States of America]

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        Hi mind! ... What happens if you press ctrl-l or type :redraw (with and without the ! attribute)? Mit freundlichen Grüßen Christian -- Glück bedeutet
        Message 3 of 5 , Feb 17, 2013
        • 0 Attachment
          Hi mind!

          On So, 17 Feb 2013, mind entropy wrote:

          > Hi,
          >
          > When I split the window my cursor disappears. The cursor is still
          > functional but has just disappeared. This is tested because when I scroll I
          > can see the brace match happening. This is usually triggered when I get
          > NerdTree window and after I close it the cursor disappears. The only way to
          > fix this now is just minimize and maximize the window and the cursor
          > reappears. I am using it in fluxbox under ubuntu 12.10. My VIM version is
          > 7.3.547

          What happens if you press ctrl-l or type :redraw (with and without the !
          attribute)?

          Mit freundlichen Grüßen
          Christian
          --
          Glück bedeutet Gelassenheit. Wer glücklich sein will, muß Zeit für die
          Ewigkeit haben.
          -- Truman Capote

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • mind entropy
          On Sun, Feb 17, 2013 at 3:14 PM, Tony Mechelynck
          Message 4 of 5 , Feb 17, 2013
          • 0 Attachment


            On Sun, Feb 17, 2013 at 3:14 PM, Tony Mechelynck <antoine.mechelynck@...> wrote:
            On 17/02/13 08:54, mind entropy wrote:
            Hi,

               When I split the window my cursor disappears. The cursor is still
            functional but has just disappeared. This is tested because when I
            scroll I can see the brace match happening. This is usually triggered
            when I get NerdTree window and after I close it the cursor disappears.
            The only way to fix this now is just minimize and maximize the window
            and the cursor reappears. I am using it in fluxbox under ubuntu 12.10.
            My VIM version is 7.3.547

            Thanks,
            Gautam.

            Do you mean the text cursor (at the intersection of 'cursorline' and 'cursorcolumn' if you use them) or the mouse pointer? It is a known feature that gvim hides the mouse pointer whenever you haven't used the mouse for a certain time.

             Its the text cursor. I am not using the cursorline and cursorcolumn feature. The text cursor is the rectangle.
             
            If the former, ":set cuc cul" (without the quotes) might help by giving you "crosshairs" on the cursor location. If the latter, just move the mouse and its pointer will reappear.

             I just want the plain old cursor.

            Best regards,
            Tony.
            --
            Beer & pretzels can't be served at the same time in any bar or restaurant.
                            [real standing law in North Dakota, United States of America]


            Thanks,
            Gautam.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          • mind entropy
            ... the top right of the window and then hit it again to maximize will the cursor appear. Thanks, Gautam. -- -- You received this message from the vim_dev
            Message 5 of 5 , Feb 17, 2013
            • 0 Attachment



              On Sun, Feb 17, 2013 at 6:11 PM, Christian Brabandt <cblists@...> wrote:
              Hi mind!

              On So, 17 Feb 2013, mind entropy wrote:

              > Hi,
              >
              >   When I split the window my cursor disappears. The cursor is still
              > functional but has just disappeared. This is tested because when I scroll I
              > can see the brace match happening. This is usually triggered when I get
              > NerdTree window and after I close it the cursor disappears. The only way to
              > fix this now is just minimize and maximize the window and the cursor
              > reappears. I am using it in fluxbox under ubuntu 12.10. My VIM version is
              > 7.3.547

              What happens if you press ctrl-l or type :redraw (with and without the !
              attribute)?

               Nothing happens. Only after I resize the screen i.e I click the box on the top right of the window and then hit it again to maximize will the cursor appear.

              Thanks,
              Gautam.


              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
               
               
            Your message has been successfully submitted and would be delivered to recipients shortly.