Loading ...
Sorry, an error occurred while loading the content.

Issue 108 in vim: rst syntax file, completion

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 108 by mortba...@gmail.com: rst syntax file, completion
    Message 1 of 9 , Feb 15, 2013
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 108 by mortba...@...: rst syntax file, completion
      http://code.google.com/p/vim/issues/detail?id=108

      The completion ^x^p doesn't work for words with some special characters
      like รค with rst syntax highlighting. It works fine with other syntax files
      but not with rst. Attached is an example document where the comletion will
      fail for the last word in the text.

      I have tried to figure out where the problem could be, but I have no idea,
      I'm already happy to have tracked it down to the rst syntax file
      http://code.google.com/p/vim/source/browse/runtime/syntax/rst.vim.

      Thanks

      Attachments:
      example.rst 111 bytes

      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • vim@...
      Comment #1 on issue 108 by chrisbr...@googlemail.com: rst syntax file, completion http://code.google.com/p/vim/issues/detail?id=108 Problem is, the rst syntax
      Message 2 of 9 , Feb 15, 2013
      • 0 Attachment
        Comment #1 on issue 108 by chrisbr...@...: rst syntax file,
        completion
        http://code.google.com/p/vim/issues/detail?id=108

        Problem is, the rst syntax file includes the lisp syntax file, which sets
        the 'iskeyword' option to unwanted values. I think, the syntax script
        should reset those settings back.

        As a workaround, create a file ~/.vim/after/syntax/rst.vim and put into it
        :set isk&vim

        Then the keyword completion should work again.

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • vim@...
        Comment #2 on issue 108 by chrisbr...@googlemail.com: rst syntax file, completion http://code.google.com/p/vim/issues/detail?id=108 BTW, this issue should
        Message 3 of 9 , Feb 16, 2013
        • 0 Attachment
          Comment #2 on issue 108 by chrisbr...@...: rst syntax file,
          completion
          http://code.google.com/p/vim/issues/detail?id=108

          BTW, this issue should probably be forwarded to the maintainer of the rst
          file (which you can find in the top of the syntax file)

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • vim@...
          Comment #3 on issue 108 by mortba...@gmail.com: rst syntax file, completion http://code.google.com/p/vim/issues/detail?id=108 Your workaround works like a
          Message 4 of 9 , Feb 18, 2013
          • 0 Attachment
            Comment #3 on issue 108 by mortba...@...: rst syntax file, completion
            http://code.google.com/p/vim/issues/detail?id=108

            Your workaround works like a charm, thank you. I sent a mail to the
            maintainer.

            --
            You received this message because this project is configured to send all
            issue notifications to this address.
            You may adjust your notification preferences at:
            https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • vim@...
            Comment #4 on issue 108 by nikolai....@gmail.com: rst syntax file, completion http://code.google.com/p/vim/issues/detail?id=108 It sounds more like
            Message 5 of 9 , Feb 18, 2013
            • 0 Attachment
              Comment #4 on issue 108 by nikolai....@...: rst syntax file,
              completion
              http://code.google.com/p/vim/issues/detail?id=108

              It sounds more like syntax/lisp.vim should be fixed to not
              change 'iskeyword' to the value that it changes it to.

              Also, you can exclude lisp from the languages that you want to have
              syntax/rst.vim support for code blocks.

              --
              You received this message because this project is configured to send all
              issue notifications to this address.
              You may adjust your notification preferences at:
              https://code.google.com/hosting/settings

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • vim@...
              Comment #5 on issue 108 by mortba...@gmail.com: rst syntax file, completion http://code.google.com/p/vim/issues/detail?id=108 I see. Well I also sent a mail to
              Message 6 of 9 , Feb 18, 2013
              • 0 Attachment
                Comment #5 on issue 108 by mortba...@...: rst syntax file, completion
                http://code.google.com/p/vim/issues/detail?id=108

                I see. Well I also sent a mail to the lisp syntax file maintainer maybe he
                will fix it.


                --
                You received this message because this project is configured to send all
                issue notifications to this address.
                You may adjust your notification preferences at:
                https://code.google.com/hosting/settings

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • vim@...
                Updates: Status: Invalid Comment #6 on issue 108 by chrisbr...@googlemail.com: rst syntax file, completion https://code.google.com/p/vim/issues/detail?id=108
                Message 7 of 9 , Sep 30, 2014
                • 0 Attachment
                  Updates:
                  Status: Invalid

                  Comment #6 on issue 108 by chrisbr...@...: rst syntax file,
                  completion
                  https://code.google.com/p/vim/issues/detail?id=108

                  Closing as invalid for now.

                  --
                  You received this message because this project is configured to send all
                  issue notifications to this address.
                  You may adjust your notification preferences at:
                  https://code.google.com/hosting/settings

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                • vim@...
                  Updates: Labels: Runtime Comment #7 on issue 108 by chrisbr...@googlemail.com: rst syntax file, completion https://code.google.com/p/vim/issues/detail?id=108
                  Message 8 of 9 , Sep 30, 2014
                  • 0 Attachment
                    Updates:
                    Labels: Runtime

                    Comment #7 on issue 108 by chrisbr...@...: rst syntax file,
                    completion
                    https://code.google.com/p/vim/issues/detail?id=108

                    (No comment was entered for this change.)

                    --
                    You received this message because this project is configured to send all
                    issue notifications to this address.
                    You may adjust your notification preferences at:
                    https://code.google.com/hosting/settings

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/d/optout.
                  • vim@...
                    Updates: Cc: drc...@campbellfamily.biz Comment #8 on issue 108 by chrisbr...@googlemail.com: rst syntax file, completion
                    Message 9 of 9 , Oct 1, 2014
                    • 0 Attachment
                      Updates:
                      Cc: drc...@...

                      Comment #8 on issue 108 by chrisbr...@...: rst syntax file,
                      completion
                      https://code.google.com/p/vim/issues/detail?id=108

                      Here is a patch, that guards the 'rst' syntax file from a changed 'isk'
                      option by sourcing other syntax files.
                      @Charles, you might want to review setting the 'isk' option in the lisp
                      syntax file.

                      Attachments:
                      rst.diff 844 bytes

                      --
                      You received this message because this project is configured to send all
                      issue notifications to this address.
                      You may adjust your notification preferences at:
                      https://code.google.com/hosting/settings

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/d/optout.
                    Your message has been successfully submitted and would be delivered to recipients shortly.