Loading ...
Sorry, an error occurred while loading the content.

Re: Patch 7.3.820

Expand Messages
  • Ken Takata
    Hi Steve, ... The default compiler for Make_cyg.mak was changed from gcc to i686-pc-mingw32-gcc in 7.3.814. It is because the latest cygwin-gcc (gcc-4)
    Message 1 of 8 , Feb 15, 2013
    • 0 Attachment
      Hi Steve,

      2013/02/15 Fri 22:54:17 UTC+9 Steve Hall wrote:

      > Perhaps it was an earlier patch (my previous build was .801), but my
      > build with Cygwin now is broken:
      >
      > mkdir -p obj i686-pc-mingw32-gcc -c -O3 -fomit-frame-pointer
      > -freg-struct-return -fno-strength-reduce -DWIN32 -DHAVE_PATHDEF
      > -DFEAT_H UGE -DWINVER=0x0500 -D_WIN32_WINNT=0x0500 -DFEAT_PERL
      > -DDYNAMIC_PERL -DDYNAMIC_PERL_DLL=\"perl58.dll\" -DFEAT_PYTHON -D
      > DYNAMIC_PYTHON -DDYNAMIC_PYTHON_DLL=\"python27.dll\" -DFEAT_RUBY
      > -DDYNAMIC_RUBY -DDYNAMIC_RUBY_DLL=\"msvcrt-ruby191.dll\ "
      > -DDYNAMIC_RUBY_VER=191 -DFEAT_LUA -DDYNAMIC_LUA
      > -DDYNAMIC_LUA_DLL=\"lua51.dll\" -DDYNAMIC_GETTEXT -DDYNAMIC_ICONV -DFE
      > AT_MBYTE -DFEAT_MBYTE_IME -DDYNAMIC_IME -DFEAT_CSCOPE -DFEAT_OLE
      > -march=i386 -Iproto -I/cygdrive/c/strawberry/perl/lib/C ORE
      > -I/cygdrive/c/Ruby193/lib/ruby/1.9.1/i386-mingw32
      > -I/cygdrive/c/Ruby193/include/ruby-1.9.1 -I/cygdrive/c/Ruby193/inc
      > lude/ruby-1.9.1/i386-mingw32 -I/cygdrive/c/PROGRA~2/Lua/5.1/include -s
      > -mno-cygwin blowfish.c -o obj/blowfish.o /bin/sh: i686-pc-mingw32-gcc:
      > command not found
      > Make_cyg.mak:613: recipe for target `obj/blowfish.o' failed
      > make: *** [obj/blowfish.o] Error 127

      The default compiler for Make_cyg.mak was changed from 'gcc' to
      'i686-pc-mingw32-gcc' in 7.3.814. It is because the latest
      cygwin-gcc (gcc-4) does not support -mno-cygwin option anymore.

      You may do one of the following:

      1. Install mingw-gcc-g++ package.
      i686-pc-mingw32-gcc (4.5.2) can be used.

      2. Specify the old version of gcc explicitly.
      E.g.
      $ make -f Make_cyg.mak CC=gcc-3

      Regards,
      Ken Takata

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Steve Hall
      ... [...] ... This solved my build error, but now I have a dependency problem: The program can t start because libstdc++-6.dll is missing from your computer.
      Message 2 of 8 , Feb 15, 2013
      • 0 Attachment
        On Fri, Feb 15, 2013 at 9:58 AM, Ken Takata <kentkt@...> wrote:
        > 2013/02/15 Fri 22:54:17 UTC+9 Steve Hall wrote:
        >
        >> Perhaps it was an earlier patch (my previous build was .801), but my
        >> build with Cygwin now is broken:
        [...]
        >> Make_cyg.mak:613: recipe for target `obj/blowfish.o' failed
        >> make: *** [obj/blowfish.o] Error 127
        >
        > The default compiler for Make_cyg.mak was changed from 'gcc' to
        > 'i686-pc-mingw32-gcc' in 7.3.814. It is because the latest
        > cygwin-gcc (gcc-4) does not support -mno-cygwin option anymore.
        >
        > You may do one of the following:
        >
        > 1. Install mingw-gcc-g++ package.
        > i686-pc-mingw32-gcc (4.5.2) can be used.

        This solved my build error, but now I have a dependency problem:

        The program can't start because libstdc++-6.dll is missing from your
        computer. Try reinstalling the program to fix this problem.

        I'm trying to build Vim binaries without library dependencies. Is it
        going to be possible with Cygwin's mingw-gcc-g++? Not sure why this
        was changed.


        > 2. Specify the old version of gcc explicitly.
        > E.g.
        > $ make -f Make_cyg.mak CC=gcc-3

        I wonder how long this will be supported. Is it, too, going to break
        in the near future?


        --
        Steve Hall [ digitect dancingpaper com ]

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Ken Takata
        Hi Steve, ... Do you enable OLE? Sorry, I didn t care about that. Please try attached patch with an option STATIC_STDCPLUS=yes. $ make -f Make_cyg.mak
        Message 3 of 8 , Feb 15, 2013
        • 0 Attachment
          Hi Steve,

          2013/02/16 Sat 2:12:54 UTC+9 Steve Hall wrote:

          > > 1. Install mingw-gcc-g++ package.
          > > i686-pc-mingw32-gcc (4.5.2) can be used.
          >
          > This solved my build error, but now I have a dependency problem:
          >
          > The program can't start because libstdc++-6.dll is missing from your
          > computer. Try reinstalling the program to fix this problem.
          >
          > I'm trying to build Vim binaries without library dependencies. Is it
          > going to be possible with Cygwin's mingw-gcc-g++? Not sure why this
          > was changed.

          Do you enable OLE? Sorry, I didn't care about that.
          Please try attached patch with an option STATIC_STDCPLUS=yes.

          $ make -f Make_cyg.mak STATIC_STDCPLUS=yes

          This option is the same as Make_ming.mak.


          > > 2. Specify the old version of gcc explicitly.
          > > E.g.
          > > $ make -f Make_cyg.mak CC=gcc-3
          >
          > I wonder how long this will be supported. Is it, too, going to break
          > in the near future?

          I'm not sure, but I think it's better to use the new one.

          Regards,
          Ken Takata

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Steve Hall
          ... This breaks my gui build (gvim.exe) with OLE=yes reporting the following: gobj/if_ole.o:if_ole.cpp:(.text+0x1384): undefined reference to `operator
          Message 4 of 8 , Feb 15, 2013
          • 0 Attachment
            On Fri, Feb 15, 2013 at 12:47 PM, Ken Takata <kentkt@...> wrote:
            >
            > Do you enable OLE? Sorry, I didn't care about that.
            > Please try attached patch with an option STATIC_STDCPLUS=yes.
            >
            > $ make -f Make_cyg.mak STATIC_STDCPLUS=yes
            >
            > This option is the same as Make_ming.mak.

            This breaks my gui build (gvim.exe) with OLE=yes reporting the
            following:

            gobj/if_ole.o:if_ole.cpp:(.text+0x1384): undefined reference to
            `operator new(unsigned int)'
            gobj/if_ole.o:if_ole.cpp:(.text+0x151d): undefined reference to
            `operator delete(void*)'
            gobj/if_ole.o:if_ole.cpp:(.text+0x1572): undefined reference to
            `operator delete(void*)'
            gobj/if_ole.o:if_ole.cpp:(.text+0x1593): undefined reference to
            `operator new(unsigned int)'
            gobj/if_ole.o:if_ole.cpp:(.text+0x1aa0): undefined reference to
            `operator new(unsigned int)'
            gobj/if_ole.o:if_ole.cpp:(.text+0x1b8e): undefined reference to
            `operator delete(void*)'
            gobj/if_ole.o:if_ole.cpp:(.text+0x1bad): undefined reference to
            `operator delete(void*)'
            gobj/if_ole.o:if_ole.cpp:(.text+0x1cd3): undefined reference to
            `operator delete(void*)'
            gobj/if_ole.o:if_ole.cpp:(.text+0x1cee): undefined reference to
            `operator delete(void*)'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTI6CVimCF[typeinfo for
            CVimCF]+0x0): undefined reference to `vtable for
            __cxxabiv1::__si_class_type_info'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTI4CVim[typeinfo for CVim]+0x0):
            undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTV13IClassFactory[vtable for
            IClassFactory]+0x8): undefined reference to `___cxa_pure_virtual'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTV13IClassFactory[vtable for
            IClassFactory]+0xc): undefined reference to `___cxa_pure_virtual'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTV13IClassFactory[vtable for
            IClassFactory]+0x10): undefined reference to `___cxa_pure_virtual'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTV13IClassFactory[vtable for
            IClassFactory]+0x14): undefined reference to `___cxa_pure_virtual'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTV13IClassFactory[vtable for
            IClassFactory]+0x18): undefined reference to `___cxa_pure_virtual'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTV8IUnknown[vtable for
            IUnknown]+0x8): more undefined references to `___cxa_pure_virtual'
            follow
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTI13IClassFactory[typeinfo for
            IClassFactory]+0x0): undefined reference to `vtable for
            __cxxabiv1::__si_class_type_info'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTI4IVim[typeinfo for IVim]+0x0):
            undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTI8IUnknown[typeinfo for
            IUnknown]+0x0): undefined reference to `vtable for
            __cxxabiv1::__class_type_info'
            gobj/if_ole.o:if_ole.cpp:(.rdata$_ZTI9IDispatch[typeinfo for
            IDispatch]+0x0): undefined reference to `vtable for
            __cxxabiv1::__si_class_type_info'
            collect2: ld returned 1 exit status
            Make_cyg.mak:567: recipe for target `gvim.exe' failed
            make: *** [gvim.exe] Error 1


            --
            Steve Hall [ digitect dancingpaper com ]

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Ken Takata
            Hi Steve, ... Sorry. There was a mistake in my patch. I have updated the patch. Please try this. Regards, Ken Takata -- -- You received this message from the
            Message 5 of 8 , Feb 15, 2013
            • 0 Attachment
              Hi Steve,

              2013/02/16 Sat 5:45:48 UTC+9 Steve Hall wrote:

              > >
              > > Do you enable OLE? Sorry, I didn't care about that.
              > > Please try attached patch with an option STATIC_STDCPLUS=yes.
              > >
              > > $ make -f Make_cyg.mak STATIC_STDCPLUS=yes
              > >
              > > This option is the same as Make_ming.mak.
              >
              > This breaks my gui build (gvim.exe) with OLE=yes reporting the
              > following:

              Sorry. There was a mistake in my patch.
              I have updated the patch. Please try this.

              Regards,
              Ken Takata

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Bram Moolenaar
              ... Thanks, I ll include it. -- SUPERIMPOSE England AD 787 . After a few more seconds we hear hoofbeats in the distance. They come slowly closer. Then out
              Message 6 of 8 , Feb 16, 2013
              • 0 Attachment
                Ken Takata wrote:

                > Hi Steve,
                >
                > 2013/02/16 Sat 5:45:48 UTC+9 Steve Hall wrote:
                >
                > > >
                > > > Do you enable OLE? Sorry, I didn't care about that.
                > > > Please try attached patch with an option STATIC_STDCPLUS=yes.
                > > >
                > > > $ make -f Make_cyg.mak STATIC_STDCPLUS=yes
                > > >
                > > > This option is the same as Make_ming.mak.
                > >
                > > This breaks my gui build (gvim.exe) with OLE=yes reporting the
                > > following:
                >
                > Sorry. There was a mistake in my patch.
                > I have updated the patch. Please try this.

                Thanks, I'll include it.

                --
                SUPERIMPOSE "England AD 787". After a few more seconds we hear hoofbeats in
                the distance. They come slowly closer. Then out of the mist comes KING
                ARTHUR followed by a SERVANT who is banging two half coconuts together.
                "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

                /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                \\\ an exciting new programming language -- http://www.Zimbu.org ///
                \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.