Loading ...
Sorry, an error occurred while loading the content.

Re: what happened to luxi mono?

Expand Messages
  • Dominique Pellé
    ... Using xubuntu-12.10: $ locate glibconfig.h /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h $ apt-file search
    Message 1 of 23 , Feb 11, 2013
    • 0 Attachment
      Charles Campbell wrote:

      > and I cannot find a glibconfig.h under /usr/include (literally; I used the
      > find command).


      Using xubuntu-12.10:

      $ locate glibconfig.h
      /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h

      $ apt-file search /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h
      libglib2.0-dev: /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h

      So the package providing that header file is "libglib2.0-dev".
      You can try to include a similar package for your distribution.

      Regards
      Dominique

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Charles Campbell
      ... I ve tried sudo yum-builddep vim-gnome; that results in: No such package(s): vim-gnome I then tried: sudo yum-builddep vim This command actually did
      Message 2 of 23 , Feb 12, 2013
      • 0 Attachment
        Dominique Pellé wrote:
        > On Mon, Feb 11, 2013 at 4:11 PM, Charles Campbell
        > <Charles.E.Campbell@...> wrote:
        >> Charles Campbell wrote:
        >>> Christian J. Robinson wrote:
        >>>> On Fri, 1 Feb 2013, Charles Campbell wrote:
        >>>>
        >>>>> My vim's status:
        >>>>>
        >>>>> * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on
        >>>>> my
        >>>>> home computer)
        >>>> *snip*
        >>>>
        >>>> If your Vim is built with Motif, it simply will not be able to use the
        >>>> "new style" fonts like "Luxi Mono"; you will be stuck with the old
        >>>> style complicated font names with a lot of dashes. The two styles
        >>>> have specific names but I never really remember what they are.
        >>>>
        >>>> So the question is, why is your Vim no longer building with GTK, but
        >>>> rather with Motif? (It can not be built with both.)
        >>>>
        >>> I think this is a promising line of inquiry.
        >>>
        >>> First, checking on presence of gtk2...
        >>>
        >>> console/ xorn? rpm -q gtk2
        >>> gtk2-2.18.9-10.el6.x86_64
        >>> gtk2-2.18.9-10.el6.i686
        >>> console/ xorn? rpm -q gtk2-devel
        >>> gtk2-devel-2.18.9-10.el6.x86_64
        >>>
        >>> So it seems both gtk2 and the developer package are installed.
        >>>
        >> Found out some more about the loss of Luxi Mono.
        >>
        >> As I mentioned earlier, this problem occurred on a work computer; it has
        >> been set to automatically update (Scientific Linux 6.3).
        >>
        >> Configure expects a number of header files to be in /usr/include, but the
        >> update has pushed the gtk related ones to /usr/include/gtk-2.0. I've made
        >> links:
        >>
        >> gtk -> gtk-2.0/gtk/
        >> lrwxrwxrwx 1 root root 11 Feb 11 09:53 gdk -> gtk-2.0/gdk/
        >> lrwxrwxrwx 1 root root 18 Feb 11 09:53 gdk-pixbuf ->
        >> gtk-2.0/gdk-pixbuf/
        >> lrwxrwxrwx 1 root root 23 Feb 11 09:54 gdk-pixbuf-xlib ->
        >> gtk-2.0/gdk-pixbuf-xlib/
        >> lrwxrwxrwx 1 root root 12 Feb 11 09:58 gio -> glib-2.0/gio/
        >> lrwxrwxrwx 1 root root 13 Feb 11 09:58 glib -> glib-2.0/glib/
        >> lrwxrwxrwx 1 root root 16 Feb 11 09:58 gobject -> glib-2.0/gobject/
        >> lrwxrwxrwx 1 root root 22 Feb 11 09:58 glib-object.h ->
        >> glib-2.0/glib-object.h
        >> lrwxrwxrwx 1 root root 18 Feb 11 09:59 gmodule.h -> glib-2.0/gmodule.h
        >> lrwxrwxrwx 1 root root 15 Feb 11 10:00 glib.h -> glib-2.0/glib.h
        >>
        >> Unfortunately, this isn't quite adequate. I'm still getting an error:
        >>
        >> || In file included from /usr/include/glib/galloca.h:34,
        >> || from /usr/include/glib.h:32,
        >> || from /usr/include/gobject/gtype.h:26,
        >> || from /usr/include/gobject/gboxed.h:26,
        >> || from /usr/include/glib-object.h:25,
        >> || from /usr/include/gio/gioenums.h:30,
        >> || from /usr/include/gio/giotypes.h:30,
        >> || from /usr/include/gio/gio.h:28,
        >> || from /usr/include/gdk/gdkapplaunchcontext.h:30,
        >> || from /usr/include/gdk/gdk.h:32,
        >> || from /usr/include/gtk/gtk.h:32,
        >> || from conftest.c:23:
        >> /usr/include/glib-2.0/glib/gtypes.h|34 col 24 error| glibconfig.h: No such
        >> file or directory
        >>
        >> Anyway, so configure decides that gtk isn't available, gui is not enabled,
        >> and Luxi Mono is no longer available to vim (although it is on my computer).
        >>
        >> Regards,
        >> C Campbell
        >>
        >>
        >> and I cannot find a glibconfig.h under /usr/include (literally; I used the
        >> find command).
        >>
        > I don't know much about the "Scientific Linux" distribution.
        > But on Ubuntu, it is possible to do...
        >
        > $ sudo apt-get build-dep vim-gnome
        >
        > ... which installs all packages required to be able to build vim-gnome.
        >
        > This installs gtk2 among plenty of other things if not already installed.
        >
        > Doing a google search suggests that "yum-builddep" is the equivalent
        > feature on Scientific Linux.
        >
        > So have you tried the following command?
        >
        > $ sudo yum-builddep vim-gnome
        >
        > (not sure whether "vim-gnome" is the package name on your distrib for the
        > GTK2 version of Vim).
        >
        > Then should you need to clean the configure cache and rebuild Vim
        > from sources:
        >
        > $ cd vim
        > $ rm -f src/auto/config.cache
        > $ ./configure --with-feature=huge --enable-gui=gtk2
        >

        I've tried sudo yum-builddep vim-gnome; that results in: No such
        package(s): vim-gnome
        I then tried: sudo yum-builddep vim

        This command actually did result in installing gpm-devel ; however, that
        wasn't necessary before to build an X11 capable version and

        make distclean
        ./configure --with-features=huge --enable-gui=gtk2
        --enable-gnome-check --enable-perlinterp --enable-pythoninterp
        --enable-rubyinterp --enable-cscope
        make

        still fails to build a gnome-capable vim (like it used to do). Removing
        "--enable-gui=gtk2" results in a motif-enabled vim (ie. Luxi Mono still
        absent).

        Thank you for helping, though,
        Chip Campbell

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Charles Campbell
        ... I used yum to install yum -y install glib.x86_64 yum -y install glib-devel.x86_64 (there was no glib2). Still, making distclean and making vim still
        Message 3 of 23 , Feb 12, 2013
        • 0 Attachment
          Dominique Pellé wrote:
          > Charles Campbell wrote:
          >
          >> and I cannot find a glibconfig.h under /usr/include (literally; I used the
          >> find command).
          >
          > Using xubuntu-12.10:
          >
          > $ locate glibconfig.h
          > /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h
          >
          > $ apt-file search /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h
          > libglib2.0-dev: /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h
          >
          > So the package providing that header file is "libglib2.0-dev".
          > You can try to include a similar package for your distribution.
          >
          I used yum to install

          yum -y install glib.x86_64
          yum -y install glib-devel.x86_64

          (there was no glib2). Still, making distclean and making vim still
          results in a not-gui-enabled vim (unless I remove the --enable-gui=gtk2
          from the configure command) and no glibconfig.h under /usr/include anywhere.

          cec/ xorn? yum -y install gtk2.x86_64
          Loaded plugins: refresh-packagekit
          Setting up Install Process
          Package gtk2-2.18.9-10.el6.x86_64 already installed and latest version
          Nothing to do
          cec/ xorn? yum -y install gtk2-devel.x86_64
          Loaded plugins: refresh-packagekit
          Setting up Install Process
          Package gtk2-devel-2.18.9-10.el6.x86_64 already installed and latest version
          Nothing to do

          Thank you for helping,
          Chip Campbell

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • James McCoy
          On Feb 12, 2013 9:44 AM, Charles Campbell ... package(s): vim-gnome ... The vim package doesn t provide a GUI-enabled Vim, so
          Message 4 of 23 , Feb 12, 2013
          • 0 Attachment


            On Feb 12, 2013 9:44 AM, "Charles Campbell" <Charles.E.Campbell@...> wrote:
            >
            > I've tried sudo yum-builddep vim-gnome; that results in:  No such package(s): vim-gnome
            > I then tried:  sudo yum-builddep vim

            The vim package doesn't provide a GUI-enabled Vim, so that probably isn't sufficient.  Scientific Linux's GUI-enabled package is vim-X11.

            James

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          • Charles Campbell
            ... FYI: I still can t build gvim to use Luxi Mono on my main work computer; however, I can build a gvim on another computer that hasn t been damaged
            Message 5 of 23 , Mar 13, 2013
            • 0 Attachment
              Charles Campbell wrote:
              > Hello!
              >
              > I seem to have run into a font problem -- as in the font I was using,
              > "Luxi Mono 10", is no longer a valid font.
              >
              > Here's what happened:
              >
              > * used gvim with Luxi Mono 10
              > * broke for lunch
              > * returned
              > * updated vim from 7.3.784 to 7.3.796
              > * Luxi mono font no longer available
              >
              <snip>

              FYI: I still can't build gvim to use Luxi Mono on my main work
              computer; however, I can build a gvim on another computer that hasn't
              been damaged by the updating process I'm stuck with -- and that gvim
              does work on my main work computer (with Luxi Mono/gtk).

              Thank you for your help!
              Chip Campbell

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Charles Campbell
              Hello! I thought I d share the solution to what happened to luxi mono? , just in case anyone else was being afflicted in a similar fashion: * symptom: the
              Message 6 of 23 , Jan 23, 2014
              • 0 Attachment
                Hello!

                I thought I'd share the "solution" to "what happened to luxi mono?",
                just in case anyone else was being afflicted in a similar fashion:

                * symptom: the font I prefer to use, Luxi Mono Bold 11, was no longer
                available (I use a lot of math-oriented utf-8 characters, which Luxi
                Mono supports well)
                * Turns out that I wasn't getting gnome-gtk2 anymore during new
                compiles; instead, I was getting motif, hence no luxi mono
                * I get "automatic updates" on my system (Scientific Linux 6.4) (not
                that I want them, its just the way It Has To Be on my government computer)
                * fallback solution: I compiled vim on my home computer (SL6.3) and
                brought the executable to work (via ftp, since we're not to use
                flashsticks anymore)
                * new symptom, just happened a day or two ago: I was not getting any vim
                menus.
                * tried a backup version of vim (also compiled on my home computer) from
                a month ago -- it too exhibited the "no vim menu" issue. That vim
                certainly didn't used to have that problem...
                * all versions of vim tried had +menu and has("gui_running") was true
                * got suspicious that auto-updating was involved, so I recompiled vim on
                my work computer, which I haven't bothered to do for many months. It
                successfully compiled with gtk and had menus!

                So, thanks goes to whomever fixed the gtk system on SL6.4.

                Regards,
                Chip Campbell





                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.