Loading ...
Sorry, an error occurred while loading the content.

Re: mason syntax highlighting problem

Expand Messages
  • Christian Brabandt
    ... I just looked into the original bug report and I am not sure this is a bug. The problem is, that when a syntax file is included into another syntax file,
    Message 1 of 4 , Feb 7, 2013
    • 0 Attachment
      On Thu, February 7, 2013 17:57, James McCoy wrote:
      > On Feb 7, 2013 10:42 AM, "Tomasz Chomiuk" <t.chomiuk@...> wrote:
      >>
      >> Hi,
      >>
      >> It looks like syntax highlighting for Mason files doesn't work
      >> properly in vim 7.3. I thought it was my OS' configuration that
      >> screwed things up but I compiled both 7.3 and 6.4 from sources and
      >> problem does exist on a clean 7.3 installation. 6.4 is fine. Please
      >> check. Thanks!
      >>
      >> --- test.mason ---
      >>
      >> <%init>
      >> if (1) {
      >> ;
      >> }
      >> </%init>
      >
      > This was broken by a change in syntax/perl.vim in changeset c9022997af9e.
      > There's a bug report upstream,
      > https://github.com/vim-perl/vim-perl/issues/40, but no resolution do far.
      >
      > There was a suggestion this may be a bug in Vim, and the topic was raised
      > previously on this list,
      > http://threads.gmane.org/gmane.editors.vim.devel/33630, but no discussion
      > happened.

      I just looked into the original bug report and I am not sure this is a bug.
      The problem is, that when a syntax file is included into another syntax
      file, the top-level syntax items in the included syntax files are no longer
      at the top-level, since they are included into a containing region. This
      is mentioned briefly in the help:

      ,----
      | - If top-level syntax items in the included syntax file are to be
      | contained within a region in the including syntax, you can use the
      | ":syntax include" command:
      `----

      Therefore the constraint given at :h :syn-contained for top-level items
      does not hold anymore.

      ,----
      | When the "contained" argument is given, this item will not be recognized
      | at the top level, but only when it is mentioned in the "contains"
      | field of another match.
      `----

      regards,
      Christian

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tomasz Chomiuk
      ... James, thanks for pointing me in the right direction. The workaround by user @ruz makes working with .mason files possible again. I hope vim magicians will
      Message 2 of 4 , Feb 8, 2013
      • 0 Attachment
        > This was broken by a change in syntax/perl.vim in changeset c9022997af9e.
        > There's a bug report upstream,
        > https://github.com/vim-perl/vim-perl/issues/40, but no resolution do far.
        >
        > There was a suggestion this may be a bug in Vim, and the topic was raised
        > previously on this list,
        > http://threads.gmane.org/gmane.editors.vim.devel/33630, but no discussion
        > happened.

        James, thanks for pointing me in the right direction. The workaround
        by user @ruz makes working with .mason files possible again. I hope
        vim magicians will release a proper fix sometimes though.

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.