Loading ...
Sorry, an error occurred while loading the content.
 

Bug in `= or info missing in docs (limited by wildignore)

Expand Messages
  • Jacobo de Vera
    Hi all, It seems like the behaviour of the second line with `= here: let g:var = /tmp/myfile edit `=g:var` depends on the contents of wildignore. If
    Message 1 of 3 , Feb 6, 2013
      Hi all,

      It seems like the behaviour of the second line with `= here:

      let g:var = '/tmp/myfile'
      edit `=g:var`

      depends on the contents of wildignore. If wildignore, in this case,
      contains something like /tmp/*, then this error is issued:

      E480: No match: `=g:var`

      I could not find any mention of this in the docs for neither
      wildignore nor `=. Is this behaviour intentional and just missing in
      the docs or is it a bug?

      Regards,
      --
      Jacobo de Vera

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... The docs actually mention it: The expression can contain just about anything, thus this can also be used to avoid the special meaning of , | , % and
      Message 2 of 3 , Feb 7, 2013
        Jacobo de Vera wrote:

        > It seems like the behaviour of the second line with `= here:
        >
        > let g:var = '/tmp/myfile'
        > edit `=g:var`
        >
        > depends on the contents of wildignore. If wildignore, in this case,
        > contains something like /tmp/*, then this error is issued:
        >
        > E480: No match: `=g:var`
        >
        > I could not find any mention of this in the docs for neither
        > wildignore nor `=. Is this behaviour intentional and just missing in
        > the docs or is it a bug?

        The docs actually mention it:

        The expression can contain just about anything, thus this can
        also be used to avoid the special meaning of '"', '|', '%' and
        '#'. However, 'wildignore' does apply like to other wildcards.


        --
        Q: What kind of stuff do you do?
        A: I collect hobbies.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Jacobo de Vera
        ... Thanks, my bad, I was working with older runtime files. -- Jacobo de Vera -- -- You received this message from the vim_dev maillist. Do not top-post!
        Message 3 of 3 , Feb 7, 2013
          On Thu, Feb 7, 2013 at 7:21 PM, Bram Moolenaar <Bram@...> wrote:
          >
          > The docs actually mention it:
          >
          > The expression can contain just about anything, thus this can
          > also be used to avoid the special meaning of '"', '|', '%' and
          > '#'. However, 'wildignore' does apply like to other wildcards.
          >



          Thanks, my bad, I was working with older runtime files.

          --
          Jacobo de Vera

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.