Loading ...
Sorry, an error occurred while loading the content.

Re: unwated subMenu/XmCascaseButton messages

Expand Messages
  • Dominique Pellé
    ... Hi Charles Perhaps you are building Vim with the Lesstif library. Lesstif does not implement everything present in Motif. Perhaps that s the cause of those
    Message 1 of 5 , Feb 4, 2013
    • 0 Attachment
      Charles Campbell wrote:

      > Hello!
      > I upgraded from 784 to 798 -- (and am doing without gtk, so I'm using the
      > motif).
      > What should I do to eliminate the following two messages that I get when I
      > fire up vim:
      >
      >
      > Warning:
      > Name: subMenu
      > Class: XmCascadeButton
      > Illegal mnemonic character; Could not convert X KEYSYM to a keycode
      >
      > Warning:
      > Name: subMenu
      > Class: XmCascadeButton
      > Illegal mnemonic character; Could not convert X KEYSYM to a keycode
      >
      > I'm getting these with
      >
      > vim -u NONE -g
      >
      > Thank you,
      > Chip Campbell

      Hi Charles

      Perhaps you are building Vim with the Lesstif library.
      Lesstif does not implement everything present in Motif.
      Perhaps that's the cause of those messages (not sure).

      Motif was a proprietary library for a long time (hence
      the free alternative Lesstif) but Motif is now LGPL. Your
      Linux distribution may have packages for Motif which
      can supersede Lesstif. At least Ubuntu has packages for
      either Lesstif or Motif. I don't know about Scientific Linux.

      But anyway, both Lesstif or Motif are rather old and quite
      buggy in my opinion, due to poor type checking in the APIs
      and badly documented memory management causing leaks
      in many Motif GUIs. It also predates Unicode so I don't
      think that Lesstif or Motif Vim GUI support Unicode among
      other things. You'd be better with the gtk2 GUI.

      Regards
      -- Dominique

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Charles Campbell
      ... Unfortunately I cannot get vim to compile with gtk2. I ve taken the trouble to remove all gtk2 (and things that depended on it) and re-installed it, and
      Message 2 of 5 , Feb 5, 2013
      • 0 Attachment
        Dominique Pellé wrote:
        > Charles Campbell wrote:
        >
        >> Hello!
        >> I upgraded from 784 to 798 -- (and am doing without gtk, so I'm using the
        >> motif).
        >> What should I do to eliminate the following two messages that I get when I
        >> fire up vim:
        >>
        >>
        >> Warning:
        >> Name: subMenu
        >> Class: XmCascadeButton
        >> Illegal mnemonic character; Could not convert X KEYSYM to a keycode
        >>
        >> Warning:
        >> Name: subMenu
        >> Class: XmCascadeButton
        >> Illegal mnemonic character; Could not convert X KEYSYM to a keycode
        >>
        >> I'm getting these with
        >>
        >> vim -u NONE -g
        >>
        >> Thank you,
        >> Chip Campbell
        > Hi Charles
        >
        > Perhaps you are building Vim with the Lesstif library.
        > Lesstif does not implement everything present in Motif.
        > Perhaps that's the cause of those messages (not sure).
        >
        > Motif was a proprietary library for a long time (hence
        > the free alternative Lesstif) but Motif is now LGPL. Your
        > Linux distribution may have packages for Motif which
        > can supersede Lesstif. At least Ubuntu has packages for
        > either Lesstif or Motif. I don't know about Scientific Linux.
        >
        > But anyway, both Lesstif or Motif are rather old and quite
        > buggy in my opinion, due to poor type checking in the APIs
        > and badly documented memory management causing leaks
        > in many Motif GUIs. It also predates Unicode so I don't
        > think that Lesstif or Motif Vim GUI support Unicode among
        > other things. You'd be better with the gtk2 GUI.
        >
        Unfortunately I cannot get vim to compile with gtk2. I've taken the
        trouble to remove all gtk2 (and things that depended on it) and
        re-installed it, and still configure won't let vim compile with gtk2
        support.
        yum -y remove gtk2.x86_64
        (then re-installed gtk2 and re-installed all 388 packages depending on
        gtk2)

        As for Motif...

        cec/ xorn? yum -y install openmotif.x86_64
        Loaded plugins: refresh-packagekit
        Setting up Install Process
        Package openmotif-2.3.3-4.el6.x86_64 already installed and latest version
        Nothing to do

        So I'm a bit stuck, it seems. I suppose I could redirect (2>/dev/null)
        vim's stderr output -- that at least removes the noise.

        Regards,
        Charles Campbell

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Tom Francis
        ... It s been a long time since I was doing any motif or Xt development, but this is complaining about a mnemonic character, and unless your X
        Message 3 of 5 , Feb 5, 2013
        • 0 Attachment
          On Feb 5, 2013, at 9:57 AM, Charles Campbell wrote:

          > Dominique Pellé wrote:
          >> Charles Campbell wrote:
          >>
          >>> Hello!
          >>> I upgraded from 784 to 798 -- (and am doing without gtk, so I'm using the
          >>> motif).
          >>> What should I do to eliminate the following two messages that I get when I
          >>> fire up vim:
          >>>
          >>>
          >>> Warning:
          >>> Name: subMenu
          >>> Class: XmCascadeButton
          >>> Illegal mnemonic character; Could not convert X KEYSYM to a keycode
          >>>
          >>> Warning:
          >>> Name: subMenu
          >>> Class: XmCascadeButton
          >>> Illegal mnemonic character; Could not convert X KEYSYM to a keycode
          >>>
          >>> I'm getting these with
          >>>
          >>> vim -u NONE -g
          >>>
          >>> Thank you,
          >>> Chip Campbell


          <snip>

          It's been a long time since I was doing any motif or Xt development, but this is complaining about a mnemonic character, and unless your X environment is really weird, that means hitting Meta + a single character. If your keyboard layout requires you to hit Meta + some key combination to produce that character, you wouldn't be able to have Meta + that character. IIRC, if the character is produced by a key combination rather than a single key press, you might get the same error. I would suggest looking through all of the menus in VIM for any underlined characters that you can't type with a single key press, as that's probably the problem. Given the name is "subMenu" it's probably for a menu or submenu, not for an action item (but I haven't looked at the relevant section of vim source, so that's just a guess!). If you can locate the one (it's probably just one), you should be able to determine if it's hard-coded, in a resources file somewhere, or both, and then set up a resources file to override with something more appropriate, or edit the resources file.

          TOM

          PS Most of the time "Meta" is now a reference to the "Alt" key, but that might not be true. :)

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • James McCoy
          On Feb 5, 2013 9:57 AM, Charles Campbell ... Was one of those the gtk2-devel package? Cheers, -- James GPG Key: 4096R/331BA3DB
          Message 4 of 5 , Feb 5, 2013
          • 0 Attachment


            On Feb 5, 2013 9:57 AM, "Charles Campbell" <Charles.E.Campbell@...> wrote:
            > Unfortunately I cannot get vim to compile with gtk2.  I've taken the trouble to remove all gtk2 (and things that depended on it) and re-installed it, and still configure won't let vim compile with gtk2 support.
            >   yum -y remove gtk2.x86_64
            >  (then re-installed gtk2 and re-installed all 388 packages depending on gtk2)

            Was one of those the gtk2-devel package?

            Cheers,
            James

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          Your message has been successfully submitted and would be delivered to recipients shortly.