Loading ...
Sorry, an error occurred while loading the content.

Re: what happened to luxi mono?

Expand Messages
  • Charles Campbell
    ... xfontsel : trying family, no luxi present fc-list : no luxi present Its really odd that Luxi disappeared from the system; nonetheless, I downloaded Luxi
    Message 1 of 23 , Feb 1, 2013
    • 0 Attachment
      Taylor Hedberg wrote:
      > Is the font *only* missing in Vim, or has it disappeared from other
      > applications as well? Does it show up under xfontsel and/or fc-list on
      > your system?
      xfontsel : trying family, no luxi present
      fc-list : no luxi present

      Its really odd that Luxi disappeared from the system; nonetheless, I
      downloaded Luxi fonts. Directions say to :
      ./configure
      make
      make install

      Here's the results of "make install":

      font-bh-ttf-1.0.3/ xorn? make install
      make[1]: Entering directory `/home/cecbkup/SW/LUXI/font-bh-ttf-1.0.3'
      make[1]: Nothing to be done for `install-exec-am'.
      test -z "/usr/local/etc/fonts/conf.avail" || /bin/mkdir -p
      "/usr/local/etc/fonts/conf.avail"
      /usr/bin/install -c -m 644 42-luxi-mono.conf
      '/usr/local/etc/fonts/conf.avail'
      test -z "/usr/share/fonts/X11/TTF" || /bin/mkdir -p
      "/usr/share/fonts/X11/TTF"
      /usr/bin/install -c -m 644 luximbi.ttf luximb.ttf luximri.ttf
      luximr.ttf luxirbi.ttf luxirb.ttf luxirri.ttf luxirr.ttf luxisbi.ttf
      luxisb.ttf luxisri.ttf luxisr.ttf '/usr/share/fonts/X11/TTF'
      make install-data-hook
      make[2]: Entering directory `/home/cecbkup/SW/LUXI/font-bh-ttf-1.0.3'
      /usr/bin/mkfontscale /usr/share/fonts/X11/TTF
      /usr/bin/mkfontdir /usr/share/fonts/X11/TTF
      mkdir -p /usr/local/etc/fonts/conf.d
      ln -s ../conf.avail/42-luxi-mono.conf /usr/local/etc/fonts/conf.d
      /usr/bin/fc-cache /usr/share/fonts/X11/TTF
      make[2]: Leaving directory `/home/cecbkup/SW/LUXI/font-bh-ttf-1.0.3'
      make[1]: Leaving directory `/home/cecbkup/SW/LUXI/font-bh-ttf-1.0.3'

      No luck with Luxi Mono yet.

      Regards,
      Charles Campbell

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Taylor Hedberg
      ... If it doesn t show up with either of those tools, then I d be inclined to conclude that it s not a Vim issue. It appears that neither X nor fontconfig
      Message 2 of 23 , Feb 1, 2013
      • 0 Attachment
        Charles Campbell, Fri 2013-02-01 @ 11:30:47-0500:
        > Taylor Hedberg wrote:
        > >Is the font *only* missing in Vim, or has it disappeared from other
        > >applications as well? Does it show up under xfontsel and/or fc-list on
        > >your system?
        > xfontsel : trying family, no luxi present
        > fc-list : no luxi present

        If it doesn't show up with either of those tools, then I'd be inclined
        to conclude that it's not a Vim issue. It appears that neither X nor
        fontconfig recognize that the font exists. It is a bit odd that it
        started occurring when you updated Vim, though. That may or may not be a
        coincidence.
      • Charles Campbell
        ... I ve found some more out -- it appears that several directories and files got changed so that only root had access. fc-list now shows Luxi Mono fonts, for
        Message 3 of 23 , Feb 1, 2013
        • 0 Attachment
          Taylor Hedberg wrote:
          > Charles Campbell, Fri 2013-02-01 @ 11:30:47-0500:
          >> Taylor Hedberg wrote:
          >>> Is the font *only* missing in Vim, or has it disappeared from other
          >>> applications as well? Does it show up under xfontsel and/or fc-list on
          >>> your system?
          >> xfontsel : trying family, no luxi present
          >> fc-list : no luxi present
          > If it doesn't show up with either of those tools, then I'd be inclined
          > to conclude that it's not a Vim issue. It appears that neither X nor
          > fontconfig recognize that the font exists. It is a bit odd that it
          > started occurring when you updated Vim, though. That may or may not be a
          > coincidence.

          I've found some more out -- it appears that several directories and
          files got changed so that only root had access. fc-list now shows Luxi
          Mono fonts, for example.

          However, I still can't get vim to accept

          :set guifont=Luxi\ Mono\ 10

          and Luxi Mono doesn't show up on vim's font selector, either.

          Thank you,
          Charles Campbell




          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • James McCoy
          On Feb 1, 2013 11:43 AM, Charles Campbell ... got changed so that only root had access. fc-list now shows Luxi Mono fonts, for
          Message 4 of 23 , Feb 1, 2013
          • 0 Attachment


            On Feb 1, 2013 11:43 AM, "Charles Campbell" <Charles.E.Campbell@...> wrote:
            > I've found some more out -- it appears that several directories and files got changed so that only root had access.  fc-list now shows Luxi Mono fonts, for example.
            >
            > However, I still can't get vim to accept
            >
            >   :set guifont=Luxi\ Mono\ 10
            >
            > and Luxi Mono doesn't show up on vim's font selector, either.

            In the version output you posted before, it showed you are building against the Motif gui toolkit. Is that intentional or another result of the permissions problems you had?  I thought that format for specifying 'guifont' was specific to GTK.

            Cheers,
            James

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          • Charles Campbell
            ... Here s my configure line: ./configure --with-features=huge --enable-perlinterp --enable-pythoninterp --enable-cscope --enable-rubyinterp . I m using motif
            Message 5 of 23 , Feb 1, 2013
            • 0 Attachment
              James McCoy wrote:
              >
              >
              > On Feb 1, 2013 11:43 AM, "Charles Campbell"
              > <Charles.E.Campbell@... <mailto:Charles.E.Campbell@...>> wrote:
              > > I've found some more out -- it appears that several directories and
              > files got changed so that only root had access. fc-list now shows
              > Luxi Mono fonts, for example.
              > >
              > > However, I still can't get vim to accept
              > >
              > > :set guifont=Luxi\ Mono\ 10
              > >
              > > and Luxi Mono doesn't show up on vim's font selector, either.
              >
              > In the version output you posted before, it showed you are building
              > against the Motif gui toolkit. Is that intentional or another result
              > of the permissions problems you had? I thought that format for
              > specifying 'guifont' was specific to GTK.
              >
              Here's my configure line:

              ./configure --with-features=huge --enable-perlinterp
              --enable-pythoninterp --enable-cscope --enable-rubyinterp . I'm using
              motif and gtk, though.

              Thank you,
              Charles Campbell

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Christian Brabandt
              Hi Charles! ... Can you try with a gtk gui? regards, Christian -- Zeig mir deine Uhr, und ich sage dir, wie spät es ist. -- -- You received this message from
              Message 6 of 23 , Feb 1, 2013
              • 0 Attachment
                Hi Charles!

                On Fr, 01 Feb 2013, Charles Campbell wrote:

                > James McCoy wrote:
                > >
                > >
                > >On Feb 1, 2013 11:43 AM, "Charles Campbell"
                > ><Charles.E.Campbell@... <mailto:Charles.E.Campbell@...>>
                > >wrote:
                > >> I've found some more out -- it appears that several directories
                > >and files got changed so that only root had access. fc-list now
                > >shows Luxi Mono fonts, for example.
                > >>
                > >> However, I still can't get vim to accept
                > >>
                > >> :set guifont=Luxi\ Mono\ 10
                > >>
                > >> and Luxi Mono doesn't show up on vim's font selector, either.
                > >
                > >In the version output you posted before, it showed you are
                > >building against the Motif gui toolkit. Is that intentional or
                > >another result of the permissions problems you had? I thought
                > >that format for specifying 'guifont' was specific to GTK.
                > >
                > Here's my configure line:
                >
                > ./configure --with-features=huge --enable-perlinterp
                > --enable-pythoninterp --enable-cscope --enable-rubyinterp . I'm
                > using motif and gtk, though.

                Can you try with a gtk gui?

                regards,
                Christian
                --
                Zeig mir deine Uhr, und ich sage dir, wie spät es ist.

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Tony Mechelynck
                ... Yes, GTK2 has a different format for guifont , incompatible with any other Vim GUI flavour. For details, see ...
                Message 7 of 23 , Feb 1, 2013
                • 0 Attachment
                  On 01/02/13 18:11, Charles Campbell wrote:
                  > James McCoy wrote:
                  >>
                  >>
                  >> On Feb 1, 2013 11:43 AM, "Charles Campbell"
                  >> <Charles.E.Campbell@... <mailto:Charles.E.Campbell@...>> wrote:
                  >> > I've found some more out -- it appears that several directories and
                  >> files got changed so that only root had access. fc-list now shows
                  >> Luxi Mono fonts, for example.
                  >> >
                  >> > However, I still can't get vim to accept
                  >> >
                  >> > :set guifont=Luxi\ Mono\ 10
                  >> >
                  >> > and Luxi Mono doesn't show up on vim's font selector, either.
                  >>
                  >> In the version output you posted before, it showed you are building
                  >> against the Motif gui toolkit. Is that intentional or another result
                  >> of the permissions problems you had? I thought that format for
                  >> specifying 'guifont' was specific to GTK.
                  >>
                  > Here's my configure line:
                  >
                  > ./configure --with-features=huge --enable-perlinterp
                  > --enable-pythoninterp --enable-cscope --enable-rubyinterp . I'm using
                  > motif and gtk, though.
                  >
                  > Thank you,
                  > Charles Campbell
                  >
                  Yes, GTK2 has a different format for 'guifont', incompatible with any
                  other Vim GUI flavour.

                  For details, see
                  :help setting-guifont
                  http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI

                  Best regards,
                  Tony.
                  --
                  In a forest a fox bumps into a little rabbit, and says, "Hi,
                  junior, what are you up to?"
                  "I'm writing a dissertation on how rabbits eat foxes," said the
                  rabbit.
                  "Come now, friend rabbit, you know that's impossible!"
                  "Well, follow me and I'll show you." They both go into the
                  rabbit's dwelling and after a while the rabbit emerges with a satisfied
                  expression on his face.
                  Comes along a wolf. "Hello, what are we doing these days?"
                  "I'm writing the second chapter of my thesis, on how rabbits
                  devour wolves."
                  "Are you crazy? Where is your academic honesty?"
                  "Come with me and I'll show you." As before, the rabbit comes
                  out with a satisfied look on his face and a diploma in his paw.
                  Finally, the camera pans into the rabbit's cave and, as everybody
                  should have guessed by now, we see a mean-looking, huge lion sitting
                  next to some bloody and furry remnants of the wolf and the fox.

                  The moral: It's not the contents of your thesis that are important --
                  it's your PhD advisor that really counts.

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Charles Campbell
                  ... My vim s status: * :set guifont=Luxi Mono 10 used to work (in fact, still does on my home computer) * same configure command used on both my home
                  Message 8 of 23 , Feb 1, 2013
                  • 0 Attachment
                    Tony Mechelynck wrote:
                    > On 01/02/13 18:11, Charles Campbell wrote:
                    >> James McCoy wrote:
                    >>>
                    >>> On Feb 1, 2013 11:43 AM, "Charles Campbell"
                    >>> <Charles.E.Campbell@... <mailto:Charles.E.Campbell@...>> wrote:
                    >>>> I've found some more out -- it appears that several directories and
                    >>> files got changed so that only root had access. fc-list now shows
                    >>> Luxi Mono fonts, for example.
                    >>>> However, I still can't get vim to accept
                    >>>>
                    >>>> :set guifont=Luxi\ Mono\ 10
                    >>>>
                    >>>> and Luxi Mono doesn't show up on vim's font selector, either.
                    >>> In the version output you posted before, it showed you are building
                    >>> against the Motif gui toolkit. Is that intentional or another result
                    >>> of the permissions problems you had? I thought that format for
                    >>> specifying 'guifont' was specific to GTK.
                    >>>
                    >> Here's my configure line:
                    >>
                    >> ./configure --with-features=huge --enable-perlinterp
                    >> --enable-pythoninterp --enable-cscope --enable-rubyinterp . I'm using
                    >> motif and gtk, though.
                    >>
                    > Yes, GTK2 has a different format for 'guifont', incompatible with any
                    > other Vim GUI flavour.
                    >
                    > For details, see
                    > :help setting-guifont
                    > http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI
                    My vim's status:

                    * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on
                    my home computer)
                    * same configure command used on both my home computer and my work
                    computer
                    * both systems run scientific linux 6.3, gtk, etc
                    * haven't updated my home computer vim from 7.3.784; did do the
                    update with vim on my work computer
                    * fc-list now shows the Luxi fonts are available
                    * setting guifont=Luxi\ Mono\ 10 on my work computer shows "E596:
                    Invalid font(s): guifont=Luxi\ Mono\ 10

                    I've tried uninstalling Luxi fonts, reconfiguring, making, and
                    re-installing. Luxi Mono 10 is still "invalid font" (under vim)
                    I've tried restarting X: (init 3, init 5) Luxi Mono 10 is still
                    "invalid font" (under vim)

                    fc-list | grep Luxi shows:
                    Luxi Serif:style=Regular
                    Luxi Serif:style=Bold
                    Luxi Mono:style=Bold
                    Luxi Sans:style=Bold
                    Luxi Sans:style=Regular
                    Luxi Mono:style=Regular
                    Luxi Serif:style=Oblique
                    Luxi Serif:style=Bold Oblique
                    Luxi Mono:style=Oblique
                    Luxi Sans:style=Oblique
                    Luxi Sans:style=Bold Oblique
                    Luxi Mono:style=Bold Oblique

                    Appreciate your help,
                    Charles Campbell



                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Christian J. Robinson
                    ... *snip* If your Vim is built with Motif, it simply will not be able to use the new style fonts like Luxi Mono ; you will be stuck with the old style
                    Message 9 of 23 , Feb 1, 2013
                    • 0 Attachment
                      On Fri, 1 Feb 2013, Charles Campbell wrote:

                      > My vim's status:
                      >
                      > * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on my
                      > home computer)

                      *snip*

                      If your Vim is built with Motif, it simply will not be able to use the
                      "new style" fonts like "Luxi Mono"; you will be stuck with the old
                      style complicated font names with a lot of dashes. The two styles
                      have specific names but I never really remember what they are.

                      So the question is, why is your Vim no longer building with GTK, but
                      rather with Motif? (It can not be built with both.)

                      - Christian

                      --
                      Time slows if you're on the outside of the bathroom door.
                      Christian J. Robinson <heptite@...> http://christianrobinson.name/

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Tony Mechelynck
                      ... This means your home Vim is probably compiled with something else than GTK2. For Motif you need the other-X11 format. :set gfn=* (without the quotes)
                      Message 10 of 23 , Feb 1, 2013
                      • 0 Attachment
                        On 01/02/13 20:37, Charles Campbell wrote:
                        > Tony Mechelynck wrote:
                        >> On 01/02/13 18:11, Charles Campbell wrote:
                        >>> James McCoy wrote:
                        >>>>
                        >>>> On Feb 1, 2013 11:43 AM, "Charles Campbell"
                        >>>> <Charles.E.Campbell@... <mailto:Charles.E.Campbell@...>>
                        >>>> wrote:
                        >>>>> I've found some more out -- it appears that several directories and
                        >>>> files got changed so that only root had access. fc-list now shows
                        >>>> Luxi Mono fonts, for example.
                        >>>>> However, I still can't get vim to accept
                        >>>>>
                        >>>>> :set guifont=Luxi\ Mono\ 10
                        >>>>>
                        >>>>> and Luxi Mono doesn't show up on vim's font selector, either.
                        >>>> In the version output you posted before, it showed you are building
                        >>>> against the Motif gui toolkit. Is that intentional or another result
                        >>>> of the permissions problems you had? I thought that format for
                        >>>> specifying 'guifont' was specific to GTK.
                        >>>>
                        >>> Here's my configure line:
                        >>>
                        >>> ./configure --with-features=huge --enable-perlinterp
                        >>> --enable-pythoninterp --enable-cscope --enable-rubyinterp . I'm using
                        >>> motif and gtk, though.
                        >>>
                        >> Yes, GTK2 has a different format for 'guifont', incompatible with any
                        >> other Vim GUI flavour.
                        >>
                        >> For details, see
                        >> :help setting-guifont
                        >> http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI
                        > My vim's status:
                        >
                        > * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on
                        > my home computer)
                        > * same configure command used on both my home computer and my work
                        > computer
                        > * both systems run scientific linux 6.3, gtk, etc
                        > * haven't updated my home computer vim from 7.3.784; did do the
                        > update with vim on my work computer
                        > * fc-list now shows the Luxi fonts are available
                        > * setting guifont=Luxi\ Mono\ 10 on my work computer shows "E596:
                        > Invalid font(s): guifont=Luxi\ Mono\ 10
                        >
                        > I've tried uninstalling Luxi fonts, reconfiguring, making, and
                        > re-installing. Luxi Mono 10 is still "invalid font" (under vim)
                        > I've tried restarting X: (init 3, init 5) Luxi Mono 10 is still
                        > "invalid font" (under vim)

                        This means your home Vim is probably compiled with something else than GTK2.

                        For Motif you need the "other-X11" format. ":set gfn=*" (without the
                        quotes) should work, giving you a dialog. The fonts may or may not be
                        listed alphabetically. Luxi mono 10 (for Motif) might come out as
                        something like

                        :set gfn=*-luxi-medium-r-normal-*-*-100-*-*-m-*-*

                        The 2nd part (I tried -luxi-) is the font face, I'm not sure what Motif
                        Vim will see on your system but in my experience (from when the default
                        gvim for Linux was GTK1, which was also "other-X11") it's all in
                        lowercase. -medium-r-normal- specify medium boldness, Roman (i.e.
                        vertical, not italic) slant and normal (neither compressed nor wide)
                        width. The number is the size and the -m- near the end is very
                        important: it specifies Monospace (i.e. fixed-width) which is the only
                        kind of fonts which any gvim other than GTK2 will accept. (GTK2 gvim
                        will accept any font installed on your computer, but non-monospace fonts
                        will look ugly.) A font all whose glyphs are the same pixel width, but
                        which is not _declared_ as monospace, will not be accepted by Motif
                        gvim, not even if you replace the -m- by -*-.

                        Each star means zero or more characters. See ":help XLFD" for details.

                        >
                        > fc-list | grep Luxi shows:
                        > Luxi Serif:style=Regular
                        > Luxi Serif:style=Bold
                        > Luxi Mono:style=Bold
                        > Luxi Sans:style=Bold
                        > Luxi Sans:style=Regular
                        > Luxi Mono:style=Regular
                        > Luxi Serif:style=Oblique
                        > Luxi Serif:style=Bold Oblique
                        > Luxi Mono:style=Oblique
                        > Luxi Sans:style=Oblique
                        > Luxi Sans:style=Bold Oblique
                        > Luxi Mono:style=Bold Oblique
                        >
                        > Appreciate your help,
                        > Charles Campbell
                        >
                        >
                        >

                        Best regards,
                        Tony.
                        --
                        It is illegal for anyone to give lighted cigars to dogs, cats, and other
                        domesticated animal kept as pets.
                        [real standing law in Illinois, United States of America]

                        --
                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Charles Campbell
                        ... I think this is a promising line of inquiry. First, checking on presence of gtk2... console/ xorn? rpm -q gtk2 gtk2-2.18.9-10.el6.x86_64
                        Message 11 of 23 , Feb 1, 2013
                        • 0 Attachment
                          Christian J. Robinson wrote:
                          > On Fri, 1 Feb 2013, Charles Campbell wrote:
                          >
                          >> My vim's status:
                          >>
                          >> * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on my
                          >> home computer)
                          > *snip*
                          >
                          > If your Vim is built with Motif, it simply will not be able to use the
                          > "new style" fonts like "Luxi Mono"; you will be stuck with the old
                          > style complicated font names with a lot of dashes. The two styles
                          > have specific names but I never really remember what they are.
                          >
                          > So the question is, why is your Vim no longer building with GTK, but
                          > rather with Motif? (It can not be built with both.)
                          >
                          I think this is a promising line of inquiry.

                          First, checking on presence of gtk2...

                          console/ xorn? rpm -q gtk2
                          gtk2-2.18.9-10.el6.x86_64
                          gtk2-2.18.9-10.el6.i686
                          console/ xorn? rpm -q gtk2-devel
                          gtk2-devel-2.18.9-10.el6.x86_64

                          So it seems both gtk2 and the developer package are installed.

                          However,

                          ./configure --with-features=huge --enable-gui=gtk2
                          --enable-perlinterp --enable-pythoninterp --enable-cscope
                          --enable-rubyinterp

                          results in a E25: GUI cannot be used: Not enabled at compile time (vim -g)

                          and, without the --enable-gui=gtk2, I get Motif-enabled gui. OK,
                          searching through /usr, I see a bunch of directories that are -rwx------
                          instead of -rwxr-xr-x . I'll fix those.

                          I'm going to have to leave and so I probably won't be able to get back
                          until this until Monday. I'll try crafting a find-based command to hunt
                          down all these rwx------ directories and changing them.

                          Thank you,
                          Charles Campbell




                          --
                          --
                          You received this message from the "vim_dev" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_dev" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        • Charles Campbell
                          ... Found out some more about the loss of Luxi Mono. As I mentioned earlier, this problem occurred on a work computer; it has been set to automatically update
                          Message 12 of 23 , Feb 11, 2013
                          • 0 Attachment
                            Charles Campbell wrote:
                            > Christian J. Robinson wrote:
                            >> On Fri, 1 Feb 2013, Charles Campbell wrote:
                            >>
                            >>> My vim's status:
                            >>>
                            >>> * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on my
                            >>> home computer)
                            >> *snip*
                            >>
                            >> If your Vim is built with Motif, it simply will not be able to use the
                            >> "new style" fonts like "Luxi Mono"; you will be stuck with the old
                            >> style complicated font names with a lot of dashes. The two styles
                            >> have specific names but I never really remember what they are.
                            >>
                            >> So the question is, why is your Vim no longer building with GTK, but
                            >> rather with Motif? (It can not be built with both.)
                            >>
                            > I think this is a promising line of inquiry.
                            >
                            > First, checking on presence of gtk2...
                            >
                            > console/ xorn? rpm -q gtk2
                            > gtk2-2.18.9-10.el6.x86_64
                            > gtk2-2.18.9-10.el6.i686
                            > console/ xorn? rpm -q gtk2-devel
                            > gtk2-devel-2.18.9-10.el6.x86_64
                            >
                            > So it seems both gtk2 and the developer package are installed.
                            >
                            Found out some more about the loss of Luxi Mono.

                            As I mentioned earlier, this problem occurred on a work computer; it has
                            been set to automatically update (Scientific Linux 6.3).

                            Configure expects a number of header files to be in /usr/include, but
                            the update has pushed the gtk related ones to /usr/include/gtk-2.0.
                            I've made links:

                            gtk -> gtk-2.0/gtk/
                            lrwxrwxrwx 1 root root 11 Feb 11 09:53 gdk -> gtk-2.0/gdk/
                            lrwxrwxrwx 1 root root 18 Feb 11 09:53 gdk-pixbuf ->
                            gtk-2.0/gdk-pixbuf/
                            lrwxrwxrwx 1 root root 23 Feb 11 09:54 gdk-pixbuf-xlib ->
                            gtk-2.0/gdk-pixbuf-xlib/
                            lrwxrwxrwx 1 root root 12 Feb 11 09:58 gio -> glib-2.0/gio/
                            lrwxrwxrwx 1 root root 13 Feb 11 09:58 glib -> glib-2.0/glib/
                            lrwxrwxrwx 1 root root 16 Feb 11 09:58 gobject -> glib-2.0/gobject/
                            lrwxrwxrwx 1 root root 22 Feb 11 09:58 glib-object.h ->
                            glib-2.0/glib-object.h
                            lrwxrwxrwx 1 root root 18 Feb 11 09:59 gmodule.h -> glib-2.0/gmodule.h
                            lrwxrwxrwx 1 root root 15 Feb 11 10:00 glib.h -> glib-2.0/glib.h

                            Unfortunately, this isn't quite adequate. I'm still getting an error:

                            || In file included from /usr/include/glib/galloca.h:34,
                            || from /usr/include/glib.h:32,
                            || from /usr/include/gobject/gtype.h:26,
                            || from /usr/include/gobject/gboxed.h:26,
                            || from /usr/include/glib-object.h:25,
                            || from /usr/include/gio/gioenums.h:30,
                            || from /usr/include/gio/giotypes.h:30,
                            || from /usr/include/gio/gio.h:28,
                            || from /usr/include/gdk/gdkapplaunchcontext.h:30,
                            || from /usr/include/gdk/gdk.h:32,
                            || from /usr/include/gtk/gtk.h:32,
                            || from conftest.c:23:
                            /usr/include/glib-2.0/glib/gtypes.h|34 col 24 error| glibconfig.h: No
                            such file or directory

                            Anyway, so configure decides that gtk isn't available, gui is not
                            enabled, and Luxi Mono is no longer available to vim (although it is on
                            my computer).

                            Regards,
                            C Campbell


                            and I cannot find a glibconfig.h under /usr/include (literally; I used
                            the find command).



                            --
                            --
                            You received this message from the "vim_dev" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_dev" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          • René Köcher
                            ... Hi Charles, I m not sure about scientific Linux but for most of todays distributions /usr/include/gtk-2.0 is the default path. (Has been for years) Vim can
                            Message 13 of 23 , Feb 11, 2013
                            • 0 Attachment
                              Am 11.02.2013 um 16:11 schrieb Charles Campbell <Charles.E.Campbell@...>:

                              > Charles Campbell wrote:
                              >> Christian J. Robinson wrote:
                              >>> On Fri, 1 Feb 2013, Charles Campbell wrote:
                              >>>
                              >>>> My vim's status:
                              >>>>
                              >>>> * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on my
                              >>>> home computer)
                              >>> *snip*
                              >>>
                              >>> If your Vim is built with Motif, it simply will not be able to use the
                              >>> "new style" fonts like "Luxi Mono"; you will be stuck with the old
                              >>> style complicated font names with a lot of dashes. The two styles
                              >>> have specific names but I never really remember what they are.
                              >>>
                              >>> So the question is, why is your Vim no longer building with GTK, but
                              >>> rather with Motif? (It can not be built with both.)
                              >> I think this is a promising line of inquiry.
                              >>
                              >> First, checking on presence of gtk2...
                              >>
                              >> console/ xorn? rpm -q gtk2
                              >> gtk2-2.18.9-10.el6.x86_64
                              >> gtk2-2.18.9-10.el6.i686
                              >> console/ xorn? rpm -q gtk2-devel
                              >> gtk2-devel-2.18.9-10.el6.x86_64
                              >>
                              >> So it seems both gtk2 and the developer package are installed.
                              > Found out some more about the loss of Luxi Mono.
                              >
                              > As I mentioned earlier, this problem occurred on a work computer; it has been set to automatically update (Scientific Linux 6.3).
                              >
                              > Configure expects a number of header files to be in /usr/include, but the update has pushed the gtk related ones to /usr/include/gtk-2.0.
                              Hi Charles,
                              I'm not sure about scientific Linux but for most of todays distributions
                              /usr/include/gtk-2.0 is the default path.
                              (Has been for years)
                              Vim can cope well with this location as long as it can find pkg-config
                              or gtk-config to tell the right paths and libs.

                              > I've made links:
                              >
                              > gtk -> gtk-2.0/gtk/
                              > lrwxrwxrwx 1 root root 11 Feb 11 09:53 gdk -> gtk-2.0/gdk/
                              > lrwxrwxrwx 1 root root 18 Feb 11 09:53 gdk-pixbuf -> gtk-2.0/gdk-pixbuf/
                              > lrwxrwxrwx 1 root root 23 Feb 11 09:54 gdk-pixbuf-xlib -> gtk-2.0/gdk-pixbuf-xlib/
                              > lrwxrwxrwx 1 root root 12 Feb 11 09:58 gio -> glib-2.0/gio/
                              > lrwxrwxrwx 1 root root 13 Feb 11 09:58 glib -> glib-2.0/glib/
                              > lrwxrwxrwx 1 root root 16 Feb 11 09:58 gobject -> glib-2.0/gobject/
                              > lrwxrwxrwx 1 root root 22 Feb 11 09:58 glib-object.h -> glib-2.0/glib-object.h
                              > lrwxrwxrwx 1 root root 18 Feb 11 09:59 gmodule.h -> glib-2.0/gmodule.h
                              > lrwxrwxrwx 1 root root 15 Feb 11 10:00 glib.h -> glib-2.0/glib.h
                              >
                              > Unfortunately, this isn't quite adequate. I'm still getting an error:
                              >
                              > || In file included from /usr/include/glib/galloca.h:34,
                              > || from /usr/include/glib.h:32,
                              > || from /usr/include/gobject/gtype.h:26,
                              > || from /usr/include/gobject/gboxed.h:26,
                              > || from /usr/include/glib-object.h:25,
                              > || from /usr/include/gio/gioenums.h:30,
                              > || from /usr/include/gio/giotypes.h:30,
                              > || from /usr/include/gio/gio.h:28,
                              > || from /usr/include/gdk/gdkapplaunchcontext.h:30,
                              > || from /usr/include/gdk/gdk.h:32,
                              > || from /usr/include/gtk/gtk.h:32,
                              > || from conftest.c:23:
                              > /usr/include/glib-2.0/glib/gtypes.h|34 col 24 error| glibconfig.h: No such file or directory
                              >
                              > Anyway, so configure decides that gtk isn't available, gui is not enabled, and Luxi Mono is no longer available to vim (although it is on my computer).
                              >
                              > Regards,
                              > C Campbell
                              >
                              >
                              > and I cannot find a glibconfig.h under /usr/include (literally; I used the find command).

                              Regards René

                              --
                              --
                              You received this message from the "vim_dev" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_dev" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                              For more options, visit https://groups.google.com/groups/opt_out.
                            • Dominique Pellé
                              On Mon, Feb 11, 2013 at 4:11 PM, Charles Campbell ... I don t know much about the Scientific Linux distribution. But on Ubuntu, it is possible to do... $
                              Message 14 of 23 , Feb 11, 2013
                              • 0 Attachment
                                On Mon, Feb 11, 2013 at 4:11 PM, Charles Campbell
                                <Charles.E.Campbell@...> wrote:
                                > Charles Campbell wrote:
                                >>
                                >> Christian J. Robinson wrote:
                                >>>
                                >>> On Fri, 1 Feb 2013, Charles Campbell wrote:
                                >>>
                                >>>> My vim's status:
                                >>>>
                                >>>> * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on
                                >>>> my
                                >>>> home computer)
                                >>>
                                >>> *snip*
                                >>>
                                >>> If your Vim is built with Motif, it simply will not be able to use the
                                >>> "new style" fonts like "Luxi Mono"; you will be stuck with the old
                                >>> style complicated font names with a lot of dashes. The two styles
                                >>> have specific names but I never really remember what they are.
                                >>>
                                >>> So the question is, why is your Vim no longer building with GTK, but
                                >>> rather with Motif? (It can not be built with both.)
                                >>>
                                >> I think this is a promising line of inquiry.
                                >>
                                >> First, checking on presence of gtk2...
                                >>
                                >> console/ xorn? rpm -q gtk2
                                >> gtk2-2.18.9-10.el6.x86_64
                                >> gtk2-2.18.9-10.el6.i686
                                >> console/ xorn? rpm -q gtk2-devel
                                >> gtk2-devel-2.18.9-10.el6.x86_64
                                >>
                                >> So it seems both gtk2 and the developer package are installed.
                                >>
                                > Found out some more about the loss of Luxi Mono.
                                >
                                > As I mentioned earlier, this problem occurred on a work computer; it has
                                > been set to automatically update (Scientific Linux 6.3).
                                >
                                > Configure expects a number of header files to be in /usr/include, but the
                                > update has pushed the gtk related ones to /usr/include/gtk-2.0. I've made
                                > links:
                                >
                                > gtk -> gtk-2.0/gtk/
                                > lrwxrwxrwx 1 root root 11 Feb 11 09:53 gdk -> gtk-2.0/gdk/
                                > lrwxrwxrwx 1 root root 18 Feb 11 09:53 gdk-pixbuf ->
                                > gtk-2.0/gdk-pixbuf/
                                > lrwxrwxrwx 1 root root 23 Feb 11 09:54 gdk-pixbuf-xlib ->
                                > gtk-2.0/gdk-pixbuf-xlib/
                                > lrwxrwxrwx 1 root root 12 Feb 11 09:58 gio -> glib-2.0/gio/
                                > lrwxrwxrwx 1 root root 13 Feb 11 09:58 glib -> glib-2.0/glib/
                                > lrwxrwxrwx 1 root root 16 Feb 11 09:58 gobject -> glib-2.0/gobject/
                                > lrwxrwxrwx 1 root root 22 Feb 11 09:58 glib-object.h ->
                                > glib-2.0/glib-object.h
                                > lrwxrwxrwx 1 root root 18 Feb 11 09:59 gmodule.h -> glib-2.0/gmodule.h
                                > lrwxrwxrwx 1 root root 15 Feb 11 10:00 glib.h -> glib-2.0/glib.h
                                >
                                > Unfortunately, this isn't quite adequate. I'm still getting an error:
                                >
                                > || In file included from /usr/include/glib/galloca.h:34,
                                > || from /usr/include/glib.h:32,
                                > || from /usr/include/gobject/gtype.h:26,
                                > || from /usr/include/gobject/gboxed.h:26,
                                > || from /usr/include/glib-object.h:25,
                                > || from /usr/include/gio/gioenums.h:30,
                                > || from /usr/include/gio/giotypes.h:30,
                                > || from /usr/include/gio/gio.h:28,
                                > || from /usr/include/gdk/gdkapplaunchcontext.h:30,
                                > || from /usr/include/gdk/gdk.h:32,
                                > || from /usr/include/gtk/gtk.h:32,
                                > || from conftest.c:23:
                                > /usr/include/glib-2.0/glib/gtypes.h|34 col 24 error| glibconfig.h: No such
                                > file or directory
                                >
                                > Anyway, so configure decides that gtk isn't available, gui is not enabled,
                                > and Luxi Mono is no longer available to vim (although it is on my computer).
                                >
                                > Regards,
                                > C Campbell
                                >
                                >
                                > and I cannot find a glibconfig.h under /usr/include (literally; I used the
                                > find command).
                                >

                                I don't know much about the "Scientific Linux" distribution.
                                But on Ubuntu, it is possible to do...

                                $ sudo apt-get build-dep vim-gnome

                                ... which installs all packages required to be able to build vim-gnome.

                                This installs gtk2 among plenty of other things if not already installed.

                                Doing a google search suggests that "yum-builddep" is the equivalent
                                feature on Scientific Linux.

                                So have you tried the following command?

                                $ sudo yum-builddep vim-gnome

                                (not sure whether "vim-gnome" is the package name on your distrib for the
                                GTK2 version of Vim).

                                Then should you need to clean the configure cache and rebuild Vim
                                from sources:

                                $ cd vim
                                $ rm -f src/auto/config.cache
                                $ ./configure --with-feature=huge --enable-gui=gtk2

                                Regards
                                Dominique

                                --
                                --
                                You received this message from the "vim_dev" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php

                                ---
                                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                For more options, visit https://groups.google.com/groups/opt_out.
                              • Charles Campbell
                                ... Found out some more about the loss of Luxi Mono. As I mentioned earlier, this problem occurred on a work computer; it has been set to automatically update
                                Message 15 of 23 , Feb 11, 2013
                                • 0 Attachment
                                  Charles Campbell wrote:
                                  > Christian J. Robinson wrote:
                                  >> On Fri, 1 Feb 2013, Charles Campbell wrote:
                                  >>
                                  >>> My vim's status:
                                  >>>
                                  >>> * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on my
                                  >>> home computer)
                                  >> *snip*
                                  >>
                                  >> If your Vim is built with Motif, it simply will not be able to use the
                                  >> "new style" fonts like "Luxi Mono"; you will be stuck with the old
                                  >> style complicated font names with a lot of dashes. The two styles
                                  >> have specific names but I never really remember what they are.
                                  >>
                                  >> So the question is, why is your Vim no longer building with GTK, but
                                  >> rather with Motif? (It can not be built with both.)
                                  >>
                                  > I think this is a promising line of inquiry.
                                  >
                                  > First, checking on presence of gtk2...
                                  >
                                  > console/ xorn? rpm -q gtk2
                                  > gtk2-2.18.9-10.el6.x86_64
                                  > gtk2-2.18.9-10.el6.i686
                                  > console/ xorn? rpm -q gtk2-devel
                                  > gtk2-devel-2.18.9-10.el6.x86_64
                                  >
                                  Found out some more about the loss of Luxi Mono.

                                  As I mentioned earlier, this problem occurred on a work computer; it has
                                  been set to automatically update (Scientific Linux 6.3).

                                  Configure expects a number of header files to be in /usr/include, but
                                  the update has pushed the gtk related ones to /usr/include/gtk-2.0.
                                  I've made links:

                                  gtk -> gtk-2.0/gtk/
                                  lrwxrwxrwx 1 root root 11 Feb 11 09:53 gdk -> gtk-2.0/gdk/
                                  lrwxrwxrwx 1 root root 18 Feb 11 09:53 gdk-pixbuf ->
                                  gtk-2.0/gdk-pixbuf/
                                  lrwxrwxrwx 1 root root 23 Feb 11 09:54 gdk-pixbuf-xlib ->
                                  gtk-2.0/gdk-pixbuf-xlib/
                                  lrwxrwxrwx 1 root root 12 Feb 11 09:58 gio -> glib-2.0/gio/
                                  lrwxrwxrwx 1 root root 13 Feb 11 09:58 glib -> glib-2.0/glib/
                                  lrwxrwxrwx 1 root root 16 Feb 11 09:58 gobject -> glib-2.0/gobject/
                                  lrwxrwxrwx 1 root root 22 Feb 11 09:58 glib-object.h ->
                                  glib-2.0/glib-object.h
                                  lrwxrwxrwx 1 root root 18 Feb 11 09:59 gmodule.h -> glib-2.0/gmodule.h
                                  lrwxrwxrwx 1 root root 15 Feb 11 10:00 glib.h -> glib-2.0/glib.h

                                  Unfortunately, this isn't quite adequate. I'm still getting an error:

                                  || In file included from /usr/include/glib/galloca.h:34,
                                  || from /usr/include/glib.h:32,
                                  || from /usr/include/gobject/gtype.h:26,
                                  || from /usr/include/gobject/gboxed.h:26,
                                  || from /usr/include/glib-object.h:25,
                                  || from /usr/include/gio/gioenums.h:30,
                                  || from /usr/include/gio/giotypes.h:30,
                                  || from /usr/include/gio/gio.h:28,
                                  || from /usr/include/gdk/gdkapplaunchcontext.h:30,
                                  || from /usr/include/gdk/gdk.h:32,
                                  || from /usr/include/gtk/gtk.h:32,
                                  || from conftest.c:23:
                                  /usr/include/glib-2.0/glib/gtypes.h|34 col 24 error| glibconfig.h: No
                                  such file or directory

                                  Anyway, so configure decides that gtk isn't available, gui is not
                                  enabled, and Luxi Mono is no longer available to vim (although it is on
                                  my computer).

                                  Regards,
                                  C Campbell


                                  and I cannot find a glibconfig.h under /usr/include (literally; I used
                                  the find command).





                                  --
                                  --
                                  You received this message from the "vim_dev" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php

                                  ---
                                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                  For more options, visit https://groups.google.com/groups/opt_out.
                                • Dominique Pellé
                                  ... Using xubuntu-12.10: $ locate glibconfig.h /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h $ apt-file search
                                  Message 16 of 23 , Feb 11, 2013
                                  • 0 Attachment
                                    Charles Campbell wrote:

                                    > and I cannot find a glibconfig.h under /usr/include (literally; I used the
                                    > find command).


                                    Using xubuntu-12.10:

                                    $ locate glibconfig.h
                                    /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h

                                    $ apt-file search /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h
                                    libglib2.0-dev: /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h

                                    So the package providing that header file is "libglib2.0-dev".
                                    You can try to include a similar package for your distribution.

                                    Regards
                                    Dominique

                                    --
                                    --
                                    You received this message from the "vim_dev" maillist.
                                    Do not top-post! Type your reply below the text you are replying to.
                                    For more information, visit http://www.vim.org/maillist.php

                                    ---
                                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                    For more options, visit https://groups.google.com/groups/opt_out.
                                  • Charles Campbell
                                    ... I ve tried sudo yum-builddep vim-gnome; that results in: No such package(s): vim-gnome I then tried: sudo yum-builddep vim This command actually did
                                    Message 17 of 23 , Feb 12, 2013
                                    • 0 Attachment
                                      Dominique Pellé wrote:
                                      > On Mon, Feb 11, 2013 at 4:11 PM, Charles Campbell
                                      > <Charles.E.Campbell@...> wrote:
                                      >> Charles Campbell wrote:
                                      >>> Christian J. Robinson wrote:
                                      >>>> On Fri, 1 Feb 2013, Charles Campbell wrote:
                                      >>>>
                                      >>>>> My vim's status:
                                      >>>>>
                                      >>>>> * :set guifont=Luxi\ Mono\ 10 used to work (in fact, still does on
                                      >>>>> my
                                      >>>>> home computer)
                                      >>>> *snip*
                                      >>>>
                                      >>>> If your Vim is built with Motif, it simply will not be able to use the
                                      >>>> "new style" fonts like "Luxi Mono"; you will be stuck with the old
                                      >>>> style complicated font names with a lot of dashes. The two styles
                                      >>>> have specific names but I never really remember what they are.
                                      >>>>
                                      >>>> So the question is, why is your Vim no longer building with GTK, but
                                      >>>> rather with Motif? (It can not be built with both.)
                                      >>>>
                                      >>> I think this is a promising line of inquiry.
                                      >>>
                                      >>> First, checking on presence of gtk2...
                                      >>>
                                      >>> console/ xorn? rpm -q gtk2
                                      >>> gtk2-2.18.9-10.el6.x86_64
                                      >>> gtk2-2.18.9-10.el6.i686
                                      >>> console/ xorn? rpm -q gtk2-devel
                                      >>> gtk2-devel-2.18.9-10.el6.x86_64
                                      >>>
                                      >>> So it seems both gtk2 and the developer package are installed.
                                      >>>
                                      >> Found out some more about the loss of Luxi Mono.
                                      >>
                                      >> As I mentioned earlier, this problem occurred on a work computer; it has
                                      >> been set to automatically update (Scientific Linux 6.3).
                                      >>
                                      >> Configure expects a number of header files to be in /usr/include, but the
                                      >> update has pushed the gtk related ones to /usr/include/gtk-2.0. I've made
                                      >> links:
                                      >>
                                      >> gtk -> gtk-2.0/gtk/
                                      >> lrwxrwxrwx 1 root root 11 Feb 11 09:53 gdk -> gtk-2.0/gdk/
                                      >> lrwxrwxrwx 1 root root 18 Feb 11 09:53 gdk-pixbuf ->
                                      >> gtk-2.0/gdk-pixbuf/
                                      >> lrwxrwxrwx 1 root root 23 Feb 11 09:54 gdk-pixbuf-xlib ->
                                      >> gtk-2.0/gdk-pixbuf-xlib/
                                      >> lrwxrwxrwx 1 root root 12 Feb 11 09:58 gio -> glib-2.0/gio/
                                      >> lrwxrwxrwx 1 root root 13 Feb 11 09:58 glib -> glib-2.0/glib/
                                      >> lrwxrwxrwx 1 root root 16 Feb 11 09:58 gobject -> glib-2.0/gobject/
                                      >> lrwxrwxrwx 1 root root 22 Feb 11 09:58 glib-object.h ->
                                      >> glib-2.0/glib-object.h
                                      >> lrwxrwxrwx 1 root root 18 Feb 11 09:59 gmodule.h -> glib-2.0/gmodule.h
                                      >> lrwxrwxrwx 1 root root 15 Feb 11 10:00 glib.h -> glib-2.0/glib.h
                                      >>
                                      >> Unfortunately, this isn't quite adequate. I'm still getting an error:
                                      >>
                                      >> || In file included from /usr/include/glib/galloca.h:34,
                                      >> || from /usr/include/glib.h:32,
                                      >> || from /usr/include/gobject/gtype.h:26,
                                      >> || from /usr/include/gobject/gboxed.h:26,
                                      >> || from /usr/include/glib-object.h:25,
                                      >> || from /usr/include/gio/gioenums.h:30,
                                      >> || from /usr/include/gio/giotypes.h:30,
                                      >> || from /usr/include/gio/gio.h:28,
                                      >> || from /usr/include/gdk/gdkapplaunchcontext.h:30,
                                      >> || from /usr/include/gdk/gdk.h:32,
                                      >> || from /usr/include/gtk/gtk.h:32,
                                      >> || from conftest.c:23:
                                      >> /usr/include/glib-2.0/glib/gtypes.h|34 col 24 error| glibconfig.h: No such
                                      >> file or directory
                                      >>
                                      >> Anyway, so configure decides that gtk isn't available, gui is not enabled,
                                      >> and Luxi Mono is no longer available to vim (although it is on my computer).
                                      >>
                                      >> Regards,
                                      >> C Campbell
                                      >>
                                      >>
                                      >> and I cannot find a glibconfig.h under /usr/include (literally; I used the
                                      >> find command).
                                      >>
                                      > I don't know much about the "Scientific Linux" distribution.
                                      > But on Ubuntu, it is possible to do...
                                      >
                                      > $ sudo apt-get build-dep vim-gnome
                                      >
                                      > ... which installs all packages required to be able to build vim-gnome.
                                      >
                                      > This installs gtk2 among plenty of other things if not already installed.
                                      >
                                      > Doing a google search suggests that "yum-builddep" is the equivalent
                                      > feature on Scientific Linux.
                                      >
                                      > So have you tried the following command?
                                      >
                                      > $ sudo yum-builddep vim-gnome
                                      >
                                      > (not sure whether "vim-gnome" is the package name on your distrib for the
                                      > GTK2 version of Vim).
                                      >
                                      > Then should you need to clean the configure cache and rebuild Vim
                                      > from sources:
                                      >
                                      > $ cd vim
                                      > $ rm -f src/auto/config.cache
                                      > $ ./configure --with-feature=huge --enable-gui=gtk2
                                      >

                                      I've tried sudo yum-builddep vim-gnome; that results in: No such
                                      package(s): vim-gnome
                                      I then tried: sudo yum-builddep vim

                                      This command actually did result in installing gpm-devel ; however, that
                                      wasn't necessary before to build an X11 capable version and

                                      make distclean
                                      ./configure --with-features=huge --enable-gui=gtk2
                                      --enable-gnome-check --enable-perlinterp --enable-pythoninterp
                                      --enable-rubyinterp --enable-cscope
                                      make

                                      still fails to build a gnome-capable vim (like it used to do). Removing
                                      "--enable-gui=gtk2" results in a motif-enabled vim (ie. Luxi Mono still
                                      absent).

                                      Thank you for helping, though,
                                      Chip Campbell

                                      --
                                      --
                                      You received this message from the "vim_dev" maillist.
                                      Do not top-post! Type your reply below the text you are replying to.
                                      For more information, visit http://www.vim.org/maillist.php

                                      ---
                                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                      For more options, visit https://groups.google.com/groups/opt_out.
                                    • Charles Campbell
                                      ... I used yum to install yum -y install glib.x86_64 yum -y install glib-devel.x86_64 (there was no glib2). Still, making distclean and making vim still
                                      Message 18 of 23 , Feb 12, 2013
                                      • 0 Attachment
                                        Dominique Pellé wrote:
                                        > Charles Campbell wrote:
                                        >
                                        >> and I cannot find a glibconfig.h under /usr/include (literally; I used the
                                        >> find command).
                                        >
                                        > Using xubuntu-12.10:
                                        >
                                        > $ locate glibconfig.h
                                        > /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h
                                        >
                                        > $ apt-file search /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h
                                        > libglib2.0-dev: /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h
                                        >
                                        > So the package providing that header file is "libglib2.0-dev".
                                        > You can try to include a similar package for your distribution.
                                        >
                                        I used yum to install

                                        yum -y install glib.x86_64
                                        yum -y install glib-devel.x86_64

                                        (there was no glib2). Still, making distclean and making vim still
                                        results in a not-gui-enabled vim (unless I remove the --enable-gui=gtk2
                                        from the configure command) and no glibconfig.h under /usr/include anywhere.

                                        cec/ xorn? yum -y install gtk2.x86_64
                                        Loaded plugins: refresh-packagekit
                                        Setting up Install Process
                                        Package gtk2-2.18.9-10.el6.x86_64 already installed and latest version
                                        Nothing to do
                                        cec/ xorn? yum -y install gtk2-devel.x86_64
                                        Loaded plugins: refresh-packagekit
                                        Setting up Install Process
                                        Package gtk2-devel-2.18.9-10.el6.x86_64 already installed and latest version
                                        Nothing to do

                                        Thank you for helping,
                                        Chip Campbell

                                        --
                                        --
                                        You received this message from the "vim_dev" maillist.
                                        Do not top-post! Type your reply below the text you are replying to.
                                        For more information, visit http://www.vim.org/maillist.php

                                        ---
                                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                        For more options, visit https://groups.google.com/groups/opt_out.
                                      • James McCoy
                                        On Feb 12, 2013 9:44 AM, Charles Campbell ... package(s): vim-gnome ... The vim package doesn t provide a GUI-enabled Vim, so
                                        Message 19 of 23 , Feb 12, 2013
                                        • 0 Attachment


                                          On Feb 12, 2013 9:44 AM, "Charles Campbell" <Charles.E.Campbell@...> wrote:
                                          >
                                          > I've tried sudo yum-builddep vim-gnome; that results in:  No such package(s): vim-gnome
                                          > I then tried:  sudo yum-builddep vim

                                          The vim package doesn't provide a GUI-enabled Vim, so that probably isn't sufficient.  Scientific Linux's GUI-enabled package is vim-X11.

                                          James

                                          --
                                          --
                                          You received this message from the "vim_dev" maillist.
                                          Do not top-post! Type your reply below the text you are replying to.
                                          For more information, visit http://www.vim.org/maillist.php
                                           
                                          ---
                                          You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                          For more options, visit https://groups.google.com/groups/opt_out.
                                           
                                           
                                        • Charles Campbell
                                          ... FYI: I still can t build gvim to use Luxi Mono on my main work computer; however, I can build a gvim on another computer that hasn t been damaged
                                          Message 20 of 23 , Mar 13, 2013
                                          • 0 Attachment
                                            Charles Campbell wrote:
                                            > Hello!
                                            >
                                            > I seem to have run into a font problem -- as in the font I was using,
                                            > "Luxi Mono 10", is no longer a valid font.
                                            >
                                            > Here's what happened:
                                            >
                                            > * used gvim with Luxi Mono 10
                                            > * broke for lunch
                                            > * returned
                                            > * updated vim from 7.3.784 to 7.3.796
                                            > * Luxi mono font no longer available
                                            >
                                            <snip>

                                            FYI: I still can't build gvim to use Luxi Mono on my main work
                                            computer; however, I can build a gvim on another computer that hasn't
                                            been damaged by the updating process I'm stuck with -- and that gvim
                                            does work on my main work computer (with Luxi Mono/gtk).

                                            Thank you for your help!
                                            Chip Campbell

                                            --
                                            --
                                            You received this message from the "vim_dev" maillist.
                                            Do not top-post! Type your reply below the text you are replying to.
                                            For more information, visit http://www.vim.org/maillist.php

                                            ---
                                            You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                            For more options, visit https://groups.google.com/groups/opt_out.
                                          • Charles Campbell
                                            Hello! I thought I d share the solution to what happened to luxi mono? , just in case anyone else was being afflicted in a similar fashion: * symptom: the
                                            Message 21 of 23 , Jan 23, 2014
                                            • 0 Attachment
                                              Hello!

                                              I thought I'd share the "solution" to "what happened to luxi mono?",
                                              just in case anyone else was being afflicted in a similar fashion:

                                              * symptom: the font I prefer to use, Luxi Mono Bold 11, was no longer
                                              available (I use a lot of math-oriented utf-8 characters, which Luxi
                                              Mono supports well)
                                              * Turns out that I wasn't getting gnome-gtk2 anymore during new
                                              compiles; instead, I was getting motif, hence no luxi mono
                                              * I get "automatic updates" on my system (Scientific Linux 6.4) (not
                                              that I want them, its just the way It Has To Be on my government computer)
                                              * fallback solution: I compiled vim on my home computer (SL6.3) and
                                              brought the executable to work (via ftp, since we're not to use
                                              flashsticks anymore)
                                              * new symptom, just happened a day or two ago: I was not getting any vim
                                              menus.
                                              * tried a backup version of vim (also compiled on my home computer) from
                                              a month ago -- it too exhibited the "no vim menu" issue. That vim
                                              certainly didn't used to have that problem...
                                              * all versions of vim tried had +menu and has("gui_running") was true
                                              * got suspicious that auto-updating was involved, so I recompiled vim on
                                              my work computer, which I haven't bothered to do for many months. It
                                              successfully compiled with gtk and had menus!

                                              So, thanks goes to whomever fixed the gtk system on SL6.4.

                                              Regards,
                                              Chip Campbell





                                              --
                                              --
                                              You received this message from the "vim_dev" maillist.
                                              Do not top-post! Type your reply below the text you are replying to.
                                              For more information, visit http://www.vim.org/maillist.php

                                              ---
                                              You received this message because you are subscribed to the Google Groups "vim_dev" group.
                                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                                              For more options, visit https://groups.google.com/groups/opt_out.
                                            Your message has been successfully submitted and would be delivered to recipients shortly.