Loading ...
Sorry, an error occurred while loading the content.

Re: New featuabsolute line number in relativenumber for the current line

Expand Messages
  • Christian Brabandt
    Hi François! ... Here is a patch. regards, Christian -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the
    Message 1 of 47 , Feb 1, 2013
    • 0 Attachment
      Hi François!

      On Fr, 01 Feb 2013, François Ingelrest wrote:

      > On Wed, Jan 30, 2013 at 12:31 PM, Bram Moolenaar wrote:
      > > This looks like a good solution. I'll include it. With Christian's
      > > addition.
      >
      > I think I found a case where the 'relativenumber' option is reset. I'm
      > sending this report in this thread, although I don't know if it's
      > caused by the recent changes to relativenumber:
      >
      > 1. vim -u NONE -U NONE
      > 2. :set number
      > 3. :set relativenumber
      > 4: :e .zshrc
      > 5: :e .zsh_history
      >
      > At step 4., relativenumber is on. At step 5., it's off. Not setting
      > number (step 3.) before relativenumber doesn't exhibit this behavior.
      >
      > This is with Vim 7.3.798, features=big, on a Debian Squeeze.

      Here is a patch.

      regards,
      Christian

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • sxc4244@...
      Ah, I understand now; sorry for the confusion -- I didn t know that patch 1115 changed the behavior of relativenumber/number. I know what I have to do now to
      Message 47 of 47 , Jun 29, 2013
      • 0 Attachment
        Ah, I understand now; sorry for the confusion -- I didn't know that patch 1115 changed the behavior of relativenumber/number. I know what I have to do now to modify my vimrc to behave like it used to for older versions by using the has("patch#") check.

        I do indeed like this new behavior better though :)
        Thanks very much for your help!

        --Stan

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.