Loading ...
Sorry, an error occurred while loading the content.

Re: using DirectX/DirectWrite for rendering text.

Expand Messages
  • Ingo Karkat
    ... +1 for making that configurable. I don t like font smoothing in Vim, and if there s a risk that this switch introduces it, I d like to have a means to turn
    Message 1 of 58 , Jan 25, 2013
    • 0 Attachment
      On 25-Jan-13 03:49:21 +0100, MURAOKA Taro wrote:

      > Because of compatibility and drawing speed.
      >
      > It is known that DirectWrite is slower than GDI on some environmemt.
      > [...]
      > Thanks, that sounds interesting. Is there a reason, we need a special
      > option just for Windows or can't we always use directx, if it is
      > available?

      +1 for making that configurable. I don't like font smoothing in Vim, and if
      there's a risk that this switch introduces it, I'd like to have a means to turn
      it off. However, I would prefer to avoid a separate (and Windows-only)
      configuration option, imagining that in the future, there will likely be similar
      rendering-related options, and that these unnecessarily pollute the namespace of
      `:set` commands.

      How about making "directx" a (first) value of a new generic 'guirender' option?!
      Instead of
      :set directx
      make it
      :set guirender+=directx`

      This option:
      - has a name that clearly conveys its purpose
      - makes sense on all platforms
      - allows for future extensions and (comma-separated) alternatives in a familiar
      and proven syntax

      -- regards, ingo

      PS: Do not top-post! Type your reply below the text you are replying to.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Peter Prohaska
      Pasting text produces inconstisten screen state. Looks like a mixture of monospaced and proportional font. Resetting rop to empty fixes the problem--and
      Message 58 of 58 , Aug 20 6:26 AM
      • 0 Attachment
        Pasting text produces inconstisten screen state. Looks like a mixture of
        monospaced and proportional font. Resetting rop to empty fixes the
        problem--and reintroduces the missing char glyphs.

        Attached is screenshot with the lines showing
        1) state right after paste (cursor was aligned above the 2nd-row tsu
        2) state after moving one character to the left ("h")
        3) state after moving left till column 1 ("hhh")

        Yank and paste, scroll off screen and back in, all produce state (1).
        Selections mark the full width as in state (3). Moving the cursor over a
        position triggers the update as seen in state (2).

        Test settings:
        rop=type:directx
        guifont=DejaVu_Sans_Mono:h10:cANSI

        Test Build: VC10; Win8; nmake -f Make_mvc.mak GUI=yes DIRECTX=yes


        Aside:
        It should definitely make it into vim.

        Skimmed through the code. Don't know much about the specific job. Looks
        solid enough. Patch currelty produces a rejected hunk against hg due to the
        addition of 'regexpengine' option.

        My user experience: Try a few dozen fonts, find a hadfull that works
        acceptable. Pre patch: rest is unusable. Post patch: rest works good or
        great. Editing terminological datasets often, i hearty recommend this
        pain-killer (or a different OS).

        Regards,
        Peter.

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.