Loading ...
Sorry, an error occurred while loading the content.

Issue 104 in vim: Incorrect commentstring option for lisp

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 104 by j...@bendyworks.com: Incorrect commentstring option for lisp
    Message 1 of 5 , Jan 20, 2013
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 104 by j...@...: Incorrect commentstring option for
      lisp
      http://code.google.com/p/vim/issues/detail?id=104

      What steps will reproduce the problem?
      1. Open a new buffer
      2. Run ':set ft=lisp' or ':set ft=scheme'
      3. Run ':set commentstring?'

      What is the expected output? What do you see instead?
      Expected ' commentstring=;%s'
      Actual ' commentstring=/*%s*/'

      What version of the product are you using? On what operating system?
      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Jan 11 2013 13:54:32)
      MacOS X (unix) version
      Included patches: 1-754
      Compiled by josh@...
      Huge version with MacVim GUI. Features included (+) or not (-):
      +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent
      +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
      +comments
      +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff
      +digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi
      +file_in_path +find_in_path +float +folding -footer +fork() +fullscreen
      -gettext -hangul_input +iconv +insert_expand +jumplist +keymap +langmap
      +libcall +linebreak +lispindent +listcmds +localmap -lua +menu +mksession
      +modify_fname +mouse +mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm
      +mouse_netterm +mouse_sgr -mouse_sysmouse +mouse_urxvt +mouse_xterm
      +multi_byte
      +multi_lang -mzscheme +netbeans_intg +odbeditor +path_extra +perl
      +persistent_undo +postscript +printer +profile +python -python3 +quickfix
      +reltime +rightleft +ruby +scrollbind +signs +smartindent -sniff
      +startuptime
      +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white
      +tcl +terminfo +termresponse +textobjects +title +toolbar +transparency
      +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
      +vreplace
      +wildignore +wildmenu +windows +writebackup -X11 -xfontset +xim -xsmp
      -xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "$VIM/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/Applications/MacVim.app/Contents/Resources/vim"
      Compilation: clang -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MACVIM -Wall
      -Wno-unknown-pragmas -pipe -DMACOS_X_UNIX -no-cpp-precomp -g -O2
      -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
      -I/System/Library/Frameworks/Tcl.framework/Headers -D_REENTRANT=1
      -D_THREAD_SAFE=1 -D_DARWIN_C_SOURCE=1
      Linking: clang -L. -L. -L/usr/local/lib -o Vim -framework Cocoa
      -framework Carbon -lncurses -liconv -framework Cocoa
      -fstack-protector -L/usr/local/lib
      -L/System/Library/Perl/5.12/darwin-thread-multi-2level/CORE -lperl -lm
      -lutil -lc -framework Python -F/System/Library/Frameworks -framework Tcl
      -framework CoreFoundation -framework Ruby

      Please provide any additional information below.
      This has also been reproduced on the latest vim for Arch Linux. The
      attached patch fixes the problem for both lisp and scheme filetypes (and
      any others that source lisp.vim)


      Attachments:
      lisp.vim.patch 491 bytes

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • vim@...
      Comment #1 on issue 104 by mybeawdh...@gmail.com: Incorrect commentstring option for lisp http://code.google.com/p/vim/issues/detail?id=104 Is there an issue
      Message 2 of 5 , Feb 6, 2013
      • 0 Attachment
        Comment #1 on issue 104 by mybeawdh...@...: Incorrect commentstring
        option for lisp
        http://code.google.com/p/vim/issues/detail?id=104

        Is there an issue with this patch? It's simple enough, and I think it's in
        the right place. This bug affects commands like 'zf' and plugins like
        vim-commentary. Something I need to change to get this pulled?

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • vim@...
        Comment #2 on issue 104 by fritzoph...@gmail.com: Incorrect commentstring option for lisp http://code.google.com/p/vim/issues/detail?id=104 At the top of
        Message 3 of 5 , Feb 6, 2013
        • 0 Attachment
          Comment #2 on issue 104 by fritzoph...@...: Incorrect commentstring
          option for lisp
          http://code.google.com/p/vim/issues/detail?id=104

          At the top of lisp.vim you can see:

          " Vim filetype plugin
          " Language: Lisp
          " Maintainer: Sergey Khorev <sergey.khorev@...>
          " URL: http://sites.google.com/site/khorser/opensource/vim

          Try contacting Sergey directly. He is the maintainer of this file.

          Currently (maybe not forever) the runtime files are maintained by
          individuals other than Bram, and these individuals send updates to Bram for
          inclusion. Bram does not usually update such files directly.

          It is also possible that you simply did not wait long enough. It has only
          been a couple of weeks.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • vim@...
          Comment #3 on issue 104 by j...@bendyworks.com: Incorrect commentstring option for lisp http://code.google.com/p/vim/issues/detail?id=104 This has been fixed
          Message 4 of 5 , Apr 19, 2013
          • 0 Attachment
            Comment #3 on issue 104 by j...@...: Incorrect commentstring
            option for lisp
            http://code.google.com/p/vim/issues/detail?id=104

            This has been fixed as of vim 7.3.875, so this issue can be closed. Thanks!

            --
            You received this message because this project is configured to send all
            issue notifications to this address.
            You may adjust your notification preferences at:
            https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • vim@...
            Updates: Status: Fixed Comment #4 on issue 104 by brammool...@gmail.com: Incorrect commentstring option for lisp
            Message 5 of 5 , Apr 19, 2013
            • 0 Attachment
              Updates:
              Status: Fixed

              Comment #4 on issue 104 by brammool...@...: Incorrect commentstring
              option for lisp
              http://code.google.com/p/vim/issues/detail?id=104

              (No comment was entered for this change.)

              --
              You received this message because this project is configured to send all
              issue notifications to this address.
              You may adjust your notification preferences at:
              https://code.google.com/hosting/settings

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.