Loading ...
Sorry, an error occurred while loading the content.

Re: Issue 103 in vim: Python thread are not running in background

Expand Messages
  • vim@...
    Comment #11 on issue 103 by degu...@gmail.com: Python thread are not running in background http://code.google.com/p/vim/issues/detail?id=103 Changing the
    Message 1 of 18 , Jan 16, 2013
    • 0 Attachment
      Comment #11 on issue 103 by degu...@...: Python thread are not
      running in background
      http://code.google.com/p/vim/issues/detail?id=103

      Changing the initial value of pygilstate to PyGILState_LOCKED may be the
      solution? (I'm only supposing since I don't know how the initial bug could
      be triggered)

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • vim@...
      Updates: Status: Accepted Comment #12 on issue 103 by lech.lor...@gmail.com: Python thread are not running in background
      Message 2 of 18 , Jan 17, 2013
      • 0 Attachment
        Updates:
        Status: Accepted

        Comment #12 on issue 103 by lech.lor...@...: Python thread are not
        running in background
        http://code.google.com/p/vim/issues/detail?id=103

        I also noticed the problem when using clang_complete. Last time closing Vim
        took 2 hours to complete! I'm using Vim 7.3.762 under Cygwin with Python
        2.6.8.

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • vim@...
        Comment #13 on issue 103 by jonathan...@gmail.com: Python thread are not running in background http://code.google.com/p/vim/issues/detail?id=103 Here is how I
        Message 3 of 18 , Jan 25, 2013
        • 0 Attachment
          Comment #13 on issue 103 by jonathan...@...: Python thread are not
          running in background
          http://code.google.com/p/vim/issues/detail?id=103

          Here is how I patched my source.

          Attachments:
          vim-python-thread-issue.patch 974 bytes

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • vim@...
          Comment #14 on issue 103 by degu...@gmail.com: Python thread are not running in background http://code.google.com/p/vim/issues/detail?id=103 That patch seems
          Message 4 of 18 , Jan 29, 2013
          • 0 Attachment
            Comment #14 on issue 103 by degu...@...: Python thread are not
            running in background
            http://code.google.com/p/vim/issues/detail?id=103

            That patch seems to fix the issue indeed.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • vim@...
            Updates: Status: Fixed Comment #15 on issue 103 by brammool...@gmail.com: Python thread are not running in background
            Message 5 of 18 , Jan 30, 2013
            • 0 Attachment
              Updates:
              Status: Fixed

              Comment #15 on issue 103 by brammool...@...: Python thread are not
              running in background
              http://code.google.com/p/vim/issues/detail?id=103

              The patch is included as 7.3.786.
              Please reopen this issue if it didn't fix the problem.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.