Loading ...
Sorry, an error occurred while loading the content.

Some problems with Make_cyg.mak

Expand Messages
  • Ken Takata
    Hi, There are some problems with Make_cyg.mak. 1. i686-w64-mingw32-gcc cannot be used for the ruby interface This is already reported in the following URL.
    Message 1 of 2 , Jan 9, 2013
    • 0 Attachment
      Hi,

      There are some problems with Make_cyg.mak.

      1. i686-w64-mingw32-gcc cannot be used for the ruby interface

      This is already reported in the following URL.
      https://groups.google.com/d/topic/vim_dev/F5lB1SjCFtM/discussion

      2. RUBY_INSTALL_NAME and RUBY_PLATFORM are not set properly

      Some problems with the ruby interface was fixed in 7.3.735,
      but actually it was not enough. I think these settings should be
      copied from Make_ming.mak.

      3. CC=gcc does not work, because the latest cygwin-gcc does not support
      -mno-cygwin option

      I think the default value of CC should be changed from gcc to
      i686-pc-mingw32-gcc, i686-w64-mingw32-gcc or gcc-3.

      Attached patches fix these problems.

      Best regards,
      Ken Takata

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Bram Moolenaar
      ... Thanks! I ll add it in the todo list. -- Did you hear about the new 3 million dollar West Virginia State Lottery? The winner gets 3 dollars a year for a
      Message 2 of 2 , Jan 11, 2013
      • 0 Attachment
        Ken Takata wrote:

        > There are some problems with Make_cyg.mak.
        >
        > 1. i686-w64-mingw32-gcc cannot be used for the ruby interface
        >
        > This is already reported in the following URL.
        > https://groups.google.com/d/topic/vim_dev/F5lB1SjCFtM/discussion
        >
        > 2. RUBY_INSTALL_NAME and RUBY_PLATFORM are not set properly
        >
        > Some problems with the ruby interface was fixed in 7.3.735,
        > but actually it was not enough. I think these settings should be
        > copied from Make_ming.mak.
        >
        > 3. CC=gcc does not work, because the latest cygwin-gcc does not support
        > -mno-cygwin option
        >
        > I think the default value of CC should be changed from gcc to
        > i686-pc-mingw32-gcc, i686-w64-mingw32-gcc or gcc-3.
        >
        > Attached patches fix these problems.

        Thanks! I'll add it in the todo list.

        --
        Did you hear about the new 3 million dollar West Virginia State Lottery?
        The winner gets 3 dollars a year for a million years.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.