Loading ...
Sorry, an error occurred while loading the content.

E763: Word characters differ between spell files

Expand Messages
  • glts
    (I posted this in vim_use a week ago but got no response. Trying again here, I would be thankful if anybody can try to reproduce this.) Hello list ... Since
    Message 1 of 4 , Nov 22, 2012
    • 0 Attachment
      (I posted this in vim_use a week ago but got no response. Trying again
      here, I would be thankful if anybody can try to reproduce this.)


      Hello list

      I am trying to use two spelling languages at the same time:

      :set spelllang=en_gb,de_ch
      :set spell

      Since the de_ch spelllang isn't included by default, Vim downloads and
      installs it automatically at ~/.vim/spell/de.utf-8.spl (also the
      suggestions file at ~/.vim/spell/de.utf-8.sug).

      Spell-checking does work fine for both languages, however, every time I
      enable spell-checking I get

      E763: Word characters differ between spell files

      The help suggests doing :mkspell on the word lists but these are not
      included with Vim. Can you help me fix this? I'm running Vim 7.3.429 on
      Ubuntu 12.04.

      Thank you, glts

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Bram Moolenaar
      ... Try replacing the en_gb spell file that you installed long ago with one downloaded from the server now. The files on the site have been updated some time
      Message 2 of 4 , Nov 22, 2012
      • 0 Attachment
        glts wrote:

        > (I posted this in vim_use a week ago but got no response. Trying again
        > here, I would be thankful if anybody can try to reproduce this.)
        >
        >
        > Hello list
        >
        > I am trying to use two spelling languages at the same time:
        >
        > :set spelllang=en_gb,de_ch
        > :set spell
        >
        > Since the de_ch spelllang isn't included by default, Vim downloads and
        > installs it automatically at ~/.vim/spell/de.utf-8.spl (also the
        > suggestions file at ~/.vim/spell/de.utf-8.sug).
        >
        > Spell-checking does work fine for both languages, however, every time I
        > enable spell-checking I get
        >
        > E763: Word characters differ between spell files
        >
        > The help suggests doing :mkspell on the word lists but these are not
        > included with Vim. Can you help me fix this? I'm running Vim 7.3.429 on
        > Ubuntu 12.04.

        Try replacing the en_gb spell file that you installed long ago with one
        downloaded from the server now. The files on the site have been
        updated some time ago to fix a mistake.

        Unfortunately there is no "update runtime files" command yet.

        --
        Q: What is a patch 22?
        A: A patch you need to include to make it possible to include patches.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • glts
        ... I was using the vim-gnome package on Linux Ubuntu 12.04; I didn t think of updating the runtime files first. Anyway, that did it, problem solved, thank
        Message 3 of 4 , Nov 22, 2012
        • 0 Attachment
          On Thursday, November 22, 2012 10:18:42 PM UTC+1, Bram Moolenaar wrote:
          > Try replacing the en_gb spell file that you installed long ago with
          > one downloaded from the server now. The files on the site have been
          > updated some time ago to fix a mistake.

          I was using the "vim-gnome" package on Linux Ubuntu 12.04; I didn't
          think of updating the runtime files first.
          Anyway, that did it, problem solved, thank you, Bram!

          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Alexey
          I had this error in terminal vim, while MacVim.app was fine. I fixed it by copying some English spell files from
          Message 4 of 4 , Jan 26, 2013
          • 0 Attachment
            I had this error in terminal vim, while MacVim.app was fine.

            I fixed it by copying some English spell files from MacVim.app/Contents/Resources/vim/runtime/spell to ~/.vim/spell

            I decided to post this solution because it worked for me, while i could not try Bram's suggestion because i am not familiar enough with Vim resources (which server? which file to replace? i did not seem to have any English spell files in ~/.vim/spell).

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.