Loading ...
Sorry, an error occurred while loading the content.

mail.vim filetype needs to set 'comments' option

Expand Messages
  • Ben Fritz
    Bram, it came up on vim_use ( https://groups.google.com/d/topic/vim_use/XnKfkjc9bSY/discussion ) that the mail.vim filetype plugin does not currently set the
    Message 1 of 3 , Nov 19, 2012
    • 0 Attachment
      Bram, it came up on vim_use ( https://groups.google.com/d/topic/vim_use/XnKfkjc9bSY/discussion ) that the mail.vim filetype plugin does not currently set the 'comments' option.

      I think you should add:

      setl comments+=n:>

      to the mail.vim ftplugin you maintain in case the user or another ftplugin has changed the 'comments' option from the default value, so that gq works as expected if the user simply sets the filetype.

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Christian Brabandt
      Hi Ben! ... And also set b:undo_ftplugin accordingly. regards, Christian -- Es muß für einen Architekten schon blöd sein, wenn ihm dauernd was einfällt. --
      Message 2 of 3 , Nov 19, 2012
      • 0 Attachment
        Hi Ben!

        On Mo, 19 Nov 2012, Ben Fritz wrote:

        > Bram, it came up on vim_use ( https://groups.google.com/d/topic/vim_use/XnKfkjc9bSY/discussion ) that the mail.vim filetype plugin does not currently set the 'comments' option.
        >
        > I think you should add:
        >
        > setl comments+=n:>
        >
        > to the mail.vim ftplugin you maintain in case the user or another
        > ftplugin has changed the 'comments' option from the default value, so
        > that gq works as expected if the user simply sets the filetype.

        And also set b:undo_ftplugin accordingly.

        regards,
        Christian
        --
        Es muß für einen Architekten schon blöd sein, wenn ihm dauernd was einfällt.

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Bram Moolenaar
        ... Yeah. Although filetype plugins have to assume the defaults are effective, otherwise you never know what is to be set. But this is simple to add in this
        Message 3 of 3 , Nov 20, 2012
        • 0 Attachment
          Ben Fritz wrote:

          > Bram, it came up on vim_use (
          > https://groups.google.com/d/topic/vim_use/XnKfkjc9bSY/discussion )
          > that the mail.vim filetype plugin does not currently set the
          > 'comments' option.
          >
          > I think you should add:
          >
          > setl comments+=n:>
          >
          > to the mail.vim ftplugin you maintain in case the user or another
          > ftplugin has changed the 'comments' option from the default value, so
          > that gq works as expected if the user simply sets the filetype.

          Yeah. Although filetype plugins have to assume the defaults are
          effective, otherwise you never know what is to be set.
          But this is simple to add in this specific case.

          --
          It was recently discovered that research causes cancer in rats.

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.