Loading ...
Sorry, an error occurred while loading the content.

Re: Issue 91 in vim: File->Open does not update window content correctly - Appeared first in v7-3-638

Expand Messages
  • John Little
    ... Well, I can t reproduce this, with Linux Mint 12, using Mate, and a just built gvim 7.3.705. (I was quite disappointed, had to add sources to build vim and
    Message 1 of 11 , Nov 2, 2012
    • 0 Attachment
      > 5. Contents are not updated, section of Filelist still shows

      Well, I can't reproduce this, with Linux Mint 12, using Mate, and a just built gvim 7.3.705.

      (I was quite disappointed, had to add sources to build vim and apt-get upgrade downloaded vast amounts of stuff, I hadn't used this Mint install for over a year.)

      Regards, John

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • vim@...
      Comment #1 on issue 91 by chrisbr...@googlemail.com: File- Open does not update window content correctly - Appeared first in v7-3-638
      Message 2 of 11 , Sep 30, 2014
      • 0 Attachment
        Comment #1 on issue 91 by chrisbr...@...: File->Open does not
        update window content correctly - Appeared first in v7-3-638
        https://code.google.com/p/vim/issues/detail?id=91

        Is this still reproducable?

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • vim@...
        Comment #2 on issue 91 by fancymo...@fancymouse.net: File- Open does not update window content correctly - Appeared first in v7-3-638
        Message 3 of 11 , Nov 22, 2014
        • 0 Attachment
          Comment #2 on issue 91 by fancymo...@...: File->Open does not
          update window content correctly - Appeared first in v7-3-638
          https://code.google.com/p/vim/issues/detail?id=91

          Still reproducible with Linux Mint (LMDE with MATE) stock package (7.4,
          --version saying includes patches 1-52) or my own build (7.4 from official
          dl site, same configure option).

          Additional comments:
          1. More likely to occur when navigating with Ctrl-F/Ctrl-B, leaving at
          least half of the screen blank.
          2. Only gvim is affected. vim is fine.

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • vim@...
          Comment #3 on issue 91 by chrisbr...@googlemail.com: File- Open does not update window content correctly - Appeared first in v7-3-638
          Message 4 of 11 , Nov 24, 2014
          • 0 Attachment
            Comment #3 on issue 91 by chrisbr...@...: File->Open does not
            update window content correctly - Appeared first in v7-3-638
            https://code.google.com/p/vim/issues/detail?id=91

            I can reproduce the issue. Unfortunately, I do not know, why patch 7.3.638
            should cause the issue. It looks to me, like the gtk drawing libraries are
            not updating the window correctly, because if I see this correctly, Vim
            requests redrawing of the complete buffer content. I do not know gtk good
            enough to propose a fix though.

            --
            You received this message because this project is configured to send all
            issue notifications to this address.
            You may adjust your notification preferences at:
            https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • vim@...
            Comment #4 on issue 91 by chrisbr...@googlemail.com: File- Open does not update window content correctly - Appeared first in v7-3-638
            Message 5 of 11 , Nov 25, 2014
            • 0 Attachment
              Comment #4 on issue 91 by chrisbr...@...: File->Open does not
              update window content correctly - Appeared first in v7-3-638
              https://code.google.com/p/vim/issues/detail?id=91

              You might want to report that bug also to the Mate developers, because it
              seems to be Mate specific (or does it happen with other desktop
              environments?).

              Nevertheless, Here is a simple patch, that forces a redraw in the gtk gui,
              that seems to work around the problem. Nevertheless, it would be good, if a
              developer with a more found GTK background could have a look at that issue
              (and my patch).

              Attachments:
              gtk2_force_redraw.diff 1.2 KB

              --
              You received this message because this project is configured to send all
              issue notifications to this address.
              You may adjust your notification preferences at:
              https://code.google.com/hosting/settings

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • vim@...
              Comment #5 on issue 91 by fancymo...@fancymouse.net: File- Open does not update window content correctly - Appeared first in v7-3-638
              Message 6 of 11 , Dec 5, 2014
              • 0 Attachment
                Comment #5 on issue 91 by fancymo...@...: File->Open does not
                update window content correctly - Appeared first in v7-3-638
                https://code.google.com/p/vim/issues/detail?id=91

                Thanks for the patch. Although with your patch as is, Ctrl-F/B still
                breaks. But after I comment out "if (type >= NOT_VALID)", it now looks good
                to me.

                --
                You received this message because this project is configured to send all
                issue notifications to this address.
                You may adjust your notification preferences at:
                https://code.google.com/hosting/settings

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • vim@...
                Updates: Labels: patch Comment #6 on issue 91 by chrisbr...@googlemail.com: File- Open does not update window content correctly - Appeared first in v7-3-638
                Message 7 of 11 , Jan 9
                • 0 Attachment
                  Updates:
                  Labels: patch

                  Comment #6 on issue 91 by chrisbr...@...: File->Open does not
                  update window content correctly - Appeared first in v7-3-638
                  https://code.google.com/p/vim/issues/detail?id=91

                  (No comment was entered for this change.)

                  --
                  You received this message because this project is configured to send all
                  issue notifications to this address.
                  You may adjust your notification preferences at:
                  https://code.google.com/hosting/settings

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                • vim@...
                  Comment #7 on issue 91 by fancymo...@fancymouse.net: File- Open does not update window content correctly - Appeared first in v7-3-638
                  Message 8 of 11 , Mar 10 3:23 AM
                  • 0 Attachment
                    Comment #7 on issue 91 by fancymo...@...: File->Open does not
                    update window content correctly - Appeared first in v7-3-638
                    https://code.google.com/p/vim/issues/detail?id=91

                    May not be a Mint specific problem... just got a chance to have a try from
                    Debian Testing (jessie rc1) and it's even worse. The patch still works.

                    --
                    You received this message because this project is configured to send all
                    issue notifications to this address.
                    You may adjust your notification preferences at:
                    https://code.google.com/hosting/settings

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/d/optout.
                  • vim@...
                    Comment #8 on issue 91 by chrisbr...@googlemail.com: File- Open does not update window content correctly - Appeared first in v7-3-638
                    Message 9 of 11 , Mar 11 11:17 AM
                    • 0 Attachment
                      Comment #8 on issue 91 by chrisbr...@...: File->Open does not
                      update window content correctly - Appeared first in v7-3-638
                      https://code.google.com/p/vim/issues/detail?id=91

                      The problem with this approach is, it will make Vim a whole lot slower,
                      since what it really does it always force a complete redraw. That is most
                      certainly not what is wanted.

                      --
                      You received this message because this project is configured to send all
                      issue notifications to this address.
                      You may adjust your notification preferences at:
                      https://code.google.com/hosting/settings

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/d/optout.
                    • vim@...
                      Comment #9 on issue 91 by brammool...@gmail.com: File- Open does not update window content correctly - Appeared first in v7-3-638
                      Message 10 of 11 , Mar 24 8:18 AM
                      • 0 Attachment
                        Comment #9 on issue 91 by brammool...@...: File->Open does not update
                        window content correctly - Appeared first in v7-3-638
                        https://code.google.com/p/vim/issues/detail?id=91

                        I cannot reproduce the problem. It smells like a GTK library problem.

                        The patch will redraw too often, causing flicker.
                        Patch 7.3.638 merely removed an unnecessary redraw, which likely uncovered
                        an existing problem.


                        --
                        You received this message because this project is configured to send all
                        issue notifications to this address.
                        You may adjust your notification preferences at:
                        https://code.google.com/hosting/settings

                        --
                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                        For more options, visit https://groups.google.com/d/optout.
                      Your message has been successfully submitted and would be delivered to recipients shortly.