Loading ...
Sorry, an error occurred while loading the content.

Re: gVim's internal borders

Expand Messages
  • aschneiderg
    ... You are right. The FTP build has a small 2px all around border only (WS_EX_CLIENTEDGE). I cloned Bram s repo (7.3.691), called vcvarsx86_amd64.bat only
    Message 1 of 9 , Oct 16, 2012
    • 0 Attachment
      El lunes, 15 de octubre de 2012 20:57:13 UTC-7, John Little escribió:
      > > I am not sure I can see black borders, mine are white (right one and bottom one). I found that on mouse over them the cursor changes to window resize, so there are two resize events I guess. Vim's one and Winblows one.
      >
      > Oops, I view Google groups with colours inverted, (white backgrounds hurt my eyes) and forgot this when I looked at your screenshot.
      >
      > So you really do get that border, coloured differently to vim's background colour.
      >
      > I've just installed a recent vim on win xp, and I see no vim-specific internal border. So, sorry, I'm no help, I suggest you give details of your OS and vim version and maybe someone with a similar system can help.
      >
      > Regards, John

      You are right. The FTP build has a small 2px all around border only (WS_EX_CLIENTEDGE).

      I cloned Bram's repo (7.3.691), called vcvarsx86_amd64.bat only appending GUI=yes and got the bottom/right issue again. Both x86 and 64 builds. No vimrc.

      We are testing Windows 8 Enterprise 64 bit / Visual Studio 2012 for our university. Putty, R, and related are compiling just fine. Win7/MVS2010 with the described clean install built the same bottom/right borders. I added :version screenshots.

      My best regards.





      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • veegee@...
      ... I only noticed this problem when I compiled my own Vim on Windows 8. Solved by running in compatibility mode for Windows 7. -- -- You received this message
      Message 2 of 9 , Apr 18 1:52 PM
      • 0 Attachment
        On Monday, October 15, 2012 3:43:30 AM UTC-4, aschneiderg wrote:
        > I understand they may result useful in some situations but I found them annoying.
        >
        > Replacing WS_EX_CLIENTEDGE with WS_EX_LEFT in gui_w32.c did the trick for the top and left ones, but the bottom one is still there and the right one appears when guifont is set.(image)
        >
        > I have no experience in Vim's source yet. Any hints on how this internal borders (which seem to be somehow the same in GTK builds too) are generated ?
        >
        > My best regards.

        I only noticed this problem when I compiled my own Vim on Windows 8.

        Solved by running in compatibility mode for Windows 7.

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • aschneiderg
        ... Hey there. Are your builds available online ? I would like to check them out. All the best. -- -- You received this message from the vim_dev maillist. Do
        Message 3 of 9 , Apr 18 7:18 PM
        • 0 Attachment
          On Thursday, April 18, 2013 3:52:30 PM UTC-5, vee...@... wrote:
          > On Monday, October 15, 2012 3:43:30 AM UTC-4, aschneiderg wrote:
          > > I understand they may result useful in some situations but I found them annoying.
          > >
          > > Replacing WS_EX_CLIENTEDGE with WS_EX_LEFT in gui_w32.c did the trick for the top and left ones, but the bottom one is still there and the right one appears when guifont is set.(image)
          > >
          > > I have no experience in Vim's source yet. Any hints on how this internal borders (which seem to be somehow the same in GTK builds too) are generated ?
          > >
          > > My best regards.
          >
          > I only noticed this problem when I compiled my own Vim on Windows 8.
          >
          > Solved by running in compatibility mode for Windows 7.

          Hey there.

          Are your builds available online ? I would like to check them out.

          All the best.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • veegee@...
          ... Uploaded for you guys. Couldn t find any 64-bit builds myself, might as well save everyone else the trouble. It s also quite a nuisance to build vim (let
          Message 4 of 9 , Apr 18 8:40 PM
          • 0 Attachment
            On Thursday, April 18, 2013 10:18:22 PM UTC-4, aschneiderg wrote:
            > Hey there.
            >
            > Are your builds available online ? I would like to check them out.
            >
            > All the best.

            Uploaded for you guys. Couldn't find any 64-bit builds myself, might as well save everyone else the trouble. It's also quite a nuisance to build vim (let alone *anything*) on winbloze. Also, I tested build using VS2012 AND VS2010. VS2012 seems to be causing problems with the border, and several other problems including crashes, freezes, missing cursor, etc. VS2010 is building a working executable as expected.

            Note, this is a 64-bit build, compiled with 64-bit Python33 and Python27 dynamic lib support.

            Let me know if it gives you any problems.

            Download: http://solar-blogg.blogspot.ca/2013/04/vim-windows-64-bit-build.html

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Ben Fritz
            ... I haven t tried building 64-bit, maybe that s different. But building Vim with MinGW on Windows is easier than Linux. You just download the source, install
            Message 5 of 9 , Apr 19 8:40 AM
            • 0 Attachment
              On Thursday, April 18, 2013 10:40:48 PM UTC-5, vee...@... wrote:
              > On Thursday, April 18, 2013 10:18:22 PM UTC-4, aschneiderg wrote:
              > > Hey there.
              > >
              > > Are your builds available online ? I would like to check them out.
              > >
              > > All the best.
              >
              > Uploaded for you guys. Couldn't find any 64-bit builds myself, might as well save everyone else the trouble. It's also quite a nuisance to build vim (let alone *anything*) on winbloze.

              I haven't tried building 64-bit, maybe that's different.

              But building Vim with MinGW on Windows is easier than Linux. You just download the source, install MinGW, and build. No dependencies to worry about.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.