Loading ...
Sorry, an error occurred while loading the content.

Issue 71 in vim: gvim over ssh features undrawn characters

Expand Messages
  • vim@googlecode.com
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 71 by shlomif@gmail.com: gvim over ssh features undrawn characters
    Message 1 of 10 , Jun 24, 2012
    View Source
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 71 by shlomif@...: gvim over ssh features undrawn characters
      http://code.google.com/p/vim/issues/detail?id=71

      Hi all,

      sometimes I ssh from my Mageia Linux 2 laptop (x86-64) to my Mageia Linux
      3/Cauldron x86-64 desktop machine and run gvim on the remote shell, that
      pops up a window on the laptop X display machine, by using ssh's X
      tunneling.

      Now, recently gvim started featured undrawn characters when I change some
      text in syntax highlighting mode, and the characters on the current line
      (or other characters) disappear. This can be fixed by moving the input
      focus out of the gvim window.

      Mageia Linux 2 ships with these packages:

      ftp://ftp.nluug.nl/pub/os/Linux/distr/mageia/distrib/2/x86_64/media/core/release/

      While Mageia Linux Cauldron contains these packages:

      ftp://ftp.nluug.nl/pub/os/Linux/distr/mageia/distrib/cauldron/x86_64/media/core/release/

      I tried compiling gvim using this script:

      #!/bin/bash
      set -x
      ./configure "$@" --prefix=$HOME/apps/vim --with-features=huge \
      --enable-perlinterp --enable-pythoninterp --enable-rubyinterp \
      --enable-tclinterp --enable-luainterp

      And I also got the disappearing characters.

      My computers are:

      1. My Mageia Cauldron machine is a desktop machine with a:

      An Intel Core i3 CPU (x86-64).
      8 GB of RAM.
      Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09)
      A 2 TB hard-disk.
      A 19״ LCD Screen by ViewSonic.
      Intel Corporation Cougar Point High Definition Audio Controller.
      Intel Corporation 82579V Gigabit Network Connection.

      2. My Mageia Linux 2 machine is an Acer Aspire 5738DZG laptop with the
      following specs:

      Intel Pentium(R) Dual-Core CPU T4300 @ 2.10GHz. (x86-64).
      ATI Mobility Radeon™ HD 4570 (r700)
      15.6״ 3D HD LCD Screen.
      3 GB Memory
      320 GB Hard Disk Drive.
      “DVD Super Multi DL drive”
      Acer Nplify™ 802.11b/g/n.


      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • vim@googlecode.com
      Comment #1 on issue 71 by chrisbr...@gmail.com: gvim over ssh features undrawn characters http://code.google.com/p/vim/issues/detail?id=71 Is there an easy way
      Message 2 of 10 , Aug 15, 2012
      View Source
      • 0 Attachment
        Comment #1 on issue 71 by chrisbr...@...: gvim over ssh features
        undrawn characters
        http://code.google.com/p/vim/issues/detail?id=71

        Is there an easy way to reproduce the issue?

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • vim@googlecode.com
        Comment #2 on issue 71 by shlo...@iglu.org.il: gvim over ssh features undrawn characters http://code.google.com/p/vim/issues/detail?id=71 Well, I can reproduce
        Message 3 of 10 , Aug 15, 2012
        View Source
        • 0 Attachment
          Comment #2 on issue 71 by shlo...@...: gvim over ssh features
          undrawn characters
          http://code.google.com/p/vim/issues/detail?id=71

          Well, I can reproduce it pretty easily with my set-up. But I don't know
          exactly where the problem lies, so I don't have any better suggestions
          other than setting up VMs with this.

          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Gary Johnson
          ... What would really help would be the following. 1. A small file containing at least one of the characters that does not redraw properly. 2. A sequence of
          Message 4 of 10 , Aug 15, 2012
          View Source
          • 0 Attachment
            On 2012-08-15, vim@... wrote:
            > Comment #2 on issue 71 by shlo...@...: gvim over ssh features
            > undrawn characters
            > http://code.google.com/p/vim/issues/detail?id=71
            >
            > Well, I can reproduce it pretty easily with my set-up. But I don't
            > know exactly where the problem lies, so I don't have any better
            > suggestions other than setting up VMs with this.

            What would really help would be the following.

            1. A small file containing at least one of the characters that does
            not redraw properly.

            2. A sequence of steps that will demonstrate the problem. It is
            preferable that you start gvim like this:

            gvim -N -u NONE -i NONE [your other arguments]

            so that your environment is free of the effects of your ~/.vimrc
            and any plugins and so that everyone's environment can be the
            same while trying to troubleshoot this.

            Regards,
            Gary

            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Gary Johnson
            ... Hmm. I guess I need to leave that comment on the code.google.com issue page for it to do any good. Phooey. Regards, Gary -- You received this message
            Message 5 of 10 , Aug 15, 2012
            View Source
            • 0 Attachment
              On 2012-08-15, Gary Johnson wrote:
              > On 2012-08-15, vim@... wrote:
              > > Comment #2 on issue 71 by shlo...@...: gvim over ssh features
              > > undrawn characters
              > > http://code.google.com/p/vim/issues/detail?id=71
              > >
              > > Well, I can reproduce it pretty easily with my set-up. But I don't
              > > know exactly where the problem lies, so I don't have any better
              > > suggestions other than setting up VMs with this.
              >
              > What would really help would be the following.
              >
              > 1. A small file containing at least one of the characters that does
              > not redraw properly.
              >
              > 2. A sequence of steps that will demonstrate the problem. It is
              > preferable that you start gvim like this:
              >
              > gvim -N -u NONE -i NONE [your other arguments]
              >
              > so that your environment is free of the effects of your ~/.vimrc
              > and any plugins and so that everyone's environment can be the
              > same while trying to troubleshoot this.

              Hmm. I guess I need to leave that comment on the code.google.com
              issue page for it to do any good. Phooey.

              Regards,
              Gary

              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • vim@googlecode.com
              Comment #3 on issue 71 by shlomif@gmail.com: gvim over ssh features undrawn characters http://code.google.com/p/vim/issues/detail?id=71 A comment from Gary
              Message 6 of 10 , Aug 16, 2012
              View Source
              • 0 Attachment
                Comment #3 on issue 71 by shlomif@...: gvim over ssh features undrawn
                characters
                http://code.google.com/p/vim/issues/detail?id=71

                A comment from Gary Johnson on the vim-dev mailing list:

                What would really help would be the following.

                1. A small file containing at least one of the characters that does
                not redraw properly.

                2. A sequence of steps that will demonstrate the problem. It is
                preferable that you start gvim like this:

                gvim -N -u NONE -i NONE [your other arguments]

                so that your environment is free of the effects of your ~/.vimrc
                and any plugins and so that everyone's environment can be the
                same while trying to troubleshoot this.

                Regards,
                Gary

                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • vim@googlecode.com
                Comment #4 on issue 71 by shlomif@gmail.com: gvim over ssh features undrawn characters http://code.google.com/p/vim/issues/detail?id=71 OK, the following file
                Message 7 of 10 , Aug 16, 2012
                View Source
                • 0 Attachment
                  Comment #4 on issue 71 by shlomif@...: gvim over ssh features undrawn
                  characters
                  http://code.google.com/p/vim/issues/detail?id=71

                  OK, the following file reproduces the problem with

                  $ gvim -U NONE -u NONE -i NONE depth_dbm_solver.c

                  (in a new UNIX user account).

                  To reproduce:

                  1. Do :350<CR> so you're on this line:

                  printf ("H %i\n", (int)out_fh);

                  2. Hit "a" to enter into insert mode.

                  3. Hold the right arrow key until the cursor moves to the end of the line.
                  Then, hold the left arrow key until the cursor moves to the start of the
                  line.
                  Repeat.

                  4. Result: some characters disappear for a while holding the left key after
                  the cursor passed through them.

                  Regards,

                  -- Shlomi Fish

                  Attachments:
                  depth_dbm_solver.c 31.3 KB

                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • vim@googlecode.com
                  Comment #5 on issue 71 by dominiqu...@gmail.com: gvim over ssh features undrawn characters http://code.google.com/p/vim/issues/detail?id=71 ... Try adding the
                  Message 8 of 10 , Aug 16, 2012
                  View Source
                  • 0 Attachment
                    Comment #5 on issue 71 by dominiqu...@...: gvim over ssh features
                    undrawn characters
                    http://code.google.com/p/vim/issues/detail?id=71

                    Shlomi wrote:

                    > OK, the following file reproduces the problem with

                    > $ gvim -U NONE -u NONE -i NONE depth_dbm_solver.c

                    Try adding the -w option to log all keys:

                    $ gvim -U NONE -u NONE -i NONE -w log-keys.txt depth_dbm_solver.c

                    Then reproduce the bug and attach the output file log-keys.txt
                    to this issue.

                    I suspect that some characters are lost so vim sees the keys as input.
                    We may see that in log-keys.txt. It may not be Vim's fault.

                    I can't reproduce it myself.



                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • vim@googlecode.com
                    Comment #6 on issue 71 by shlo...@iglu.org.il: gvim over ssh features undrawn characters http://code.google.com/p/vim/issues/detail?id=71 Here is the
                    Message 9 of 10 , Aug 16, 2012
                    View Source
                    • 0 Attachment
                      Comment #6 on issue 71 by shlo...@...: gvim over ssh features
                      undrawn characters
                      http://code.google.com/p/vim/issues/detail?id=71

                      Here is the log-keys.txt file. Hope it helps.

                      Attachments:
                      log-keys.txt 2.2 KB

                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • vim@googlecode.com
                      Comment #7 on issue 71 by shlomif@gmail.com: gvim over ssh features undrawn characters http://code.google.com/p/vim/issues/detail?id=71 Update: now that I
                      Message 10 of 10 , Nov 5, 2012
                      View Source
                      • 0 Attachment
                        Comment #7 on issue 71 by shlomif@...: gvim over ssh features undrawn
                        characters
                        http://code.google.com/p/vim/issues/detail?id=71

                        Update: now that I upgraded my laptop to Mageia Cauldron (the Mageia
                        development distribution that is going to be Mageia 3), I can no longer
                        reproduce this problem. As far as I am concerned, it can be closed, but you
                        may wish to investigate this problem in order to prevent future users
                        running into it and reporting it.

                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      Your message has been successfully submitted and would be delivered to recipients shortly.