Loading ...
Sorry, an error occurred while loading the content.
 

Re: On Ubuntu 12.04, GTK Gvim doesn't work properly.

Expand Messages
  • Bram Moolenaar
    ... Thanks. I just upgraded to 12.04 thus I should be able to verify this soon. -- It is illegal to rob a bank and then shoot at the bank teller with a water
    Message 1 of 6 , May 2, 2012
      Yasuhiro Matsumoto wrote:

      > It seems that gtk_init connect to dbus session. Currently, it is
      > called before fork, i.e. parent process.
      > Parent process quit after the checking gui enable. So dbus session
      > become disconnected.
      >
      > https://bugs.launchpad.net/ubuntu/+source/vim/+bug/987707
      >
      > I moved call of gtk_init to child process.
      >
      > https://gist.github.com/2576464
      >
      > It seens good to me.

      Thanks. I just upgraded to 12.04 thus I should be able to verify this
      soon.

      --
      It is illegal to rob a bank and then shoot at the bank teller with a water
      pistol.
      [real standing law in Louisana, United States of America]

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • mattn
      I had mistake in the patch. Please look newer in same URL. ... -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below
      Message 2 of 6 , May 7, 2012
        I had mistake in the patch.
        Please look newer in same URL.

        On Wednesday, May 2, 2012 10:35:12 PM UTC+9, Bram Moolenaar wrote:
        > Yasuhiro Matsumoto wrote:
        >
        > > It seems that gtk_init connect to dbus session. Currently, it is
        > > called before fork, i.e. parent process.
        > > Parent process quit after the checking gui enable. So dbus session
        > > become disconnected.
        > >
        > > https://bugs.launchpad.net/ubuntu/+source/vim/+bug/987707
        > >
        > > I moved call of gtk_init to child process.
        > >
        > > https://gist.github.com/2576464
        > >
        > > It seens good to me.
        >
        > Thanks. I just upgraded to 12.04 thus I should be able to verify this
        > soon.
        >
        > --
        > It is illegal to rob a bank and then shoot at the bank teller with a water
        > pistol.
        > [real standing law in Louisana, United States of America]
        >
        > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        > \\\ an exciting new programming language -- http://www.Zimbu.org ///
        > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.