Loading ...
Sorry, an error occurred while loading the content.

Re: BUG: xxd -r strips a byte depending on value of last byte of binary

Expand Messages
  • Britton Kerin
    Hmm, I can t either. How annoying. I saw it many many times the other day, not sure what was different. My vi setup sometimes inserts a gratuitous ^]
    Message 1 of 3 , May 1, 2012
    • 0 Attachment
      Hmm, I can't either. How annoying. I saw it many many times the
      other day, not sure what was different. My vi setup sometimes inserts
      a gratuitous ^] character when I'm coding, I don't know when in my
      many .vimrc changes it started doing it, but it looks like a
      non-printing character representation or something, maybe it was
      related to that. But that's only a long-shot guess.

      Britton

      On Thu, Apr 26, 2012 at 9:47 PM, John Little <John.B.Little@...> wrote:
      > Sorry, I can't reproduce this, vim 7.3.475 and xxd V1.10 on linux.
      > What versions and OS?  What 16 bytes do you get?
      >
      > I suspected there was some interaction with the endofline option, which applies if you set binary, but I have to explicitly :set binary noeol before saving to get a 16 byte file on saving, and I see [noeol] in vim's saving message.
      >
      > Regards, John
      >
      >
      > --
      > You received this message from the "vim_dev" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.