Loading ...
Sorry, an error occurred while loading the content.

Issue 62 in vim: Netrw v145: '/' character in 'is keyword' leaks into new buffers

Expand Messages
  • vim@googlecode.com
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 62 by Michael....@gmail.com: Netrw v145: / character in is keyword leaks into new
    Message 1 of 5 , Apr 11, 2012
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 62 by Michael....@...: Netrw v145: '/' character in 'is
      keyword' leaks into new buffers
      http://code.google.com/p/vim/issues/detail?id=62

      What steps will reproduce the problem?

      1. Edit a file in Vim over FTP using Netrw.
      2. Subsequently created buffers have the '/' character as part of the 'is
      keyword' string, This messes with syntax highlighting and indentation of
      various files (e.g. HTML, XML etc.).

      What is the expected output? What do you see instead?

      The global value of 'is keyword' should *not* be updated.

      What version of the product are you using? On what operating system?

      Netrw v145

      Please provide any additional information below.

      I attach a patch which fixes the issue for me. It would appear that some
      file detection code added in v145 modifies the global value of 'iso'
      instead of the local value. The patch also corrects a missing ')' in the
      netrw#NetRead function and removes an extraneous 'endif'.

      Attachments:
      netrw_145.patch 1.6 KB

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • vim@googlecode.com
      Comment #1 on issue 62 by Michael....@gmail.com: Netrw v145: / character in is keyword leaks into new buffers
      Message 2 of 5 , Apr 11, 2012
      • 0 Attachment
        Comment #1 on issue 62 by Michael....@...: Netrw v145: '/' character
        in 'is keyword' leaks into new buffers
        http://code.google.com/p/vim/issues/detail?id=62

        Sorry, that 'iso' above should read: 'isk'

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • vim@googlecode.com
        Comment #2 on issue 62 by drc...@campbellfamily.biz: Netrw v145: / character in is keyword leaks into new buffers
        Message 3 of 5 , Apr 11, 2012
        • 0 Attachment
          Comment #2 on issue 62 by drc...@...: Netrw v145: '/'
          character in 'is keyword' leaks into new buffers
          http://code.google.com/p/vim/issues/detail?id=62

          I tried the given steps with v146d and did not observe the issue.

          iskeyword is supposed to be local-to-buffer, but apparently new buffers
          subsequently edited in the stead of the buffer appear inherit that buffer's
          iskeyword setting (unless modified otherwise, presumably). I'll change
          that.

          I will also include the missing parenthesis.

          The extra "endif" had been elided already.

          I need to test some other changes (supporting Windows) before releasing
          v146e, but probably won't be able to get to doing this until this weekend
          (Apr 14,15).

          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • vim@googlecode.com
          Comment #3 on issue 62 by Michael....@gmail.com: Netrw v145: / character in is keyword leaks into new buffers
          Message 4 of 5 , Apr 11, 2012
          • 0 Attachment
            Comment #3 on issue 62 by Michael....@...: Netrw v145: '/' character
            in 'is keyword' leaks into new buffers
            http://code.google.com/p/vim/issues/detail?id=62

            Hi, thanks for the response.

            In terms of reproducing the problem, I think you may have to browse a
            directory using Netrw first. I can reproduce consistently, using FTP at
            least.

            In terms of 'is keyword' being buffer-local - it is, but it is initialised
            from the global value. Vim's help says:

            "When editing a new buffer, its local option values must be initialized.
            Since
            the local options of the current buffer might be specifically for that
            buffer,
            these are not used. Instead, for each buffer-local option there also is a
            global value, which is used for new buffers. With ":set" both the local and
            global value is changed. With "setlocal" only the local value is changed,
            thus this value is not used when editing a new buffer."




            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • vim@...
            Updates: Status: Fixed Comment #4 on issue 62 by drc...@campbellfamily.biz: Netrw v145: / character in is keyword leaks into new buffers
            Message 5 of 5 , Feb 11 12:55 PM
            • 0 Attachment
              Updates:
              Status: Fixed

              Comment #4 on issue 62 by drc...@...: Netrw v145: '/'
              character in 'is keyword' leaks into new buffers
              http://code.google.com/p/vim/issues/detail?id=62

              This issue appears to have been fixed awhile back, so I'm closing it as
              fixed. FYI: see http://www.drchip.org/astronaut/vim/index.html#NETRW if
              you wish to have the latest (albeit experimental) version of netrw.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.