Loading ...
Sorry, an error occurred while loading the content.
 

Bug in conceal feature

Expand Messages
  • Marcin Szamotulski
    Hello, I found a strange behaviour of the conceal feature. Here is how to reproduce it (I m on GNU/Linux): vim -u NONE --noplugin ... Now $ in normal mode
    Message 1 of 3 , Mar 31, 2012
      Hello,

      I found a strange behaviour of the conceal feature. Here is how to reproduce
      it (I'm on GNU/Linux):

      vim -u NONE --noplugin
      :help +xim
      :syntax enable
      :set syntax=help
      :set cole=2
      :set cocu=n

      Now $ in normal mode brings the cursor far beyond the end of the line which
      is:
      m *+xim* X input method |xim|

      Now using Fx (after $) also set the cursor beyond the line end (and not over
      the x in |xim|). But using CTRL-] at this position opens the help page for
      *xim* which is fine. While when putting the cursor over x it opens
      *ole-methods* since in fact the cursor is over the word method in the above
      line.

      When cole=0 is set everything works fine and it seems the position of the
      cursor with cole=2 and cole=0 agree. Also when cocu is not set (is empty)
      everything works fine.

      I use vim-7.3.487 (in the terminal but the same I can reproduce in
      gvim-7.3.487).

      Best,
      Marcin

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Christian Brabandt
      Hi Marcin! ... That is known and probably already in Bram s todo list. Dominique Pellé and I have also just talked about that at
      Message 2 of 3 , Mar 31, 2012
        Hi Marcin!

        On Sa, 31 Mär 2012, Marcin Szamotulski wrote:

        > Hello,
        >
        > I found a strange behaviour of the conceal feature. Here is how to reproduce
        > it (I'm on GNU/Linux):
        >
        > vim -u NONE --noplugin
        > :help +xim
        > :syntax enable
        > :set syntax=help
        > :set cole=2
        > :set cocu=n
        >
        > Now $ in normal mode brings the cursor far beyond the end of the line which
        > is:
        > m *+xim* X input method |xim|
        >
        > Now using Fx (after $) also set the cursor beyond the line end (and not over
        > the x in |xim|). But using CTRL-] at this position opens the help page for
        > *xim* which is fine. While when putting the cursor over x it opens
        > *ole-methods* since in fact the cursor is over the word method in the above
        > line.
        >
        > When cole=0 is set everything works fine and it seems the position of the
        > cursor with cole=2 and cole=0 agree. Also when cocu is not set (is empty)
        > everything works fine.
        >
        > I use vim-7.3.487 (in the terminal but the same I can reproduce in
        > gvim-7.3.487).

        That is known and probably already in Bram's todo list. Dominique Pellé
        and I have also just talked about that at
        http://groups.google.com/group/vim_dev/msg/ac0bd5ae66e55177
        and
        http://groups.google.com/group/vim_dev/msg/b36a94dd486b2287

        Dominique's patch seems to solve the issue.

        regards,
        Christian

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Marcin Szamotulski
        Hello, I can confirm that the patch fixes this issue as well. Best regards, Marcin ... -- You received this message from the vim_dev maillist. Do not
        Message 3 of 3 , Mar 31, 2012
          Hello,

          I can confirm that the patch fixes this issue as well.

          Best regards,
          Marcin

          On 11:53 Sat 31 Mar , Marcin Szamotulski wrote:
          > Hello,
          >
          > I found a strange behaviour of the conceal feature. Here is how to reproduce
          > it (I'm on GNU/Linux):
          >
          > vim -u NONE --noplugin
          > :help +xim
          > :syntax enable
          > :set syntax=help
          > :set cole=2
          > :set cocu=n
          >
          > Now $ in normal mode brings the cursor far beyond the end of the line which
          > is:
          > m *+xim* X input method |xim|
          >
          > Now using Fx (after $) also set the cursor beyond the line end (and not over
          > the x in |xim|). But using CTRL-] at this position opens the help page for
          > *xim* which is fine. While when putting the cursor over x it opens
          > *ole-methods* since in fact the cursor is over the word method in the above
          > line.
          >
          > When cole=0 is set everything works fine and it seems the position of the
          > cursor with cole=2 and cole=0 agree. Also when cocu is not set (is empty)
          > everything works fine.
          >
          > I use vim-7.3.487 (in the terminal but the same I can reproduce in
          > gvim-7.3.487).
          >
          > Best,
          > Marcin

          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.