Loading ...
Sorry, an error occurred while loading the content.

Issue 54 in vim: :command -complete option affects processing command arguments

Expand Messages
  • vim@googlecode.com
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 54 by zyx....@gmail.com: :command -complete option affects processing command arguments
    Message 1 of 4 , Mar 4 10:08 AM
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 54 by zyx....@...: :command -complete option affects
      processing command arguments
      http://code.google.com/p/vim/issues/detail?id=54

      What steps will reproduce the problem?

      1. Define a command: `:command -nargs=1 -complete=dir Echo :echo <q-args>`
      2. Run it: `:Echo $HOME`

      What is the expected output? What do you see instead?

      Expected: $HOME (would have seen this if there were no “-complete=dir”
      argument)

      Seeing: /home/zyx

      What version of the product are you using? On what operating system?

      vim-7.3.456

      Even if this is intended behavior, I do see its documentation nowhere
      between `:h :command-complete` and `:h command-completion-custom`.

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • vim@...
      Comment #1 on issue 54 by chrisbr...@googlemail.com: :command -complete option affects processing command arguments
      Message 2 of 4 , Sep 30, 2014
      • 0 Attachment
        Comment #1 on issue 54 by chrisbr...@...: :command -complete
        option affects processing command arguments
        https://code.google.com/p/vim/issues/detail?id=54

        Let's just document that behaviour for now:

        diff --git a/runtime/doc/map.txt b/runtime/doc/map.txt
        --- a/runtime/doc/map.txt
        +++ b/runtime/doc/map.txt
        @@ -1283,6 +1283,7 @@ completion can be enabled:
        -complete=custom,{func} custom completion, defined via {func}
        -complete=customlist,{func} custom completion, defined via {func}

        +Note: That some completion methods might expand environment variables.

        Custom completion *:command-completion-custom*
        *:command-completion-customlist*


        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • vim@...
        Comment #2 on issue 54 by brammool...@gmail.com: :command -complete option affects processing command arguments
        Message 3 of 4 , Sep 30, 2014
        • 0 Attachment
          Comment #2 on issue 54 by brammool...@...: :command -complete option
          affects processing command arguments
          https://code.google.com/p/vim/issues/detail?id=54

          I'll include that change.

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • vim@...
          Updates: Status: Fixed Comment #3 on issue 54 by chrisbr...@googlemail.com: :command -complete option affects processing command arguments
          Message 4 of 4 , Oct 8, 2014
          • 0 Attachment
            Updates:
            Status: Fixed

            Comment #3 on issue 54 by chrisbr...@...: :command -complete
            option affects processing command arguments
            https://code.google.com/p/vim/issues/detail?id=54

            Closing, as the documentation has been adjusted.

            --
            You received this message because this project is configured to send all
            issue notifications to this address.
            You may adjust your notification preferences at:
            https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          Your message has been successfully submitted and would be delivered to recipients shortly.