Loading ...
Sorry, an error occurred while loading the content.
 

Re: add a script

Expand Messages
  • Peter Odding
    Hi all, ... This seems to be dependent on some set of (as of yet unidentified) preconditions because I don t have any problems with uploading scripts to
    Message 1 of 10 , Dec 1, 2011
      Hi all,

      > Somehow Vim.org doesn't properly initialize cookies or something—I'm not
      > sure what—and every attempt at logging in just goes back to the login
      > page (or was it the home page? previously visited page?) /Sometimes/ it
      > actually succeeds for me, and I don't know why.

      This seems to be dependent on some set of (as of yet unidentified)
      preconditions because I don't have any problems with uploading scripts
      to www.vim.org even though I do so quite regularly (a couple of times a
      week on average). Nowadays I no longer upload scripts by hand; I wrote a
      Python script* that uses the mechanize library to publish new releases
      of my Vim plug-ins. This script has worked fine for me for a couple of
      months now, so it can't be that the session/cookie handling is
      fundamentally broken on Vim Online (or it's broken in a way that's
      compatible with the mechanize library :-).

      - Peter

      * https://github.com/xolox/vim-tools/blob/master/vim-plugin-release

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.