Loading ...
Sorry, an error occurred while loading the content.

Re: [Bug] make xxd and GVimExt failed in MinGW Windows

Expand Messages
  • matsushita shougo
    ... Sorry, I fixed the patch. -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are replying to.
    Message 1 of 3 , Sep 27, 2011
    • 0 Attachment
      >
      > Matsushita Shougo wrote:
      >
      >> Hi, I built Vim in Windows and found below error message.
      >>
      >> % mingw32-make.exe -f Make_ming.mak GUI=yes IME=yes MBYTE=yes ICONV=yes DEBUG=no
      >> E:/MinGW/bin/mingw32-make.exe -C xxd -f Make_cyg.mak CC=gcc
      >> mingw32-make.exe[1]: Entering directory `H:/Work/vim/src/xxd'
      >> gcc -O2 -Wall -DWIN32 -mno-cygwin -s -o xxd.exe xxd.c
      >>
      >> This behavior is : xxd(and GVimExt) is using -mno-cygwin option in
      >> MinGW environment.
      >> But, MinGW gcc(ver.4.6 or above) is deleted -mno-cygwin option.
      >> http://lists.gnu.org/archive/html/mingw-cross-env-list/2011-03/msg00119.html
      >> So appeared error message.
      >>
      >> I made this patch, and error message doesn't appear.
      >
      > It looks like you rely on making a copy of GvimExt/Make_ming.mak to
      > GvimExt/Make_cyg.mak. Before you make the change to Make_ming.mak.
      > The copied version of xxd/Make_ming.mak is included, the copy in
      > GvimExt/ not.

      Sorry, I fixed the patch.

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.