Loading ...
Sorry, an error occurred while loading the content.
 

Issue 23 in vim: matchparen matches parens in strings with syntax off despite what :help matchparen says

Expand Messages
  • vim@googlecode.com
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 23 by donaldca...@gmail.com: matchparen matches parens in strings with syntax off despite
    Message 1 of 2 , Sep 2, 2011
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 23 by donaldca...@...: matchparen matches parens in strings
      with syntax off despite what :help matchparen says
      http://code.google.com/p/vim/issues/detail?id=23

      What steps will reproduce the problem?
      1. Bring up vim with syntax off
      2. Position the cursor at the open paren of a line like (hash-table-set!
      the-table "SETUP,create,original" ");")
      3.

      What is the expected output? What do you see instead?
      Expect it to match the close paren at the end of the line. Instead, it
      matches the close paren inside the string.

      What version of the product are you using? On what operating system?
      7.3.289. Slackware Linux 13.37 64-bit

      Please provide any additional information below.



      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • vim@...
      Updates: Status: Invalid Comment #1 on issue 23 by chrisbr...@googlemail.com: matchparen matches parens in strings with syntax off despite what :help
      Message 2 of 2 , Sep 30, 2014
        Updates:
        Status: Invalid

        Comment #1 on issue 23 by chrisbr...@...: matchparen matches
        parens in strings with syntax off despite what :help matchparen says
        https://code.google.com/p/vim/issues/detail?id=23

        Documentation states explicitly, that syntax highlighting attributes are
        used. If you turn off syntax highlighting, you can't expect Vim to skip
        comments then.

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      Your message has been successfully submitted and would be delivered to recipients shortly.