Loading ...
Sorry, an error occurred while loading the content.

Re: Bug in bufexplorer plugin related to 'Show buffers/tab'

Expand Messages
  • Jeff
    Hi James, Sorry for the issue.  I will take a look at it and see if I can figure out what is going on.  As I do not have Linux running, I will hopefully be
    Message 1 of 3 , Aug 2, 2011
    • 0 Attachment
      Hi James,

      Sorry for the issue.  I will take a look at it and see if I can figure out what is going on.  As I do not have Linux running, I will hopefully be able to reproduce this under Windows 7.

      -Jeff


      From: James Vega <jamessan@...>
      To: vim_dev <vim_dev@...>
      Cc: Jeff Lanzarotta <delux256-vim@...>
      Sent: Sunday, July 31, 2011 4:23 PM
      Subject: Re: Bug in bufexplorer plugin related to 'Show buffers/tab'

      Adding bufexplorer's author to Cc.

      On Sun, Jul 31, 2011 at 07:34:11AM -0700, rehan wrote:
      > I wonder if anyone can help me with the following bug, that is
      > reducing the functionality (for me) of this great plugin.
      >
      > I am having problems with the 'Show buffers/tab' functionality.
      > Sometimes it works. Sometimes it gives errors similar to the one
      > below, especially when I try and change the sort ordering.
      >
      > Error detected while processing function
      > <SNR>17_BEToggleShowTabBuffer..<SNR>17_BEDisplayBufferList..<SNR>17_BEBuildBufferList..<SNR>17_BESortListing:
      > line    8:
      > E493: Backward range given: 4,$sort ir /\d.\{7}\zs\f\+\ze/
      >
      > To replicate the bug it is usually enough to open a bunch of files in
      > a few tabs, then hit 'T', then hit 's'.  Doesn't always break
      > immediately, but after opening and closing the bufexplorer window a
      > few times, and hitting 'T' and 's' each time it is open, it always
      > breaks sooner or later.
      >
      > A separate, but probably related problem is that sometimes when I
      > enable  'Show buffers/tab' functionality (by hitting 'T', no buffers
      > appear in the list at all.
      >
      > I am using vim 7.3 (default ubuntu 11.04 distribution install), and
      > also have plugins NERD_commenter.vim  NERD_tree.vim installed.
      >
      > Many thanks in advance for any suggestions / fixes,
      >
      > Rehan

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php


      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.