Loading ...
Sorry, an error occurred while loading the content.

[Bug] Popup menu is automatically closed when folds are visible

Expand Messages
  • Jan Christoph Ebersbach
    Hi, When I define a fold, close it and then open the popup completion menu somewhere else in the buffer, the menu appears for a short moment and is then
    Message 1 of 4 , Jul 3, 2011
    • 0 Attachment
      Hi,

      When I define a fold, close it and then open the popup completion menu
      somewhere else in the buffer, the menu appears for a short moment and
      is then removed. I can reproduce this behavior only when the fold is
      visible in the current window. And it doesn't matter whether the popup
      menu is drawn on folded text or on "regular" text.

      I also tried to set different foldmethods (manual, expr, indent). The
      results are always the same.

      Vim: GTK and console
      Version: 7.3.237
      OS: Debian Testing

      Greetings,

      Jan Christoph

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Bram Moolenaar
      ... What command do you use to get the completion menu? Any plugins or settings that matter? Try starting with vim -u NONE . -- Marriage isn t a word. It s
      Message 2 of 4 , Jul 3, 2011
      • 0 Attachment
        Jan Christoph Ebersbach wrote:

        > When I define a fold, close it and then open the popup completion menu
        > somewhere else in the buffer, the menu appears for a short moment and
        > is then removed. I can reproduce this behavior only when the fold is
        > visible in the current window. And it doesn't matter whether the popup
        > menu is drawn on folded text or on "regular" text.
        >
        > I also tried to set different foldmethods (manual, expr, indent). The
        > results are always the same.
        >
        > Vim: GTK and console
        > Version: 7.3.237
        > OS: Debian Testing

        What command do you use to get the completion menu?
        Any plugins or settings that matter? Try starting with "vim -u NONE".

        --
        Marriage isn't a word. It's a sentence.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Ben Fritz
        ... I think maybe you re seeing the same behavior documented here: http://code.google.com/p/vim/issues/detail?id=3 -- You received this message from the
        Message 3 of 4 , Jul 3, 2011
        • 0 Attachment
          On Jul 3, 11:30 am, Bram Moolenaar <B...@...> wrote:
          > Jan Christoph Ebersbach wrote:
          > > When I define a fold, close it and then open the popup completion menu
          > > somewhere else in the buffer, the menu appears for a short moment and
          > > is then removed. I can reproduce this behavior only when the fold is
          > > visible in the current window. And it doesn't matter whether the popup
          > > menu is drawn on folded text or on "regular" text.
          >
          > > I also tried to set different foldmethods (manual, expr, indent). The
          > > results are always the same.
          >
          > > Vim: GTK and console
          > > Version: 7.3.237
          > > OS: Debian Testing
          >
          > What command do you use to get the completion menu?
          > Any plugins or settings that matter?  Try starting with "vim -u NONE".
          >

          I think maybe you're seeing the same behavior documented here:

          http://code.google.com/p/vim/issues/detail?id=3

          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Jan Christoph Ebersbach
          Hi, ... Thank you for pointing me in the right direction. Actually it s a bug in my vim-orgmode plugin. Greetings, Jan Christoph -- You received this message
          Message 4 of 4 , Jul 16, 2011
          • 0 Attachment
            Hi,

            > > What command do you use to get the completion menu?
            > > Any plugins or settings that matter?  Try starting with "vim -u NONE".

            Thank you for pointing me in the right direction. Actually it's a bug
            in my vim-orgmode plugin.

            Greetings,

            Jan Christoph

            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.