Loading ...
Sorry, an error occurred while loading the content.

Default matchit.vim configuration broken for embedded stuff in HTML

Expand Messages
  • Ben Fritz
    See notes on http://vim.wikia.com/wiki/Script:39 By default, ftplugin/html.vim causes % not to work on embedded languages like javascript or CSS inside HTML.
    Message 1 of 1 , Jul 1, 2011
    • 0 Attachment
      See notes on http://vim.wikia.com/wiki/Script:39

      By default, ftplugin/html.vim causes '%' not to work on embedded
      languages like javascript or CSS inside HTML.

      This is easily fixed by modifying the b:match_words variable as set in
      the ftplugin/html.vim, to also include (:),[:],{:} or maybe the
      'matchpairs' option would also work.

      Since the html ftplugin is meant to work with matchit, I suggest that
      this be fixed.

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.