Loading ...
Sorry, an error occurred while loading the content.

Re: [BUG] `verbose set sw?' is not working in help buffer

Expand Messages
  • Bram Moolenaar
    ... [...] In help files the option values are set to sane values. Option values set in the program don t have a verbose location. -- Your fault: core dumped
    Message 1 of 4 , Jun 25, 2011
    • 0 Attachment
      ZyX wrote:

      > Consider the following script:
      >
      > vim --noplugin -u <(<<< "set sw=3D4") -c 'help :abc'
      >
      > If you type `:set sw?' at this point you will be shown just its value, but if
      > you type `<C-w>j:set sw?' you will see something like
      >
      > shiftwidth=4
      > Last set from /proc/4285/fd/11
      >
      > Same for some other options:
      [...]

      In help files the option values are set to sane values. Option values
      set in the program don't have a verbose location.

      --
      Your fault: core dumped

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • ZyX
      Reply to message «Re: [BUG] `verbose set sw? is not working in help buffer», sent 04:12:57 26 June 2011, Sunday ... If I set sw to 100 it will remain set
      Message 2 of 4 , Jun 25, 2011
      • 0 Attachment
        Reply to message «Re: [BUG] `verbose set sw?' is not working in help buffer»,
        sent 04:12:57 26 June 2011, Sunday
        by Bram Moolenaar:

        > In help files the option values are set to sane values. Option values
        > set in the program don't have a verbose location.
        If I set 'sw' to 100 it will remain set to 100 in a help buffer. It does not
        look like a `sane' value. And it is not a value defined by Vim itself, so it is
        a bug.

        Original message:
        > ZyX wrote:
        > > Consider the following script:
        > > vim --noplugin -u <(<<< "set sw=3D4") -c 'help :abc'
        > >
        > > If you type `:set sw?' at this point you will be shown just its value,
        > > but if you type `<C-w>j:set sw?' you will see something like
        > >
        > > shiftwidth=4
        > >
        > > Last set from /proc/4285/fd/11
        > >
        > > Same for some other options:
        > [...]
        >
        > In help files the option values are set to sane values. Option values
        > set in the program don't have a verbose location.
      • Ben Schmidt
        ... The local option is set from the global option, not from a file, so has no verbose location. ... will show you whence the global option was set. I wouldn t
        Message 3 of 4 , Jun 26, 2011
        • 0 Attachment
          On 26/06/11 11:15 AM, ZyX wrote:
          > Reply to message «Re: [BUG] `verbose set sw?' is not working in help buffer»,
          > sent 04:12:57 26 June 2011, Sunday
          > by Bram Moolenaar:
          >
          >> In help files the option values are set to sane values. Option values
          >> set in the program don't have a verbose location.
          > If I set 'sw' to 100 it will remain set to 100 in a help buffer. It does not
          > look like a `sane' value. And it is not a value defined by Vim itself, so it is
          > a bug.

          The local option is set from the global option, not from a file, so has
          no verbose location.

          :verbose setglobal sw?

          will show you whence the global option was set.

          I wouldn't call it a bug.

          But it could be a helpful enhancement to, when setting a local option
          from a global option, also set the verbose location.

          Ben.



          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.