Loading ...
Sorry, an error occurred while loading the content.

Issue 7 in vim: terminal resize during file recovery

Expand Messages
  • vim@googlecode.com
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 7 by michaelj...@gmail.com: terminal resize during file recovery
    Message 1 of 5 , Jun 7, 2011
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 7 by michaelj...@...: terminal resize during file recovery
      http://code.google.com/p/vim/issues/detail?id=7

      What steps will reproduce the problem?
      1. open a file with vim
      2. in a new terminal, open the same file with another vim instance
      3. resize your terminal

      What is the expected output? What do you see instead?
      I expect the text to reformat while the terminal resizes. Instead, the text
      gets garbled and never formats properly again. In some cases, the output
      remains affected after dismissing the prompt, during editing. In either
      case, the problem can sometimes be fixed by resizing the terminal window
      once again while editing.

      What version of the product are you using? On what operating system?

      $;vim --version
      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Nov 16 2010 17:05:25)
      Included patches: 1-56
      Modified by <bugzilla@...>
      Compiled by <bugzilla@...>
      Huge version without GUI. Features included (+) or not (-):
      +arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset +cindent
      -clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info
      +comments
      +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con +diff
      +digraphs
      -dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path
      +find_in_path +float +folding -footer +fork() +gettext -hangul_input +iconv
      +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent
      +listcmds +localmap -lua +menu +mksession +modify_fname +mouse -mouseshape
      +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm -mouse_sysmouse
      +mouse_xterm +multi_byte +multi_lang -mzscheme +netbeans_intg -osfiletype
      +path_extra +perl +persistent_undo +postscript +printer +profile +python
      -python3 +quickfix +reltime +rightleft +ruby +scrollbind +signs +smartindent
      -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary
      +tag_old_static -tag_any_white -tcl +terminfo +termresponse +textobjects
      +title
      -toolbar +user_commands +vertsplit +virtualedit +visual +visualextra
      +viminfo
      +vreplace +wildignore +wildmenu +windows +writebackup -X11 -xfontset -xim
      -xsmp
      -xterm_clipboard -xterm_save
      system vimrc file: "/etc/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      fall-back for $VIM: "/etc"
      f-b for $VIMRUNTIME: "/usr/share/vim/vim73"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -O2 -g -pipe -Wall
      -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64
      -mtune=generic -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=1
      Linking: gcc -L. -rdynamic -Wl,-export-dynamic -Wl,--enable-new-dtags
      -Wl,-rpath,/usr/lib64/perl5/CORE -L/usr/local/lib -Wl,--as-needed -o
      vim -lm -lnsl -lselinux -lncurses -lacl -lattr -lgpm -ldl
      -Wl,--enable-new-dtags -Wl,-rpath,/usr/lib64/perl5/CORE -fstack-protector
      -L/usr/lib64/perl5/CORE -lperl -lresolv -lnsl -ldl -lm -lcrypt -lutil
      -lpthread -lc -L/usr/lib64/python2.7/config -lpython2.7 -lpthread -ldl
      -lutil -lm -Xlinker -export-dynamic -lruby -lpthread -lrt -ldl -lcrypt -lm


      Fedora 14, XFCE window manager, and xfce4-terminal


      Please provide any additional information below.



      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Gary Johnson
      ... Resizing the terminal while running vim works fine with Vim 7.2.148 and 7.3.189, GNOME Terminal 2.26.3.1, KDE 4.3.1 and Fedora 11. It has worked fine for
      Message 2 of 5 , Jun 7, 2011
      • 0 Attachment
        On 2011-06-07, vim@... wrote:
        > Status: New
        > Owner: ----
        > Labels: Type-Defect Priority-Medium
        >
        > New issue 7 by michaelj...@...: terminal resize during file recovery
        > http://code.google.com/p/vim/issues/detail?id=7
        >
        > What steps will reproduce the problem?
        > 1. open a file with vim
        > 2. in a new terminal, open the same file with another vim instance
        > 3. resize your terminal
        >
        > What is the expected output? What do you see instead?
        > I expect the text to reformat while the terminal resizes. Instead, the text
        > gets garbled and never formats properly again. In some cases, the output
        > remains affected after dismissing the prompt, during editing. In either
        > case, the problem can sometimes be fixed by resizing the terminal window
        > once again while editing.

        Resizing the terminal while running vim works fine with Vim 7.2.148
        and 7.3.189, GNOME Terminal 2.26.3.1, KDE 4.3.1 and Fedora 11. It
        has worked fine for as long as I can remember in xterm on a variety
        of Unixes.

        > What version of the product are you using? On what operating system?
        >
        > $;vim --version
        > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Nov 16 2010 17:05:25)
        > Included patches: 1-56
        > Modified by <bugzilla@...>
        > Compiled by <bugzilla@...>
        > Huge version without GUI. Features included (+) or not (-):

        ...

        > Fedora 14, XFCE window manager, and xfce4-terminal

        This sort of thing happens when the terminal doesn't send SIGWINCH
        to the application as it should so that vim doesn't know how many
        lines and columns the terminal has. I suspect a problem with XFCE
        or xfce4-terminal, but I don't have access to an XFCE system at the
        moment.

        What happens when you execute

        :set columns? lines?

        before and after resizing? If you resize the terminal with vim
        running in it, then exit and restart vim, does the display look
        correct and does

        :set columns? lines?

        show the terminal's new size?

        Regards,
        Gary

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • James Vega
        ... Did you try this in the specific scenario of a swap file recovery prompt? That was the described scenario and I can reproduce the behavior. -- James GPG
        Message 3 of 5 , Jun 7, 2011
        • 0 Attachment
          On Tue, Jun 07, 2011 at 02:00:01PM -0700, Gary Johnson wrote:
          > On 2011-06-07, vim@... wrote:
          > > Status: New
          > > Owner: ----
          > > Labels: Type-Defect Priority-Medium
          > >
          > > New issue 7 by michaelj...@...: terminal resize during file recovery
          > > http://code.google.com/p/vim/issues/detail?id=7
          > >
          > > What steps will reproduce the problem?
          > > 1. open a file with vim
          > > 2. in a new terminal, open the same file with another vim instance
          > > 3. resize your terminal
          > >
          > > What is the expected output? What do you see instead?
          > > I expect the text to reformat while the terminal resizes. Instead, the text
          > > gets garbled and never formats properly again. In some cases, the output
          > > remains affected after dismissing the prompt, during editing. In either
          > > case, the problem can sometimes be fixed by resizing the terminal window
          > > once again while editing.
          >
          > Resizing the terminal while running vim works fine with Vim 7.2.148
          > and 7.3.189, GNOME Terminal 2.26.3.1, KDE 4.3.1 and Fedora 11. It
          > has worked fine for as long as I can remember in xterm on a variety
          > of Unixes.

          Did you try this in the specific scenario of a swap file recovery
          prompt? That was the described scenario and I can reproduce the
          behavior.

          --
          James
          GPG Key: 1024D/61326D40 2003-09-02 James Vega <jamessan@...>
        • Gary Johnson
          ... No, but I just did. The display is corrupted while the prompt is displayed, but there are no lasting effects. Once the prompt is dismissed with either
          Message 4 of 5 , Jun 7, 2011
          • 0 Attachment
            On 2011-06-07, James Vega wrote:
            > On Tue, Jun 07, 2011 at 02:00:01PM -0700, Gary Johnson wrote:
            > > On 2011-06-07, vim@... wrote:
            > > > Status: New
            > > > Owner: ----
            > > > Labels: Type-Defect Priority-Medium
            > > >
            > > > New issue 7 by michaelj...@...: terminal resize during file recovery
            > > > http://code.google.com/p/vim/issues/detail?id=7
            > > >
            > > > What steps will reproduce the problem?
            > > > 1. open a file with vim
            > > > 2. in a new terminal, open the same file with another vim instance
            > > > 3. resize your terminal
            > > >
            > > > What is the expected output? What do you see instead?
            > > > I expect the text to reformat while the terminal resizes. Instead, the text
            > > > gets garbled and never formats properly again. In some cases, the output
            > > > remains affected after dismissing the prompt, during editing. In either
            > > > case, the problem can sometimes be fixed by resizing the terminal window
            > > > once again while editing.
            > >
            > > Resizing the terminal while running vim works fine with Vim 7.2.148
            > > and 7.3.189, GNOME Terminal 2.26.3.1, KDE 4.3.1 and Fedora 11. It
            > > has worked fine for as long as I can remember in xterm on a variety
            > > of Unixes.
            >
            > Did you try this in the specific scenario of a swap file recovery
            > prompt? That was the described scenario and I can reproduce the
            > behavior.

            No, but I just did. The display is corrupted while the prompt is
            displayed, but there are no lasting effects. Once the prompt is
            dismissed with either 'e' or 'o', the display appears fine to me.

            I suppose the behavior while the prompt is present could be
            considered a bug, but I would classify it as a Well Don't Do That
            Then.

            Regards,
            Gary

            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • vim@...
            Comment #1 on issue 7 by chrisbr...@googlemail.com: terminal resize during file recovery https://code.google.com/p/vim/issues/detail?id=7 Is this still an
            Message 5 of 5 , Sep 30, 2014
            • 0 Attachment
              Comment #1 on issue 7 by chrisbr...@...: terminal resize during
              file recovery
              https://code.google.com/p/vim/issues/detail?id=7

              Is this still an issue? If I resize the terminal when Vim is displaying the
              Attention message, I see, that Vim is correctly resizing at least the
              dialog.

              --
              You received this message because this project is configured to send all
              issue notifications to this address.
              You may adjust your notification preferences at:
              https://code.google.com/hosting/settings

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            Your message has been successfully submitted and would be delivered to recipients shortly.