Loading ...
Sorry, an error occurred while loading the content.

Re: Can't reproduce - 'lines' is 25 and 'scrolloff' is 12

Expand Messages
  • sc
    ... i confirm this: for me j moves one line in the above circumstance sc -- You received this message from the vim_dev maillist. Do not top-post! Type your
    Message 1 of 9 , May 2, 2011
    • 0 Attachment
      On Monday, May 02, 2011 20:02:03 Jean-Rene David wrote:

      > Can someone reproduce this item from the todo list:

      > When 'lines' is 25 and 'scrolloff' is 12, "j" scrolls zero or
      > two lines instead of one. (Constantin Pan, 2010 Sep 10)

      > I can't. And I didn't find a message on either mailing lists
      > on that subject around that date.

      i confirm this: for me j moves one line in the above
      circumstance

      sc

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Ben Schmidt
      ... Me too. That s another one that s been fixed but not removed, then, it seems. Ben. -- You received this message from the vim_dev maillist. Do not
      Message 2 of 9 , May 2, 2011
      • 0 Attachment
        On 3/05/11 1:04 PM, sc wrote:
        > On Monday, May 02, 2011 20:02:03 Jean-Rene David wrote:
        >
        >> Can someone reproduce this item from the todo list:
        >
        >> When 'lines' is 25 and 'scrolloff' is 12, "j" scrolls zero or
        >> two lines instead of one. (Constantin Pan, 2010 Sep 10)
        >
        >> I can't. And I didn't find a message on either mailing lists
        >> on that subject around that date.
        >
        > i confirm this: for me j moves one line in the above
        > circumstance

        Me too. That's another one that's been fixed but not removed, then, it seems.

        Ben.


        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Lech Lorens
        ... I can reproduce it. However, I need to set ls to 0 for the problem to show. -- Cheers, Lech -- You received this message from the vim_dev maillist. Do
        Message 3 of 9 , May 3, 2011
        • 0 Attachment
          On 03-May-2011 Jean-Rene David <jrdavid.ml@...> wrote:
          > Can someone reproduce this item from the todo list:
          >
          > When 'lines' is 25 and 'scrolloff' is 12, "j" scrolls zero or two lines
          > instead of one. (Constantin Pan, 2010 Sep 10)
          >
          > I can't. And I didn't find a message on either mailing lists on that
          > subject around that date.

          I can reproduce it. However, I need to set 'ls' to 0 for the problem to
          show.

          --
          Cheers,
          Lech

          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Jean-Rene David
          ... Still no luck for me, even with ls set to 0. What version of vim are you using? -- JR -- You received this message from the vim_dev maillist. Do not
          Message 4 of 9 , May 3, 2011
          • 0 Attachment
            * Lech Lorens [2011.05.03 10:00]:
            > On 03-May-2011 Jean-Rene David <jrdavid.ml@...> wrote:
            > > Can someone reproduce this item from the todo list:
            > >
            > > When 'lines' is 25 and 'scrolloff' is 12, "j" scrolls zero or two lines
            > > instead of one. (Constantin Pan, 2010 Sep 10)
            > >
            > > I can't. And I didn't find a message on either mailing lists on that
            > > subject around that date.
            >
            > I can reproduce it. However, I need to set 'ls' to 0 for the problem to
            > show.

            Still no luck for me, even with 'ls' set to 0. What version of vim are
            you using?

            --
            JR

            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Ben Schmidt
            ... I see the behaviour now, with 7.3.161. Ben. -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you
            Message 5 of 9 , May 3, 2011
            • 0 Attachment
              On 4/05/11 12:11 AM, Jean-Rene David wrote:
              > * Lech Lorens [2011.05.03 10:00]:
              >> On 03-May-2011 Jean-Rene David<jrdavid.ml@...> wrote:
              >>> Can someone reproduce this item from the todo list:
              >>>
              >>> When 'lines' is 25 and 'scrolloff' is 12, "j" scrolls zero or two lines
              >>> instead of one. (Constantin Pan, 2010 Sep 10)
              >>>
              >>> I can't. And I didn't find a message on either mailing lists on that
              >>> subject around that date.
              >>
              >> I can reproduce it. However, I need to set 'ls' to 0 for the problem to
              >> show.
              >
              > Still no luck for me, even with 'ls' set to 0. What version of vim are
              > you using?

              I see the behaviour now, with 7.3.161.

              Ben.



              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Jürgen Krämer
              Hi, ... you might also have to adjust cmdheight by 1. For me this happens with set lines=25 scrolloff=12 laststatus=0 cmdheight=1 on Windows with GVim
              Message 6 of 9 , May 3, 2011
              • 0 Attachment
                Hi,

                Jean-Rene David wrote:
                > * Lech Lorens [2011.05.03 10:00]:
                >> On 03-May-2011 Jean-Rene David <jrdavid.ml@...> wrote:
                >>> Can someone reproduce this item from the todo list:
                >>>
                >>> When 'lines' is 25 and 'scrolloff' is 12, "j" scrolls zero or two lines
                >>> instead of one. (Constantin Pan, 2010 Sep 10)
                >>>
                >>> I can't. And I didn't find a message on either mailing lists on that
                >>> subject around that date.
                >>
                >> I can reproduce it. However, I need to set 'ls' to 0 for the problem to
                >> show.
                >
                > Still no luck for me, even with 'ls' set to 0. What version of vim are
                > you using?

                you might also have to adjust 'cmdheight' by 1. For me this happens with

                set lines=25 scrolloff=12 laststatus=0 cmdheight=1

                on Windows with GVim 7.3.170. It also happens with

                set lines=26 scrolloff=12 laststatus=2 cmdheight=1

                Seems it always happens if there is only one window and if

                2 * &scrolloff + &cmdheight + (&laststatus == 2 ? 1 : 0) == &lines

                because

                set lines=25 scrolloff=10 laststatus=2 cmdheight=4

                and

                set lines=23 scrolloff=10 laststatus=0 cmdheight=3

                show the same bug.

                Regards,
                Jürgen

                --
                Sometimes I think the surest sign that intelligent life exists elsewhere
                in the universe is that none of it has tried to contact us. (Calvin)

                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • sc
                ... ok i can make it jump with these settings, but it isn t that j is failing to advance through the file, it s that the scroll offset moves by reading seq
                Message 7 of 9 , May 3, 2011
                • 0 Attachment
                  On Tuesday, May 03, 2011 09:31:48 Jürgen Krämer wrote:

                  > Hi,

                  > Jean-Rene David wrote:
                  > > * Lech Lorens [2011.05.03 10:00]:
                  > >> On 03-May-2011 Jean-Rene David <jrdavid.ml@...> wrote:
                  > >>> Can someone reproduce this item from the todo list:
                  > >>>
                  > >>> When 'lines' is 25 and 'scrolloff' is 12, "j" scrolls zero
                  > >>> or two lines instead of one. (Constantin Pan, 2010 Sep
                  > >>> 10)
                  > >>>
                  > >>> I can't. And I didn't find a message on either mailing
                  > >>> lists on that subject around that date.
                  > >>
                  > >> I can reproduce it. However, I need to set 'ls' to 0 for
                  > >> the problem to show.
                  > >
                  > > Still no luck for me, even with 'ls' set to 0. What version
                  > > of vim are you using?

                  > you might also have to adjust 'cmdheight' by 1. For me this
                  > happens with

                  > set lines=25 scrolloff=12 laststatus=0 cmdheight=1

                  > on Windows with GVim 7.3.170. It also happens with

                  > set lines=26 scrolloff=12 laststatus=2 cmdheight=1

                  > Seems it always happens if there is only one window and if

                  > 2 * &scrolloff + &cmdheight + (&laststatus == 2 ? 1 : 0) ==
                  > &lines

                  > because

                  > set lines=25 scrolloff=10 laststatus=2 cmdheight=4

                  > and

                  > set lines=23 scrolloff=10 laststatus=0 cmdheight=3

                  > show the same bug.

                  ok i can make it jump with these settings, but it isn't that
                  'j' is failing to advance through the file, it's that the
                  scroll offset moves

                  by reading seq into an empty module with

                  :0r!seq 100

                  and scrolling with 'j', if you have 'cursorline' on you can
                  see current line moving up and down -- slow it down and you'll
                  see it is in fact moving through the file one line at a time
                  as it should, but the scrolloffset is not keeping current line
                  in the same place as one might expect

                  sc

                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Bram Moolenaar
                  ... - CVS sux, men don t like commitment /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net /// sponsor Vim, vote for features
                  Message 8 of 9 , May 5, 2011
                  • 0 Attachment
                    Jean-Rene David wrote:

                    > Can someone reproduce this item from the todo list:
                    >
                    > When 'lines' is 25 and 'scrolloff' is 12, "j" scrolls zero or two lines
                    > instead of one. (Constantin Pan, 2010 Sep 10)
                    >
                    > I can't. And I didn't find a message on either mailing lists on that
                    > subject around that date.

                    This is the description I received:

                    > Hello. I've found a weird behavior of vim when scrolling down. If you
                    > set the 'scrolloff=X' and window height to (2*X+1), then on 'j' Vim
                    > scrolls down in a broken manner (two lines at once, then zero lines,
                    > then two again). The cursor acts correctly though, moving down one
                    > line per 'j'. See the screenshots joined in the attached gif.
                    >
                    > How to reproduce the bug (X is here 12, but the bug evinces itself on
                    > any value of X):
                    >
                    > 1. Set terminal height to (2*X+1) lines, i.e. 25. So, that:
                    >
                    > $ echo $LINES
                    > 25
                    >
                    > 2. Run Vim with scrolloff=X.
                    >
                    > $ hexdump /dev/urandom | head -100 | vim "+set scrolloff=12" "+set number" -
                    >
                    > 3. Press 'j' to move the cursor down until the scrolling starts. Watch
                    > line numbers on the left increasing by 2 on every second 'j'.
                    >
                    > Scrolling up works fine. GVim acts likewise. I've also tried on
                    > another machine (with Debian), and the bug shows up there.

                    -
                    CVS sux, men don't like commitment

                    /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                    /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                    \\\ an exciting new programming language -- http://www.Zimbu.org ///
                    \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  Your message has been successfully submitted and would be delivered to recipients shortly.