Loading ...
Sorry, an error occurred while loading the content.

'wildmenu with problems

Expand Messages
  • Axel
    Entering :echo &w[tab] in 7.3 138 is giving me - instead of the first option starting with w - the following wildmenu expansion: [1] [No Name] Hitting [tab]
    Message 1 of 5 , Mar 8 11:31 PM
    • 0 Attachment
      Entering :echo &w[tab] in 7.3 138 is giving me - instead of the first
      option starting with "w" - the following wildmenu expansion:

      [1] [No Name]

      Hitting [tab] again will display the SECOND possible extension,
      "weirdinvert".

      Settings here are:

      wildchar=[Tab]
      wildcharem=0
      wildignore=*.a,*.dll,*.exe,*.o
      wildignorecase=0
      wildmenu=1
      wildmode=full
      wildoptions=

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • John Little
      ... 7.3.135, I get warn , which I imagine you should be. HTH, John -- You received this message from the vim_dev maillist. Do not top-post! Type your reply
      Message 2 of 5 , Mar 9 2:20 PM
      • 0 Attachment
        On Mar 9, 8:31 pm, Axel <axel.ben...@...> wrote:
        > Entering :echo &w[tab] in 7.3 138 is giving me - instead of the first
        > option starting with "w" - the following wildmenu expansion:
        >
        > [1] [No Name]

        7.3.135, I get "warn", which I imagine you should be.

        HTH, John

        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Ben Schmidt
        ... Also works for me in 7.3.125 and 7.3.138. Maybe a plugin is causing this? Ben. -- You received this message from the vim_dev maillist. Do not top-post!
        Message 3 of 5 , Mar 9 2:37 PM
        • 0 Attachment
          On 10/03/11 9:20 AM, John Little wrote:
          > On Mar 9, 8:31 pm, Axel<axel.ben...@...> wrote:
          >> Entering :echo&w[tab] in 7.3 138 is giving me - instead of the first
          >> option starting with "w" - the following wildmenu expansion:
          >>
          >> [1] [No Name]
          >
          > 7.3.135, I get "warn", which I imagine you should be.

          Also works for me in 7.3.125 and 7.3.138.

          Maybe a plugin is causing this?

          Ben.



          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Axel
          Same reason as for the :version/:set all error: unsetting lazyredraw fixes the error. Axel ... -- You received this message from the vim_dev maillist. Do not
          Message 4 of 5 , Mar 11 5:16 AM
          • 0 Attachment
            Same reason as for the :version/:set all error: unsetting lazyredraw
            fixes the error.

            Axel

            On Mar 9, 11:37 pm, Ben Schmidt <mail_ben_schm...@...> wrote:
            > On 10/03/11 9:20 AM, John Little wrote:
            >
            > > On Mar 9, 8:31 pm, Axel<axel.ben...@...>  wrote:
            > >> Entering :echo&w[tab] in 7.3 138 is giving me - instead of the first
            > >> option starting with "w" - the following wildmenu expansion:
            >
            > >> [1] [No Name]
            >
            > > 7.3.135, I get "warn", which I imagine you should be.
            >
            > Also works for me in 7.3.125 and 7.3.138.
            >
            > Maybe a plugin is causing this?
            >
            > Ben.

            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • John Little
            ... If I put set lazyredraw in my .vimrc, I still get warn , also with vim -u NONE -c set nocp lazyredraw . Regards, John -- You received this message from
            Message 5 of 5 , Mar 11 10:58 PM
            • 0 Attachment
              On Mar 12, 2:16 am, Axel <axel.ben...@...> wrote:
              > Same reason as for the :version/:set all error: unsetting lazyredraw
              > fixes the error.

              If I put set lazyredraw in my .vimrc, I still get "warn", also with
              vim -u NONE -c "set nocp lazyredraw".

              Regards, John

              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.